Assigning a VLAN to a LAN Port

As of Firmware 6.3, users can assign a specific VLAN to a LAN Port. Here are the steps to use this feature:

NB: Not all models support per-port VLAN support. See our full model comparison for details.

UPDATE: Per-port VLAN support added for a number of models in firmware 7.1.0:

Balance: 305, 380, 580,710, 1350, 2500
MediaFast​: 500, 750

UPDATE 2: Per-port VLAN support has also been added to the MAX Transit en BR1 MK2 in firmware 7.0:

Enable VLAN

  • Go to “Network > Interfaces > LAN”
  • Click the “?” as the screenshot below, then you can click the link to enable the VLAN feature.

  • VLAN is enabled.

Designate Trunk Type and VLAN

Once VLAN has been enabled, navigate to Network > LAN > Port Settings.
To configure a VLAN Trunk, click the pull down menus under the VLAN column to select the desired VLAN.

To configure a port-based VLAN, click the pull down menus under Port Type and select Access before selecting your VLAN.


Does this work on the Surf Soho router too or just some of the Balance routers?

Port base VLAN is available for Surf SOHO.

More models will support Port Base VLAN coming soon for firmware 7. For more information, please refer to the firmware 7 download link & release note:

1 Like

This seems to work great on Balance 380s and Balance Ones, but I have four Balance 20s that I’m trying to assign Trunk ports with VLAN = “Any” and the option is missing - it only allows me to select tagged VLANs, and not “Any” or the untagged VLAN.

Am I missing something?

Untagged LAN is not available in VLAN Trunk mode with the following models:

Balance 20
Balance 30/30 LTE
Balance 50/50 LTE

Custom VLAN is not available in VLAN Trunk mode for:

Balance 305, 380 or above
MediaFast 500/750

1 Like

Hi Ron -

Can you explain why? This was available in an earlier firmware for the Bal 20, and now it’s not.

We have Peplink devices at 10 sites across the globe, each with one or more Pepwave APs. Now that we want to put our WLAN on VLAN 3, four of my sites can’t see the untagged LAN from Wi-Fi.

I’ve never seen anything with a trunk mode that doesn’t let you trunk untagged traffic…


I know this is an old thread but I don’t want to make a new one as I think the answer is on the forums somewhere, I just can’t find it.

I have tried to assign an Access VLAN to the ‘untagged’ lan but I lose all contact with the router. I already have wifi turned off and none of the ports allow access to my laptop, the one I used to make the changes.

I have to reset the router and change the setting so that there are only 3 Access VLAN ports and leave the ‘untagged’ port alone.

I assume it has something to do with the ‘untagged’ port being the IP address of the router and also being port one?

My problem is I’m afraid to use Port One now because I believe it can see every other device (maybe this is necessary for the router IP address port) so can anyone please give me any advice how to secure the ‘untagged’ port so inter vlan is disabled and it can’t see any other devices apart from obviously the WAN port I imagine?

Although I did notice in the WAN port settings there is a VLAN option but I am not even going to try messing with that when I can’t configure the LAN ports correctly.

Why would a WAN port be VLAN if the nature of WAN means it has to communicate with every device connected to the router?

Thanks for any advice.

Kind regards.