Firmware 8.1.2 Now in GA

Firmware 8.1.2 is now ready for production environments.

To get yours, simply head over to Firmware download page and download for your device. Alternatively, you can update via InControl 2 Firmware Management.

Release Notes


I tried 8.1.2 on a FusionHub appliance running on Amazon EC2. After about 7-8 hours of use, it chokes and stops routing VPN traffic. Only a stop and start of the EC2 instance brings it back up. Rolled back to 8.1.1 and the reliability has been good.

1 Like

Good news! Thanks to the Peplink team. :+1:t2:
@Lai : Could you please explain to me, where I can configure these 2 new settings (click path unclear)?

  • [DHCP WAN] Added: Management IP Address for

  • [System] Added support for Service Provider Configuration via DHCP Option

@thebigbeav, By the VPN you meant Speedfusion or Remote User access stopped working ?
Please, submit a support ticket with Diagnostic file from your FusionHUB. We will check if anything can be found in the logs.

Thank you.



Management IP Address can be enabled by clicking on the “?” next to Hostname in WAN settings:

Service Provider Configuration via DHCP Option is only available at this moment for the partners or users who need to load a lot of devices with the same configuration before sending them to the field.


@RolandasR : Thank you! So that is intended to configure an external company Management Server’s public IP address (to avoid access from somewhere else)? Does this block incontrol servers then?

I was about to upgrade mine, standing by pending further info, thanks!

OK. I give up. What is a “Management IP Address for DHCP WAN”? Its not explained in the Release Notes and its not even mentioned in the 8.1.2 User Guide.


I installed this and immediately experienced the inability to connect to most of my WiFi network. After about a day troubleshooting this, the problem was isolated to the fact this revision does not work with VLANs. Rolling back to the previous 8.1.1 does not fix the problem. My guest, security and camera systems are down because of this. This is as serious a failure as it gets. What assistance does Peplink offer in fixing this?


We have some reference here :

It’s more to the IP address to manage the gateway device that running using different IP network for the management. :wink:

1 Like


Can you please open a ticket for us to further check on this ? Please ATTN the ticket to sitloongs :wink:

1 Like

What device type…and what AP(s)?

i opened a ticket i have no cellular connectivity at all this is very frustating

This upgrade did not work out too well, at least in one instance:

An HD2 IP67 LTEA is located in a remote area, connected only by cellular (Verizon). It is connected to a B380 hub (SpeedFusion) and handles local servers, devices and Pepwave access points…

History & problem:

The device has been working flawlessly with FW 8.1.1.

An upgrade to FW 8.1.2 GA seemed to succeed, but some hours after the upgrade we observed that the unit no longer responded to WebUI logins (be it from WAN, SF or LAN), nor to UI access from InControl, nor did it report to InControl, nor did it respond to speed fusion speed tests from the B380 hub (the error there being “Error: Cannot connect to remote server at port 5000”) .

The response to a connection to the login URL (via a public IP address, the speedfusion connection or from a server on the LAN) is “System error” after the URL is directed from the base URL ( to the usual landing path (

The unit continues to route correctly, and remote access via SF to device-local servers continues to function.

We have no direct, physical access to the device, so a local reboot or similar attempts to kick it back alive are not available to us.

With IC2 connection and WebUI connections both inoperative, we cannot get a diagnostic report nor turn on RA.

I can provide sample screenshots demonstrating things that work (the core functionality of routing and speedfusion connectivity) and those that don’t (IC2, WebUI via LAN, WAN, SF).


Ticket submitted: 21050466

1 Like

I have configured my Peplink Balance One Router via System Security settings to listen on HTTPS only using a specific Web Admin Port (e.g. 9000).

When I am using the Router’s URL only with HTTP in the browser (http://IP.IP.IP.IP:9000 instead of https://IP.IP.IP.IP:9000), I am receiving the following error message:

400 Bad Request

The plain HTTP request was sent to HTTPS port

I’d like to suggest to fix this by auto forwarding to HTTPs protocol.

@ckirch : mainly it was done for Starlink app dish management as described here
It allows to access external network using configured IP address instead of the main WAN IP.
It is not related to the Incontrol servers as the default gateway is being used for that matter.


I read that item and it raised more questions than it answered. To be fair, that item starts in the middle of the topic, not the beginning.
Is this feature is for Starlink only?
If not, what problem is it solving?

Hi. In the release notes I see this:

I think this is the feature for which you are looking.

It is indeed for Starlink. Possibly could apply to other gateway manufacturers who don’t use standard IP of but have a custom mobile app that allows you to manage the device.

My understanding of it.

I installed 8.1.2 and it does not seem to be stable. I get random reboots and my wifi has dropped to nothing. I have a balance one. How do find 8.1.1 to downgrade?