Firmware 8.1.2 Now in GA

@Wayne_Goldstein, I am curious whether the problem will happen to the previous firmware version. You may reboot your Balance One to the previous firmware at System > Reboot.

1 Like

@ckirch, that’s been considered and the improvement has been registered in the wishlist :wink: We should see it in the next major release :crossed_fingers:

2 Likes

I found it by searching for archive. I uploaded the previous version and all issues went away. I suggest that there is a problem with the 8.1.2

Tried to upgrade last night and what a disaster. Half my Wifi devices never reconnected. Another 1/4 were flapping up and down. I know this because I monitor my smart home devices with Nagios and I could see them going up and down. Tried to reboot, adjust broadcast settings, to no avail.

I rolled back and the 1/4 that were flapping came back, but the other half are still down… I dread having to go around reconnecting all these devices again.

I’m curious what happened… did the firmware upgrade somehow change the SSIDs (like the MAC associated with them) and that’s why the devices couldn’t reconnect is because technically it changed despite the name and keys being the same?

Can someone please look into this?

@mamc
What devices are involved?

1 Like

Almost all the devices having issues are smarthome products like light switches/simmers, smart plugs, wifi cameras, etc.

All my computers, game systems, servers, etc - seem to connect just fine.

Not sure if it’s due to the fact that the smarthome products use cheap 2.4Ghz wifi adapters and the issues are related only to 2.4Ghz band? Or if it’s something unique about how those devices connect.

I actually see them trying to connect in the “Wireless Clients” page, but it’s just not happening.

None of my 5Ghz devices seem to have any issues connecting. I’m very perplexed.

Thanks, which pepwave device are you using as the AP?
What’s the signal strength of the devices?
Any other Ap’s using the same channel in the area?

The signal strength is between 40-70. I’m using the Pepwave Soho Mk3.

I’m in a suburban area and do have some competing APs but nothing terrible.

I wasn’t having any issues until the upgrade and then bam all these devices offline.

I’m working with support and they said they see some corruption in the diagnostic report but what type I do not know.

My biggest fear is that I will factory reset the device and then my backed up configuration files will have been what was corrupted either from a while back or from due to the upgrade.

I have 5 different SSIDs and 10 vlans, 50ish DNS records and DHCP reservations, and a lot of firewall rules. If I had to start from scratch it would be incredibly demoralizing.

It would be great to know how many others are having a similar issue. One person in this thread already reported all his IoT devices going offline and no reconnecting. It would be assuring to know that a factory reset (as suggested by support) + restoration of config file helped resolve his issue.

My issues are with the same machine and are similar to yours. A factory reset and configuration restore did not help my issues, and neither did a factory reset and manual restore of each setting.

1 Like

Surf SOHO MK3 being used as an AP.

I opened a ticket and Rokas has been taking care of it. My apologies, I forgot to ATTN sitloongs. Any and all help very much appreciated.

Did your configuration actually restore properly? I’m willing to try it myself but I am worried I will have to hand enter all the configs in all over again. I’d probably start all over with new hardware at that point :confused:

I’m really worried that this firmware upgrade did something irreversible like update microcode that permanently breaks Wifi.

The saved configuration seemed to restore properly, but the same problems stayed. I then tried the factory reset and manually restored the settings, but again, the same problems, (lack of VLANs), stayed. My problems are a bit different than yours in that my VLANs originate from a pfsense firewall upstream, and the Surf SOHO is used only as an AP and switch.

Man, I am still back on 8.1.0 because I wasn’t comfortable with the issues in 8.1.1. I don’t see firmware upgrades in my future anytime soon. :neutral_face:

If I could roll that far back I would, but I dont have working configs from that far back. Plus, rolling back to 8.1.1 with a pre-upgrade config file - didn’t even help :frowning:

I’d have stayed on 8.1.0 but there was that issue w/ DNS/domain based FW rules causing insane CPU usage.

@WiFiHiFi

Can you please share the ticket number here ?

1 Like

Ticket 21050460

Thank you.

1 Like

I am also having the same problem that WiFiHiFi is having after updating the Surf SOHO MK3. Many of my cameras and cheap IOT devices wont connect to the 2.4GHz band SSID. I bought a second wifi router from a different company to A/B compare the two, and that other router works fine connecting to all the devices. Rolling the MK3 firmware back to 8.1.1 does not help. This is definitely something that happened in the recent firmware upgrade.

1 Like

I may have an explanation.

The re-setting of the Wi-Fi often causes a different MAC address to be assigned to existing SSIDs. A reset is caused by rebooting (of course) but also by any change to the SSIDs, such as adding one or disabling one.

You don’t see this in the router, the firmware does not expose the MAC address assigned to each SSID. I saw it using a Wi-Fi scanner.

For some devices, the change in MAC address does not matter, they re-connect just fine. However, I had an Internet radio that would not re-connect on its own, it had to be power cycled. This despite the fact that there were no changes to the SSID it connected to, other than a new MAC address.

To be clear, I saw this on firmware 8.1.1, so it is not specific to 8.1.2.

I have no explanation for why this happens but we just saw in the Frag Attacks that coders make lots of mistakes in dealing with Wi-Fi. One of the dozen Frag Attack bugs had to do with devices not clearing out saved data when a device disconnects.

I would bet a nickel that if the SSID MAC address never changed, there would be no problems. Probably not Peplink’s fault, but hopefully they can fix it anyway.

1 Like