Firmware 8.1.2 Now in GA

Very good possibility that many vendors are reusing third party libraries in their implementations.

Bug in base libs will affect 1000’s of implementations.

Wonder if Peplink’s firmware is completely built from the ground up or makes use of various low level libraries.

Yup, all but guaranteed.

If my guess is right, then the question becomes if and when Peplink changed how they assign MAC addresses to SSIDs.

I have an update. I have spent the last 48 hours of my life teaching myself Wifi engineering. I knew skipping the WLAN section of Cisco certification would bite me in the ass someday. 13 years later and it’s caught up to me.

No matter WHAT I do, I cannot get the majority of smarthome devices like cameras, light switch/dimmers, oil tank monitors, etc to work on the 2.4Ghz band. ANY 5GHz devices work - NO PROBLEM. Not sure if its because they’re so new they negotiate better in general or because of the 2.4GHz radio…?

Anyways, I went as far as to buy a cheapo router to test with. I disabled by Smarthome SSID and recreated it on the cheapo router w/ same password…within SECONDS, all the devices came back online and registered to the cheapo router.

I thought OK great, they came alive, now maybe they will fail back? NO! Soon as I took the cheapo router offline and enabled that SSID on Pepwave they again fell dead in the water.

I even tried creating new test SSIDs on the Pepwave and factory resetting the smart home devices and joining them to the new temp/test SSIDs - they still will NOT connect!

I busted out my wife’s Mac and started sniffing the Wifi traffic (cant do it on my Lenovo b/c of Intel device + Windows OS).

What I am seeing is that the Peplink device is not sending ACKs back to devices after the Probe Request. It sends a Prob Response… in fact it sends dozens. But the next step (authentication) simply never happens.

When I hook up the cheapo router and sniff the traffic, I see it sending ACKs after the Probe Request, then sending a Probe Response, then the device sends its own ACK in response to the Probe Response. Then they move to the next step in negotiation - authentication. Then bam successful connection.

I tried to compare the headers and other attributes being passed in the beacons and Probe Responses as well, but no luck because I don’t really know what I’m supposed to be looking at.

Also, there is little to no good documentation on Wifi on the 'net. Just a bunch of outdated Cisco CCNP material and theoretical docs on Wifi during the WEP era in the 90’s (yuck).

I would be happy to send my packet captures to support, but the gentleman who has my ticket assigned has not responded yet.

I even ordered a replacement unit to see if that fixes the issue. As I have said before on here, rolling back the firmware did not fix the issue which leads me to believe either some permanent change was made OR perhaps this issue existing in 8.1.1 but did not completely manifest on my system until 8.1.2. That might explain why rolling back to 8.1.1 did not fix the issue.

Can someone PLEASE help? I will take time out of my day and work with you to troubleshoot.

PS - does anyone know if config files are backwards compatible with firmware? Like if I were to flash 8.1.0 or earlier, could I restore my 8.1.1 or 8.1.2 config files or would I have to flash config files from 8.1.0 (I’m not even sure I have them that old, but I’m willing to try).


Glad I’m not the only one. We have have at least three users with similar issues. Either something permanent like microcode update happened in 8.1.2 that resetting to lower firmware does not FIX – OR the issue is also in 8.1.1 and just didn’t manifest until it upgraded again to 8.1.2.

I wonder if rolling back to 8.1.0 or earlier would work. I had to order a second device because half my network is down. My doorbell came is beeping red alerting to the world the connection is broken (not Peplink’s problem, but still I feel like a dumdum broadcasting my broken connection to the world). Other important devices I have for home automation are not working.

I don’t even care about the extra $200 I spent right now, I just want this fixed… now if I upgrade the spare to 8.1.2 and that also breaks Wifi then I will be extremely pissed and it will be obvious that something is catastrophically wrong, breaking two units in a row. Let’s see how it goes.

@mamc you have done excellent work here! The other details you provided regarding what does and doesn’t work for you are identical to my experience.

I was about to respond to @Michael234 that I appreciate his guess, but that I had also tested creating brand new SSIDs and trying to connect these devices to it for the first time ever with no luck either, so I am guessing it is not related to the changing MAC address, though that may be a problem that might affect some others’ devices.

Thanks for everyone’s time. @mamc for the win! Hoping its an easy firmware fix from Peplink!

1 Like

Agreed. Excellent work. My guess was wrong.

I would expect config files for firmware version 8 on the same router to all be compatible.

Have you looked at “Band Steering” in SSID advanced settings? This setting is available in the SURF SOHO settings web interface; don’t know about other peplink devices.

Yes, I have the setting disabled. I even toggled it on and off again to be sure there wasn’t some strange remnant.

There are some devices that hard code a MAC into their config, but lemme tell ya when I plugged in my cheapo router, every since device came online within a minute. I maintain a list of MAC addresses for all my hardware and believe it was every single one that connected to cheapo. No doubt some others might have clients like this, but I do not have any in my diverse array of gear.

I’m hoping that my work will help them. I am sure they are busy so I don’t want to waste their time by doing no work whatsoever.

I’m a network and server engineer by trade… 13 years. I dislike when people make demands of me to fix their systems without assistance from them. Which is why whenever I have a problem I exhaust what I’m capable of and gather as much information as possible before engaging support. Ya know, help them help me help them… help me :slight_smile:

1 Like

Do you have both 2.4 and 5GHz checked as below:

I’ve tried just 2.4Ghz with 5.0Ghz off… also tried both enabled. Didn’t make a difference. I also played with all the various Width and Channel settings - no luck.

I even enabled the advanced settings and toyed there a bit. You click on the ? button in the upper right hand corner to see them FYI.

Are you sure you’re making the changes correctly? First you save and then you apply (just trying to be thorough). Perhaps you could say which device you’re using and post a refreshed ssid settings screenshot.

Yes, I save the config and then apply. I don’t really feel comfortable posting my settings on the public forum. But rest assured, I tried everything I could, hitting apply and save config every time.

Update: rolling back to 8.1.0 did not fix the issue.

If it were me, I’d try a factory reset and then reload my config. If that doesn’t work, I’d open a support ticket with Peplink. Good luck.

I’ve done a factory reset and rebuild config from scratch (not complete config, but only what is sufficient to get the smarthome devices back online) + tested out 8.1.0, 8.1.1 and 8.1.2.

I have a support ticket open - 21050533.

@sitloongs - can you take a look at this ticket? You’ve helped me in the past, I trust your expertise.

EDIT: since testing 8.1.0 and reverting back to 8.1.2, I’m now two less 2.4GHz connecting. I have a water monitoring device that previously connected fine and a dehumifidier that would flap. Now, neither once of them are connecting at all. I fear I have made things worse by downgrading to 8.1.0 and then upgrading back. And yes, I took a config of my state before downgrading and restored the same config after upgrading again… did not help. Very strange!


:+1: :+1:

So very interesting and could be my WISP but I have been having some connectivity issues since updating to 8.1.2. I was on 8.1.0 before. No issues. I updated to 8.1.2 RC2 or 3 and started noticing WiFi WAN would connect after reboot then shortly after drop then get stuck on Connecting… Normally it would reconnect but it wouldn’t. Even moving the WiFi to disabled and back to priority 1 it still won’t connect. As soon as I reboot the whole device, it immediately connects without issue, every time. I tried rolling back to 8.1.0 but issue remained. Now on 8.1.2 GA. I am going to try to monitor and see if I can identify anything funky. I am in a weird environment with several variables so its hard to track things down sometimes. Just curious if perhaps the WiFi radio firmware itself was updated in 8.1.2 ? Could that explain the same issue being present in 8.1.0 even after rolling back? Clicking the “Wireless Networks” button shows the SSIDs with excellent signal strength. I do wish it would break out multiple APs that share same SSID but have different MAC address though…or at least let us see the MAC address of which AP you are connected to on the Details tab…

So are all the folks with WiFi issues using devices with integrated WiFi …and not something like a Balance One Core controlling separate Pepwave APs?