Starlink app fix

Peplink seems to be one of the few edge routers that cannot accommodate the Starlink app workaround. When NOT using the included Starlink wireless router, in order to be able to use the mobile app, you need the ability to route 192.168.100.1/32 or 192.168.100.0/24 to the WAN interface but not to the next hop necessarily. I tried all suggestions and tinkered for hours and could not get it to work. I believe a limitation in the routing code will need to be tweaked to allow this.

I imagine Peplink would be a pretty common choice coming up for people in Starlink beta, but not being able to use the app to see statistics is a killer.

Here is a discussion on it: https://www.reddit.com/r/Starlink/comments/jxkz1q/anyone_know_how_to_get_the_starlink_app_to_work/

and here is a Peplink forum discussion on: Starlink and Peplink Balance - #9 by darwinperrier

2 Likes

Odd, they have that functionality for PPOE connections. I imagine this could be fixed in a similar way. I think they call it “Management IP Address” or something like that. It allows for a dsl modem to be managed while in bridge mode.

1 Like

@sipple31, @jmjones, thank you for bringing this to our attention, the team has reviewed the request and working on the solution. Target to have a special build firmware to address this in the coming days/weeks. Stay tuned.

[Update: 01 April 2021]
The special firmware for the below models can be downloaded here, other models are coming. Please give it a try and let us know the result.

Balance 210 HW4-5
Balance 30 LTE HW3
Balance 30 Pro HW1
Balance 310 HW4
Balance One HW1-3
Balance One Core HW1
MAX 700 HW3-4
MAX BR1 ENT HW1
MAX HD1 Dome HW1
MAX HD2 HW5-6
MAX HD2 Dome HW1
MAX HD2 IP67 HW2-4
MAX HD2 Mini HW1-3
MAX HD2 with MediaFast HW1-3
MAX HD4 HW1-5
MAX HD4 IP67 HW1
MAX HD4 with MediaFast HW1-3
MAX Transit HW1-3
MAX Transit Duo HW1-3
MediaFast 200 HW1,3
SpeedFusion Engine Cam HW1

Steps to enter the Management IP Address:

  1. Enable the feature in DHCP WAN

  2. Input the Management IP:

8 Likes

Thank you for the prompt reply and I’m happy to assist with testing if you need it… :+1:

1 Like

thanks for bringing this up again @sipple31. I believe I saw a post on reddit indicating it might have been pulled in to an upcoming release. i am hopeful they will draw attention to it as the ‘fix’ for Starlink customers. in the meantime I am considering an option described in another thread here which is to put a dumb switch between the dish and the peplink, and then attaching the starlink router to said dumb switch. will still require jumping onto the starlink router’s wifi temporarily to grab the stats, but atleast then its possible.

1 Like

Does it work if you create an outbound policy and put it at the top of the list and turn on expert mode.
Do an enforced 192.168.100.1 via the wan it’s plugged into?

1 Like

If you read the peplink thread from the first post, you will see that an outbound policy does not work, and that a static route is required.

1 Like

The simplest workaround is to run your Peplink off the aux port on the Starlink router. This keeps the app working… it’s just non-ideal because you have double-NAT, the extra hardware in-between, and a Wi-Fi network clouding up the airspace that you can’t turn off.

1 Like

Was expert mode enabled? It doesn’t seem clear in the original post that an outbound policy to ip 192.168.100.1 as an ip or network 192.168.100.0/24 , enforced to the correct wan with expert mode enabled was tried.
Also the tracert showed trying it to the LAN via the WAN.
Can someone please test this and show the screenshots of the configuration?

1 Like

I have expert mode enabled, it didn’t help. When you check the ARP table, there is never an WAN 1 arp entry for

192.168.100.1.

Here is a CLI ping test manually sent out of the WAN interface. This bypasses all questions of Outbound Policy rules.

support ping 192.168.100.1 wan 1

PING 192.168.100.1 (192.168.100.1) from 100.66.32.1 eth1: 56(84) bytes of data.

— 192.168.100.1 ping statistics —

5 packets transmitted, 0 received, 100% packet loss, time 4192ms

A tcpdump confirms that the packets to 192.168.100.1 are sent to the MAC address of the WAN DHCP default router, and since the mac address handing the statistics of the sat terminal is a different mac address from the CGNAT default router handled by the bridged modem there is no response.

? (100.127.255.1) at 02:02:00:00:00:01 [ether] on Starlink
? (192.168.100.1) at 26:12:ac:1a:80:01 [ether] on WAN-EXT
(This is with my dual WAN + switch workaround).

The passive interception of 192.168.100.1 regardless of mac was standard in DOCSIS modems, but many other bridged modems (DSL, Starlink) do not examine the bridged traffic, and only accept management traffic specifically destined for their MAC address.

For these to work, you need to use one of the listed workarounds until Peplink handles static routes on WAN interfaces, or some other way to manually set the mac address of these outbound packets.

If you would like to see the tcpdump I can go generate a fresh one.

1 Like

I wonder if putting the peplink in drop in mode would help?
I think it does arp proxy.

1 Like

You’ll have double NAT anyway due to starlinks use of carrier NAT, this would likely be triple NAT but it should in theory still work.

2 Likes

thnx for sharing these details…! control cables UAE

Working for me! :clap:

1 Like

Amazing! I am a Starlink beta user. Downloading and installing the test fw now and will report back.

On a Balance One Core, I’m not seeing the ‘Management IP Address’ field despite being on the latest fw.
image

image

I also reloaded the admin portal in private browsing to make sure it wasn’t a caching problem or anything.

Update: my router just rebooted again and seemed to revert to the prior FW? Trying the process again now.

New router version seems to be staying now on the 2nd try, however, the Management IP Address field is still MIA.

You need to click on the ? next to the hostname field to enable it.

4 Likes

Ahh thanks! My confusion was that the field already existed in the demo screenshots above.

Working great now :slight_smile:

1 Like

Awesome! I have a starlink dish myself and it’s been great so far.

2 Likes