Update not working on Soho MK3 (Firmware 8.1.0)

Hi there, I’ve asked to closed the ticket as I have gotten the upgrade to work by factory restoring the soho, manually applying the firmware then restoring my configuration from backup.

Now all i have to figure is how to get it working properly as an access point. :sunglasses:

Off the topic here a bit, but are you trying to use SoHo Mk3 as an access point connecting to something like Balance One? I am thinking about going that route myself.

Indeed I am! Purchased a Balance 20 and using my SOHO as an AP. Balance One would have been a nice speed increase bug couldnt justify the cost. Plus, my ISP download is 150mbps so the Balance 20 is a good match.

Here is my thread fyi:

So far, i have everything working with the exception of PiHole (serving mainLan only, but want it across all vlans)

Bonjour Forwarding is giving me problems. I can see the device in my Airplay list from my iPhone but it cant connect. Hopefully i get this working since its one of the reasons for going with a Balance series device.

1 Like

i confirmed this fix step. I did same thing. Restore to factory setting. Upgrade via download. Restore the old configuration. And it worked.

non-bootable situation is fixed as well. It appears SOHO MK3 has enough space for two firmware image and I am back to normal less than 5 minutes. My VPN to home office didn’t even know I went down. It was on a different access point, but VPN agent restored the connection by the time I came back up from my basement utility room.


Yes indeed.

Download configuration
Restore factory settings
Log in and change password
Go to system, firmware tab, check for new firmware, download the FW 8.1.0, it reboots.
Upload the configuration file.
And it’s all working great.

1 Like

New to this forum. I have a Soho Mk3 with firmware 8.0, and am wondering if the upgrade to 8.1 is working and stable. Concerned about all of the issues I am seeing in the forum.


1 Like

Hi. Our experience is that 8.1.0 is definitely stable although a few folks have had difficulties in upgrading. If the latter were to happen the only result is that the upgrade fails – no other harm done. The improvements in 8.1.0 justify an upgrade from 8.0.0 in my view.

There are a couple of issues with 8.1.0 noted in the forum and here … https://download.peplink.com/resources/firmware-8.1.0-release-notes.pdf. They’ll bother some users and not others – depends on what you are doing with your SOHO. Peplink has a history of dealing with them in a minor release which I’d expect to see in the relatively near future.

1 Like

I’m having a similar issue with a BR1 and a Transit Duo. It goes through the upgrade process and boots back up on 8.0.2. The reboot page lists 8.0.2 and 8.1.0, both non-bootable.

It also took multiple tries on a different BR1 and a Transit Cat18 before the upgrade took.

I have a Soho Mk3 currently running firmware 8.0, and tried to upgrade to firmware 8.10. It downloaded the image and went through the process of upgrading, rebooting, etc. All seemed fine, except it is still running firmware 8.0.0. Not sure what to try next. Maybe try manual update method?

Ok, the manual update method worked! Now running 8.1.0.

Hi All,

The special firmware as mentioned in the earlier post released. For those having issue to upgrade the SOHO MK3 device, please help to upgrade the device using the followings firmware :

sha1: 816d6c7b70c68a23acee92c92890da6edd227b68

Please report back if firmware upgrade still having issue :smiling_face_with_three_hearts: :smiling_face_with_three_hearts:


The new firmware works perfekt now. Thanks


@sitloongs If a SOHO MK3 has already been upgraded to 8.1.0 using the initial GA version, is there any reason to install the special version of 8.1.0?


No need to upgrade the SOHO MK3 again using the firmware :grin:

The special firmware given above mainly for users that having issue to upgrade their SOHO MK3 device using the GA firmware.

1 Like

Thx but no. Still not upgrading. It appears to finish but has not upgraded


Do you have ticket opened for this ? We may need to check from your device to confirm.

1 Like

Reporting here: since installing FW 8.1.0 (update from FW 8.0.2) , browser speed tests cause my Soho Mark III to crash during the upload speed part of the test.

This happens every single time I run a speed test (I’ve done about 15 this morning).

I have Google Fiber that ordinarily has equal download and upload speeds. The problem is that a higher (for U.S. residential) upload speed (anything > 55 Mbps) sustained only for 5-10 seconds causes the Mk 3 to crash every time.

I have no way of rate limiting my own upload speeds and this is causing me serious issues with my ability to telework.

I have not enabled any of the new features in this update.

Update 2:

Same instability crashing problems persist regardless of which FW I boot to.
In process of getting debug dumps to provide when filing a support request tomorrow.


Was able to downgrade via local method.

I’m really glad Peplink allows simultaneous use of both InControl and locally connected admin, and doesn’t force users to choose between the two…

The MK3 stops responding after the speed test and needs to reboot it manually in order to recover it? Please help to attach a Diagnostic Report when you open the ticket.


1 Like

Is special firmware still needed to upgrade SOHO MK3 to firmware 8.1?

I ask because today (Sept 15) I downloaded build 4941 of firmware 8.1 from firmware 7 and got the not bootable error shown below.