Turned my Surf SOHO into an AP - VLANs not working, need validation


I’ve read a few posts from @MartinLangmaid and they helped alot.

I recently acquired a Balance 20 and decided to turn my Surf SOHO into an AP but would like some validation on how i configured it.

On the Balance 20

  • replicated the defined network from the SOHO (1 untagged and 2 vlans)
  • manually added a dhcp reservation ( for the SOHO using its lan mac address

On the SOHO:

  • changed the device IP to (Balance 20 is
  • disabled DHCP on all networks
  • unplugged WAN cable
  • WIFI configuration and other configurations left untouched.

I connected a LAN port from the SOHO (ACCESS port type) to Lan port 4 (TRUNK) on the Balance 20.

I’m uncertain on whether i should be setting lan port 4 on the B20 to Trunk, but based on my understanding, if the device connected is capable of tagging, like the Surf SOHO, then TRUNK is proper.

For some reason, I’m not seeing the SURF SOHO as a client on the B20 client list even though i can connect to it and created a dhcp reservation for it.

FYI… was hoping i could test out Bonjour forwarding by setting a LAN port on the SOHO AP to “ACCESS > My IoT VLAN”… but the apple device can’t connect (Airport Express used for audio streaming)

Not sure if this is feasble… figured setting up the port on the SOHO to ACCESS > vlan ID 21, and SOHO connecting to B20 via lan trunk port, the B20 would pick it up.

** Update: none of my vlans are assigning IPs …


Seems my Surf SOHO is also no longer accessible via inControl. States that WAN is disconnected.


Getting a dedicated AP ONE mini AC might work better after all.

I’m going to try something similar in a few days. I’ve been wondering if I should plug the wan into the lan, so that it gets an IP on both interfaces and can talk to the internet.

Still, it seems a missed opportunity not to have an AP mode, or a bridged mode so that wan and lan are the same.

Yeah its a little frustrating. Right now i have wifi working over main untagged lan, but my vlan wifi ain’t working. It doesnt seem to be assigning IPs so no devices are connecting (wired or wireless)

Having it offline in inControl is not a showstopper, as I’ll probably stop using inControl.

So, problem why vlans were not working? I hadn’t enabled “trunk” on the lan port of the SOHO connected to the B20.

Makes sense, the SOHO being in “access” mode, was sending down packets untagged IPs, so B20 was serving them from the untagged lan… IPs no longer matched, so no dhcp assignment.

So in this case, important to have “trunk” enabled at BOTH ENDS. :slight_smile:

I hope i’m understanding this correctly.

1 Like

I think you are! Glad its working!


One thing to note, because I’m no longer connected to WAN in the SOHO, NTP time sync is no longer working.

Also no longer connected to InControl and firmware checks won’t work, but that’s fine, can be manually applied.

All that to say, i may have a deal on an AP Rugged or AC mini. :sunglasses:

I may donate the Soho to family to replace their ISP gateway.

Regarding the time sync on the SOHO. Saw an option on the Balance 20 to enable NTP server. Checked that off, then used my Balance 20 IP as the Time Sync server on the SOHO.

SOHO time stamps now syncing. :sunglasses:

1 Like