Update not working on Soho MK3 (Firmware 8.1.0)

After updating firmware 8.0.2 to 8.1.0 it still shows firmware 8.0.2 after reboot.
This happened only on SOHO MK3 and not on the B30.

Regards Silas

Can’t say anything about B30.

I can’t upgrade SOHO MK3 HW1 firmware. Tried online, incotnrol 2, and manual. they all seem to fail, but no firmware upgrade failure message in the log file either. It just says “Firmware upgrade now”, but no other entry after reboot. It just shows 8.0.2 build 1480.

Same here on Surf soho MK3. I just tried two times from UI.
It acts like it’s doing the FW upgrade and after it boots back up still has 8.0.2

I have tried all three ways of FW upgrade, from file, from IC2, from UI

Manual and online firmware updates from 8.0.2 to 8.1 fail on my SOHO MK3 HW1 also.

Let me check on this and update again shortly.

1 Like

I just use my device and do a quick check and the firmware upgrade seen working fine for my SOHO MK3 HW1 device :

Please open a support ticket for support team to investigate from the devices.
https://ticket.peplink.com/ticket/new/public

1 Like

I tried again and still the same results image image image image image

I’m getting the exact same issue on my Surf SOHO MK3

I have the same hardware, but it upgraded fine with mine. I’m having a different (unrelated) issue though that has forced me to back down to 8.0.2 again.

@Ballistic and @stego

You have the ticket opened ?

Based on the screenshot provided by @Ballistic, suspect the firmware partition having issue and this is the reason why you can’t upgrade [Non-bootable] .

image

There will be a new firmware:

For your case a special firmware based on 8.1.0 will be build which will have couple of improvements which should help with firmware update. I will provide it to you as soon as it will be created.

Same issue here, surf soho mk3

@sitloongs … Just a note … We just upgraded three new routers of the exact same models prior to sale. No issues going to 8.1.0 and booting therefrom. Curious that some have issues and others do not.

2 Likes

Was looking at this a bit more. I assume something to do with my current configuration is not allowing the auto update. I suppose I can download the current configuration, rollback to factory default, try the firmware upgrade, if successful then restore the configuration and see if it works. I am just too lazy to do all those things at the moment. Going to wait a few more days before making any move on this.

image

image

image

image

image
Wednesday, August 12, 2020
7:35 AM

I tried the automatic “Download and Update” option on my SOHO MK3 HW 1 and it failed to update and I saw the same “Non-bootable” error for Firmware 2. I then tried manually downloading the firmware and upgrading that way, which worked fine.

I didn’t even think non-bootable is an error state. =) I did try the manual update, but that didn’t work either for me.

@sitloongs Ticket submitted. #20080325

I just created a support ticket on this topic as well. =) cheers!

Hi All,

I have discussed with Engineering team and Engineering team agreed to release a special firmware that will help to isolate the issue. Based on the screenshot provided, we are suspecting the upgrade process is not completed and this cause the firmware roll-back to the previous running firmware partition.

The special firmware is targeted to fix the firmware upgrade issue and for those users that having the issue to upgrade the SOHO devices are advice to use the special firmware. I will update and post again when the special firmware is ready.

1 Like

Just a quick background: There was no interruption to the automatic upgrade when I attempted the firmware update. Soho MK3 was sitting in a large utility room with controlled humidity (55% humidity level), the ambient temperature kept around 75F, and Soho MK3 is connected to UPS.