Unable to access VPN server via L2TP


#1

I am able to remotely access the Balance 20 VPN server using PPTP protocol, but have not been successful using L2TP. Is it necessary to open any ports/protocols in the firewall or forward any ports for this? Are there any security settings that need to be set in the client? I have tried to do this both from my Samsung s5 phone and a notebook running windows 8.1.


#2

Hi Paul,

Please refer here to setup L2TP With IPsec. I tested it is working fine with Android phone and Windows 8.1.

Please ensure your Windows 8.1 setup as below:-



Hope this help.


#3

I double/triple checked everything I set up against these suggestions and I’m still unable to connect using L2TP. From windows, I get error 789. Haven’t yet been able to figure this one out. From Android, client reports ‘unsuccessful’.

When I switch back to PPTP, I have not trouble connecting from either client.


#4

Hi Paul

  1. Samsung phone uses wifi connection to establish L2TP?

  2. If item 1 is true, both Samsung and Windows machine are located behind a NAT device?


#5

The Windows machine is behind NAT. The Samsung has been tested both over both WiFi and cellular with the same result. Ultimately, I’m only concerned with being able to access the server via cellular or a remote internet connection. I only tried the windows machine here for test purposes.


#6

Hi Paul,

You will facing problem with multiple Windows machines if behind NAT device. We have announced this here. However we don’t facing problem on Android or IOS devices. Please open ticket for us to take closer look.

Thank you.


#7

Hi,

I am using a 310 and my L2TP IPsec VPN works fine with my iPhone however when tried with the Windows 7 machine it keeps failing. what could be wrong?


#8

I believe the Balance 310 is behind a NAT device. If so, please refer to this link.


#9

It’s not a problem with peplink but a small registry bug on the windows machine. You can edit a specific registry value on the win 7 machine and it will work fine