MAX Transit WiFi Stuck "Scanning"

Hi, I have a month old MAX Transit router that will not connect to WiFi.

Model: Pepwave MAX Transit
Firmware: 8.0.2s046 firmware build 4437

My MAX Transit is setup in an RV with a Poynting MIMO antenna. When I enable the 2.4 WIFI WAN and connect to a network, the status shows “Scanning…” and never connects.

I’ve ruled out signal strength ( currently showing -59dBm ) and key/password as I’m able to connect to the network without issue from other devices.

Process looks like this:

The network I’d like to connect to:

I click “Connect” and enter details and click “Save”

Brings me back to list of networks

I again click “Connect” and then “OK”.

I’m then redirected to the Dashboard view, where I see “Scanning”:

As a test, I turned on hotspot on my phone and I got WiFi WAN to connect no problem. :man_shrugging:

I’m new to Pepwave devices, but logging on the router seems to be useless. Looking at event logs only shows “changes applied”. :tired_face:

I’ve rebooted many times. Also tried reverting to the stock antennas.

Am I missing something? I see there is at least one other thread on this, but the resolution wasn’t clear. @javier.reynaldos were you able to get this resolved?

Thanks for your help!

Hi Josh;

The resolution to my issue in exactly the same circumstances as you describe was to “refresh” the password/passcode on the Wi-Fi device to which I was trying to connect.

In my case, as the Wi-Fi is at my In-Law’s house, I was able to do so with their permission (which took a couple of days to get). I reused the same 10-digit key and suddenly the Pepwave connected without issue.

In my rounds of troubleshooting, I was able to see an error in the event log that the “Pepwave was unable to associate to Wi-Fi XXXXXX. Passcode may be incorrect”
Do you see this kind of message in the event log?
To what kind of Wi-Fi Network are you trying to connect?
Now, I don’t have much of a sample size (this happened to me at two different locations where both had residential-internet service with older routers (2Wire equipment). I suspect this equipment was the underlying cause.

I hope you’re able to try the password reset. it was the only thing that worked in my case.

Kind regards,


Thanks so much for your reply @javier.reynaldos.

That is really interesting, I wouldn’t have thought a password reset would be a solution.

I am RVing across the country, staying at various RV parks. When I first got the router, I had no issue connecting to my UniFi setup at my house. But since I’ve been on the road, 90% of the time I can’t connect to RV parks WiFi. In one instance an RV Park had 5ghz WiFi and I was able to connect no problem. No luck with 2.4.

Oddly my event log never shows any errors. I filed a ticket with pepwave support, I’m hoping there are additional diagnostics they can walk me through.

Thanks again for your reply. Let me know if you have any other ideas. :smile:


We are doing the same thing; however, since my husband is Canadian we’re spending the summer up here.
Like you, I connected successfully to my home Wi-Fi (my own Netgear Router) without a problem. I was also successful at Myrtle Beach State Park with both the 2.4 GHz and 5 GHz networks. But we’ve had no luck when it comes to private RV parks Wi-Fi nor with residential Wi-Fi where the DHPC and WPA/WPA2 security is handled by ISP-Issued equipment.
At the end of the day, I think the issue may be between the Pepwave and older, ISP-provided Wi-Fi equipment. Whether it’s missing firmware upgrades, or just downward compatibility of the Pepwave, there is something that the home Wi-Fi just doesn’t like about the Pepwave.

After repeated attempts to connect the Pepwave, I was able to see a couple of the connect entries in the event log but there was definitely a significant lag before they showed up. This indicates to me that the pepwave makes several attempts before logging the event (or the error just takes a long time to process). Try letting the “Scanning…” go on for an extended length of time without rebooting the device before checking the log.

Wish I could help more, but that’s all I got.



1 Like

@TK_Liew @WeiMing this seems to be a reoccurring problem. Is the Pepwave team able to help find a solution? I’ve created a ticket #20070767, hoping to get support.


1 Like

Do you have a signal threshold set on the peplink?

Roaming turned on?

Are there multiple APs with the same SSID you are trying to connect to?

Thanks for replying @mystery.

Do you have a signal threshold set on the peplink?\

No signal threshold set.

Roaming turned on?

Roaming is turned off

Are there multiple APs with the same SSID you are trying to connect to?

Possibly, but I will need to confirm. Would this matter? I see there is an option for a preferred BSSID. I could try pinning to one and see if that works.

it could be trying to connect to a more distant AP even though there is a close one

i use the wifiman app by ubiquiti on my android phone to get a sense to whats out there


Would you please upgrade the transit device using firmware 8.1.0 RC4 and redo the test ? We have multiple enhancements on the WIFI WAN in firmware 8.1.0.

If you still found problem to connect, please upload the diagnostic report in the ticket for support team to check.


Hi @sitloongs. Thanks for your reply. I upgraded to 8.1.0 RC4, but it did not fix the issue. I’m still seeing the WiFi WAN stuck on “Scanning”.

Again, I’ve confirmed the key/password is correct and I’m able to connect to the wireless network from other devices.


Would you able to upload the diagnostic report and enable Peplink Remote Assistance Service for support team to check ?

1 Like

I am having the same issue. I also updated the Firmware (Beta) and the problem persists.

@Robert_Webb, may I know how you workaround the problem? Downgrade to the previous firmware then the Wifi WAN will connect immediately? If so, please submit a ticket for us to take a closer look.

1 Like

Hi - I downgraded and am still unable to connect to Wi-Fi. I submitted a Ticket. Peplink #20080205

I have checked the ticket. Both of your Wifi WANs are connected now. We didn’t make any changes to it.

By the way, I notice the Wifi signal strength received by 2.4GHz Wifi WAN is poor. Somemore, you have enabled Signal Threshold for both Wifi WAN. These might be the root causes which cause the Wifi WANs failed to connect to the AP.

Please revert the Signal Threshold to the default setting for the time being since the device couldn’t get a good signal strength. You may consult your point of purchase (local Peplink partner) on how to improve the Wifi signal strength there.

Hope this helps.

1 Like

Disabling Wi-Fi AP (Dashboard page) addressed the issue for me (albeit temporarily). I am now able to connect to 2 different Wi-Fi signals (2.4 and 5.0 Ghz). I am still working with support (Topher) and he plans to engage a different team to further investigate.

@Robert_Webb, I have provided feedback to to Frontier. Please help follow up there. Thanks.

1 Like

I’m having the same issues - did you get this problem resolved? I can connect 5ghz no problem but not 2.4ghz.

Same issue here, any updates on this?

I have filed Peplink Ticketing System for the same issue. Thanks.