Introducing Firmware 8.1.1!

The new 8.1.1 firmware for your Peplink device includes a newly added feature; Cloud Application Optimization, which allows frequented applications to be prioritized, especially via SpeedFusion Cloud, making it much more powerful.

Other new features such as Wi-Fi Mesh compatibility and OpenVPN support to enable network extension and reduce downtime.

Improved enhancements are offered for troubleshooting, available through an additional supported NetFlow server and Air Monitor support, both highly requested features to improve efficiency.

Watch Full Webinar >

Visit Firmware 8.1.1 Website >

Download Now >


Key Features


Cloud Application Optimization:
Accessing your Cloud based applications is now possible using just one Peplink device connected to our SpeedFusion Cloud. Use Cloud Application Optimization to increase efficiency and quality as well as prioritize the flow of applications such as Google, Office 365 and Zoom.

Learn More >

8.1.1_wifi_mesh_network_web

Wi-Fi Mesh Support:
Supports 802.11ac and models above. This along with the AP Controller, allows for mesh network extension.

Learn More >

8.1.1_open_vpn_web

OpenVPN Client mode:
Connect to your other devices using OpenVPN client mode, creating a compatible virtual WAN. Customize priority of WANs, outbound policy, firewall etc. to suit your requirements.

Learn More >

Enhanced Support

Support DSCP:
Support for firewall filtering via DSCP, with the ability to recognise packets and block negative qualities. The outbound policy can be configured to optimize data flow based on priority and efficiency by DSCP.

WAN PoE:
PoE activation via the FlexModule ethernet ports can also be activated when they are configured as WAN.

API:
The WAN settings configurations can now be accessed via the new API interface for controlling, configuring and monitoring Peplink devices in the network.

FlexModule Mini VDSL:
Allows a DSL connection to be added. Compatible with Balance 20X, 380X, 580X.

Traffic Awareness

Netflow:
Added support for an additional NetFlow server (now two). Traffic insights can now provide data via IP. Simple Network Management Protocol (SNMP) is now supported for your Peplink router to collect and forward NetFlow data on your connected clients.

Air Monitor Support:
A useful wireless environment monitoring feature which is now supported in 8.1.1. Great for troubleshooting remotely and proactively handling Wi-Fi and WAN performance.
3 Likes

Balance 20 unstable with 8.1.1. Portal page only accessible for the first 2 min and then becomes unresponsive and unable to connect to the portal page again.

1 Like

I was running RC3 and was about to update to latest official, but noticed the build numbers ar the same… I am currently running 8.1.1 b4990 so presume I am already on latest release?

Correct, RC3 = 8.1.1 GA now.

3 Likes

Balance 20X running like a dream on this firmware, backup USB 2nd WAN, SpeedFusion Cloud connections, 9 Access points using WPA3 with solid connectivity…

3 Likes

I can confirm that 8.1.1 is unusable on Balance 20 HW3. After wasting a couple hours, I had to re-install build 4956. It’s a bit flakey, but is usable.

1 Like

Nice work Peplink team!

I’ve been up and running on 8.1.1 RC3 now GA for 14 days without a hiccup on my B20x.

1 Like

It would be helpful if you were to detail what the apparent issues are. “Unusable” is not very descriptive.

1 Like

As a previous user mentioned, the router is only usable for about two minutes after boot-up. Then the web interface locks up.

About a month ago, I spent two weekends and at least 20 hours testing various beta versions of 8.1.1 with similar results. I submitted several reports to Peplink, but the router locks up before you can even gather any information that may be useful for troubleshooting. While I was testing, I had to reboot the router countless times and it often takes several minutes for the router to connect to WAN1 and WAN2 (if it connects at all).

Others have reported the same kind of problems with their Balance 20 routers. I also tested with a spare Balance 20 (HW6) and experienced the same problems.

I was hoping that the official 8.1.1 release would fix the serious Balance 20 problems that have been reported, but that does not appear to be the case.

With 8.1.1, the Balance 20 locks up so quickly that it is basically unusable. While I would like to help, I also have to earn a living, so I cannot spend any more time troubleshooting. I just need a router that works. With the correct tools and a deeper knowledge of the firmware, I might be able to figure it out, but it’s been a long time since I’ve done that kind of work. If I were to have billed all the hours I’ve spent trying to fix problems with the Balance 20, it would have been much less expensive for me to have just purchased a new Balance One.

If new releases of firmware won’t work on older versions on Balance 20 routers, Peplink should just admit it. Otherwise, they’re just causing needless frustration to their customers.

FW 8.1.1 build 5040 breaks all AP connectivity on BPL-ONE-CORE HW1. All locally managed APs drop offline. FW 8.1.1 was installed, then I waited 30+ minutes for the APs to reconnect. They will not communicate back to the router. I tried a Web UI factory reset on all the APs as well as using a paperclip in the reset button. They will not respond to pings and they do not show up on the AP page. When I roll back to 8.0.2 build 4407 by rebooting into the other FW slot, they all come back online and sync fine.

FW 8.1.1 is completely unusable on my B1 Core.


I’m having the same issue on the Max BR1. It responds the first few min after boot up then stops. Goes offline in InControl and can’t access it via web. It seems to be happening when I use the IP Passthrough feature. 8.0.1 didn’t have this issue.

@jeff, @thebigbeav & @cmb991: Looks ike you guyz are really fighting with this. I think the thing to do here is (1) download a diag file, (2) turn on RA and (3) submit a ticket. The engineers may have difficulties getting in to take a look under the hood with RA if the router is flaky but at least you’ll bring visibility to the issue(s) and they’ll have the diagnostic file to look at.

2 Likes

I have already downloaded several diag files, turned on RA and submitted several tickets (for the beta version). All of this assumes the UI is stable enough to do something, but it’s not. The firmware is so unstable that the UI is not usable long enough to do anything useful. When trying to do this, I often had to reboot multiple times just to be able to login again. Rebooting destroys any useful diagnostic information. When Peplink engineers tried to login remotely, it would lock up before they do could do much.

My router is not in a test lab, it’s in a real working environment and is used by multiple people. The only time I can do any tests like this are after hours and on weekends. After installing 8.1.1 and seeing it lock up again, I was concerned that I would not be able to reinstall the old firmware. It took 3 reboots for me finally get the old build 4956 reinstalled and working.

I’ve been using Peplink routers for 10+ years, but I do not have unlimited time and energy to devote to troubleshooting these kinds of problems.

Try a factory default. I have over 900 peplink routers in use. Perhaps four or five times we have had one somehow corrupt it’s config and eith lock up or reboot constantly. A factory default normally fixes this.

image001.jpg

Have already done that (more than once). Have two different B20 routers and they both exhibit the same problems. It’s definitely a firmware issue, not just one bad router.

I’m using this router with two WANs, but instead of providing a backup if one WAN fails, the failure of WAN2 caused the router to become unresponsive. WAN2 failed briefly on Friday afternoon (which caused an alert to be sent to me). WAN2 recovered after a minute or two, but when I tried to login to the router see what was going on, it was impossible. Fortunately, it was still passing traffic for existing clients, but it would not allow any new DHCP clients to connect. I had to wait a couple hours (until after 5pm) before I could reboot and get things back to normal.

This problem was with build 4956.

@jeff

You have several tickets summited for the issue ? Would you able to share me the tickets number ? I’m working on 1 of the ticket and I’m waiting your help to provide more diagnostic report due to the accessibility issue to the device (B20 Hw3).

Maybe you have attach the diagnostic report in other tickets, it’s best that I can review all the provided diagnostic reports. Very sorry for this as I tried search using your email ID but I failed to find the tickets, maybe you have different email ID :disappointed_relieved:. I will try to ping you again via the ticket that we are working on and may need your help to share those mentioned diagnostic reports

1 Like

@thebigbeav , @cmb991 and @HydraSync ,

Would you please open a support ticket for support team to check ?
https://ticket.peplink.com/ticket/new/public

1 Like

ticket 20120426

@jeff ,

Ticket 20120426 is the one that we are working on it. I just pinged you using the ticket. Can you provide more diagnostic report as requested ?

1 Like

How can I provide a diagnostic report if I cannot login to the device after a problem occurs? As I mentioned earlier, when the problem occurred a few days ago, I had to reboot 3 times before I could login again.