Defining a Custom Dynamic DNS Server

As of Firmware 6.3, users can specify a custom Dynamic DNS server by entering its URL. To begin, navigate to Network > WAN and then select the connection you wish to modify.

Afterwards, scroll down until you reach the Dynamic DNS Settings menu. From there, click the drop-down next to the Service Provider item, and select Others…

From there, you will be able to enter the details for your Dynamic DNS server. Click the Save button and then the Apply changes button on the top right hand corner to implement your changes.

Related Article:
List of dynamic DNS services supported by Peplink

1 Like

Hi
I have configure a other ddns (I have make my personal ddns).
I receive 19 connection during 10 min and after noting.
And my ddns server is no longer updated.

Could you help me? Thanks

A post was merged into an existing topic: Dynamic DNS with other server

2 posts were split to a new topic: Duck DYNDNS custom settings

This is not working for me. When trying to save my configuration I get an “Invalid URL” error message.

I’m using a MAX BR1 Mini on FW 7.1.1 build 3102.

My DDNS provider is Namecheap, who in turn use ENOM for URL based updates.

The correct format of the URL is:
https://dynamicdns.park-your-domain.com/update
?host=SUBDOMAIN
&domain=DOMAIN.TLD
&password=DDNS_PASSWORD

As described at this link:
https://www.namecheap.com/support/knowledgebase/article.aspx/29/11/how-do-i-use-a-browser-to-dynamically-update-the-hosts-ip

As an aside, when using the URL approach the Username, Password and Hosts fields in the BR1 Mini are not needed.

Why is it that the BR1 thinks my URL is invalid? It works fine when used in a web browser.

Note, I have tried http (non-secure) version and without any protocol label in the URL at all, and these also fail with same “Invalid URL” error. Of course, https is the only truly acceptable format.

I’m attempting to get this to our on a Pepwave MAX Transit with firmware 8.1.0 build 4943. Did you figure this out? I’m also wanting to use Namecheap and other DDNS clients I’ve configured as custom work just fine with the format as you described, although the ip needs to be at the end.

https://dynamicdns.park-your-domain.com/update?host= [host] &domain= [domain_name] &password= [ddns_password] &ip= [your_ip]