Update not working on Soho MK3 (Firmware 8.1.0)

Hi All,

The special firmware as mentioned in the earlier post released. For those having issue to upgrade the SOHO MK3 device, please help to upgrade the device using the followings firmware :

sha1: 816d6c7b70c68a23acee92c92890da6edd227b68

Please report back if firmware upgrade still having issue :smiling_face_with_three_hearts: :smiling_face_with_three_hearts:


The new firmware works perfekt now. Thanks


@sitloongs If a SOHO MK3 has already been upgraded to 8.1.0 using the initial GA version, is there any reason to install the special version of 8.1.0?


No need to upgrade the SOHO MK3 again using the firmware :grin:

The special firmware given above mainly for users that having issue to upgrade their SOHO MK3 device using the GA firmware.

1 Like

Thx but no. Still not upgrading. It appears to finish but has not upgraded


Do you have ticket opened for this ? We may need to check from your device to confirm.

1 Like

Reporting here: since installing FW 8.1.0 (update from FW 8.0.2) , browser speed tests cause my Soho Mark III to crash during the upload speed part of the test.

This happens every single time I run a speed test (I’ve done about 15 this morning).

I have Google Fiber that ordinarily has equal download and upload speeds. The problem is that a higher (for U.S. residential) upload speed (anything > 55 Mbps) sustained only for 5-10 seconds causes the Mk 3 to crash every time.

I have no way of rate limiting my own upload speeds and this is causing me serious issues with my ability to telework.

I have not enabled any of the new features in this update.

Update 2:

Same instability crashing problems persist regardless of which FW I boot to.
In process of getting debug dumps to provide when filing a support request tomorrow.


Was able to downgrade via local method.

I’m really glad Peplink allows simultaneous use of both InControl and locally connected admin, and doesn’t force users to choose between the two…

The MK3 stops responding after the speed test and needs to reboot it manually in order to recover it? Please help to attach a Diagnostic Report when you open the ticket.


1 Like

Is special firmware still needed to upgrade SOHO MK3 to firmware 8.1?

I ask because today (Sept 15) I downloaded build 4941 of firmware 8.1 from firmware 7 and got the not bootable error shown below.


@Michael234, yes the special firmware is needed when you have a problem upgrading
the MK3 to 8.1.0.

Thank you.

I have two Surf SOHO Mk3 which are in InControl and repeatedly fail the update from 8.0 to 8.1 . When I got a third Surf SOHO Mk3, I did not put it in InControl and it updated to 8.1.0 on the first try.

Since the first two units are still failing the update, should I use the special firmware mentioned above, or is there a newer one?



Yes please, the special firmware is need for SOHO MK3 devices that having issue to upgrade.

Great. Thanks! I’m not sure if I can do this today, but I’ll let you know how it goes when I get there.

I downloaded the file from the link above, and tried to do the upgrade via InControl2 -> Settings -> Remote Web Admin -> System -> Firmware.
I selected the file and clicked Manual Upgrade.
The progress bar went across and I got a box with:
JavaScript from “2937-e4bd-990c-ic.rwa10.peplink.com
Error 504 : error

What should I do next?

@TimC, maybe you can submit a ticket for us to take a closer look at what happened to the device?

OK. I submitted a ticket. Thank you for that link!

How I got firmware 8.1.0 working on my Surf Soho MK IIi :

First I logged directly into the router (I.e. not using InControl to eliminate a variable / layer of complexity) and rolled the firmware back to 8.0.2.

Contacted 5gstore, who filed a ticket on my behalf ( #57445206 ) in hopes of being able to fix my situation without having to factory reset and spend an entire day reconfiguring all of my settings, firewall rules, etc (really wish you could do those via ssh or imported csv file but I understand it’s way way more router capabilities for $200 spent 3 years ago than anything else out there, that’s for sure)

Did a number of combinations of manually uploaded FW upgrades & testing as they suggested using both factory defaults and my previous config file.

In the end the most time consuming solution has been reliable, and I’ve been running FW 8.1.0 for the last couple of months w/o any problems, thankfully:

(All of these steps were taken while being directly logged into the router and not using InControl…I used InControl to upgrade to FW 8 the first time so I wanted to avoid using it for firmware upgrades this time)…

  • print to PDFs every single router settings page
  • manually upload and reinstall 7.x.x firmware
  • power cycle
  • factory reset & keep factory default config settings
  • power cycle
  • manually upload and reinstall 8.1.0 firmware
  • power cycle
  • go through the long process of manually rebuilding my config using the PDFs I saved, but this time, because I already had the max number of VLANS in use (16), 4 WiFi SSID’s, a trunk port connected to a managed switch, intrusion detection enabled, InControl enabled and doing whatever it does in the background to make it work with the platform, and a LOT of firewall rules (outgoing & internal) on top of all that:
    I realized that while it’s really great that you’ve added so many more options over the years to use instead of making them exclusively available on more expensive models, I imagine as a company this is a double-edged sword by making so many options available to the SoHo because while customers would like to be able to use as many of the features that you offer all at once, the router’s particular processor and memory naturally must be proportional to the low cost of the unit.
    So therefore I can reasonably expect to be able to use only so many features at once.
    Consequently this time I did NOT try to also use the content blocking, content prioritization, some of the newer firewall features found under the AP section, using an external logging server, and I also largely reduced the firewall logging overall (that last one was a little harder to give up, personally)
  • back up config and power cycle

Everything has been just as stable as it was under FW 7.x.x, I’m happy to say.

No hard feelings, of course.
No company has a 100% perfect development & deployment history, and the last 3 years of service I’ve gotten from Peplink at an incredibly low cost has been highly reliable otherwise.

This was your biggest firmware development effort and deployment since everything around the world went crazy with COVID.
And I know as much as anyone that how much of an exhausting disruptor it has been to suddenly move to doing highly coordinated software development, testing, and deployment, + infrastructure dev work, etc from home, and that greatly increased the degree of complexity logistically, which inevitably raised the probability of errors in a major release like firmware 8 is.
I’m impressed you’ve been able to get squeeze as much additional functionality into the SoHo as you have and continue to do.

Keep up the good work!

1 Like

Yay! I got a reply to my ticket within a few hours. The reply had a link to the very same file that had failed and thrown the nondescript Error 504 : error . But I figured I would download it and try it. And I used the Remote Web Admin in InControl to do a Manual Upgrade - just like I had done before. But this time it worked. Weird. But the double weird thing was that my laptop went weird, the networking stack went goofy and other things quit working. Fortunately, a reboot and then a shutdown and reboot solved the weirdness on my laptop, and the Surf SOHO is still working too.