Firmware 8.1.2 Now in GA

Rolled back to firmware version 7.1.2 in a desperate effort to gain back the functionality we’ve lost in our business. Sadly, no change. Clearly whatever broke the 2.4Ghz radio functionality is pretty deep level with the radios rather than just an obscure configuration.

Perhaps I’m just an inpatient person but when people rely on these devices for business and a published firmware update turns a dual band device into a single band device, the fix should be released swiftly. We have business essential devices that are now inoperable. Come on Peplink. Figure out what you broke in the radios and get the fix out there NOW.

1 Like

I don’t think you are being impatient. There are major issues with a GA firmware that are not resolved by rolling back and there hasn’t been a post from Peplink in this thread in 9 days, let alone a status update.

I get that diagnosing, fixing, and testing things takes time. Just toss us a bone with an official status update. :wink:


It’s gotta be something with the AP/radio. Microcode, Firmware, etc. I’m guessing that some open source library was upgraded and it contained something that wasn’t well understood or full scale tested. This kind of stuff happens all the time with software, not surprising it happens w/ firmware too.

1 Like

I have the smoking gun. My new pepwave device that I had to buy just for this testing works just fine with all my smart home devices.

The difference between working and non-working device is that the working device sends “ACK” in acknowledgment of Probe Requests. The non-working devices does not. This causes probing devices to ignore the Probe Response completely.

Something in the new firmware update changes the radio behavior and stops sending these “ACKs” for Probe Requests. Can this code/functionality please be rolled back?

@sitloong - I have sent you the captures.


Yes, we are checking on that. Supposedly all changes will be reverted when downgrade the firmware.

For your issue a bit strange that the devices no longer able to connect back.

1 Like


Suppose this is related to the Cellular WAN signal showing issue in the router utility. We will check on it and update again. May i know the router utility firmware version ?

Update :
Known issue for Router utility 2.1.1.

1 Like

We checked and the WIFI device is connecting fine in using AP 3.7.3 firmware.


@Niek_V ,

Niek case the problem device able to connect to SOHO MK3 now. Still monitor the status.

1 Like

i have the same unit and same problems. i just upgraded to 8.1.2 last night. i only have 1 vlan though.

@sgruepep ,

Found your ticket. Support team will further check on this.

1 Like

Sorry @sitloongs I should have told you that. 2.1.1, build 102.
I see how that it was reported as in issue on FW 8.1.2 RC2.


No worry. targeted this should be fix for next coming Router Utility version 2.1.2. :wink:


Forgive me if this is a dumb question. What is RU? I’m assuming it’s not “regular” device firmware as that would likely not get a version designator of 2.1.2 when we are currently at a firmware version of 8.1.2

So, what does RU stand for and is this a different upload area of the web console than the Firmware section?

I am also having this issue with a Pepwave MAX HD1 . What is the interim solution as it appears a downgrade and factory reset does not fix the problem?

1 Like

Yes. But your two second Google search didn’t work this time. In this context RU = Router Utility. :wink:
That’s what @sbeisner1 is asking about.

1 Like

I am having the 2,4 GHz drop outs / reconnect issues with a Pepwave AP One AC Mini with Firmware 3.9.0 build 1067 and Apple HomePods and iPhones
Ticket No.# 21050430

1 Like

Ok , let me check on that


Can some define or scope out the problem(s) with 2.4GHz devices on firmware 8.1.2?

Clearly many people are having a problem but my first two tests with devices on the 2.4GHz band and firmware 8.1.2 in a Balance 20x worked fine.


In my case (with both a Balance 20x and a Surf SOHO) devices using the 2.4GHz band will briefly (only briefly) show that they can see the 2.4GHz network and then it disappears before they can connect. At my house (with the SURF SOHO) two different ROKU devices, a new Lexmark printer, and an outdoor camera that worked fine before the firmware update can no longer connect. Sadly these devices only have 2.4GHz capability so trying the 5GHz network is not an option.

What’s strange too with this issue is my password never changed on the router. These are not new devices - they were connected before and they know the password to connect but can’t. Going through the setup utilities on those devices as if they were joining a new router does not work either as they only briefly see the 2.4GHz network and then it’s gone as if you’ve pulled the power cord out of the Peplink. The 2.4GHz radio network is just not there.

Same problem with our 2.4GHz devices at work (the Balance 20x) as well. This all happened after the upgrade to 8.1.2 firmware. Rolling back does not fix the problem.

I submitted an official ticket. #21060362