Firewall rule order not being saved


I am trying to set the firewall rule order on my Balance One router for the internal firewall and the rule order reverts after leaving the page. I drag the rules into the order I want and they keep reverting after coming back to the firewall page. Can anyone else see if they are having this problem? I am on the latest firmware. I’ve tried Firefox, Chrome, and IE and get the same result each time.


This is also happening on my Peplink Balance 30 with Firmware 7.1.0 build 3504. I had to delete and re-enter to get the proper order.


@mdr and @kaczocht. Just to confirm. Have you click the Apply Changes after you changed the rules order?


@TK_Liew The Apply Changes button does not activate in order to let you click it when you change the rule order. It stays greyed out and remains unclickable.


We have confirmed this is a bug. You may delete and re-define the rule for the temporary workaround. If you need to change the firewall rules frequently, please downgrade to previous firmware version.

We are working on the fix. Thanks.


Not sure if this would help in your specific case, but in prior firmware versions, the Apply Changes button sometimes stays grayed out after various changes (it’s been this way for several versions), but if I click over to another tab, say Dashboard, it will then be clickable.


I am experiencing the same problem with Surf SOHO MK3 . SW 7.1.0 build 1FB2


Hi all,

The special build to fix the problem is available here.

Can't change order of firewall rules


It works now but all rules are ignored when blocking specific inter VLAN traffic if “allow inter vlan traffic option” is active.
Same in the other direction. If “allow inter vlan traffic” option is off, allowing some traffic in the firewall has no effect.

Anyone else has this?



@Venn, we have tested with similar settings but it doesn’t show the same results as yours. Likely would need you to submit a support ticket for the team to investigate.