AP One Enterprise periodic lock-up

I have a Balance One with an AP One Enterprise running two Wifi networks. This is a new setup that has been running more or less smoothly for a couple of weeks. The Balance One is running a PepVPN link to a Surf SOHO at another site. Twice in the past three days, the Wifi has locked up to where devices lose their connection to the network and while the Wifi still appears to be out there, if you try to reconnect, the AP reports that the password is incorrect. In both cases, the only solution was to reboot the AP One and then everything is instantly back to normal and all devices reconnect automatically. I am not positive that every single device is kicked off the network, but it is certainly true for most. Tonight, I came home to find all of the IOT devices in distress (having been in that condition for six hours). I could not get to them to reconnect, but my phone which came in the door with me was perfectly happy. Again, the reboot solved the problem. I welcome any suggestions! Thanks.

What firmware are you running on the AP? There were numerous firmware updates, many of which were not successful (I’m being polite). The current firmware is good. I’m running 3.6.0 Package ID 1158 which I believe is the most recent.

1 Like

I’m running 3.6.0 as well. I upgraded shortly after the install. Thanks!

Another thing that might shed some light on this problem is that the AP seems to continually disconnect and reconnect devices. I see nothing in the event log to explain what happens when it locks up, but the log is full of lines like this:

Oct 03 11:18:50 2935-75E8-7F74: Client C4:9D:ED:19:78:5E disassociated from Emerald
Oct 03 09:40:20 2935-75E8-7F74: Client A4:F1:E8:AE:93:86 associated with Emerald
Oct 03 09:38:50 2935-75E8-7F74: Client A4:F1:E8:AE:93:86 disassociated from Emerald
Oct 03 09:38:21 2935-75E8-7F74: Client 34:12:98:58:74:18 associated with Emerald
Oct 03 09:38:20 2935-75E8-7F74: Client 34:12:98:58:74:18 disassociated from Emerald
Oct 03 09:28:19 2935-75E8-7F74: Client A4:F1:E8:AE:93:86 associated with Emerald
Oct 03 09:27:09 2935-75E8-7F74: Client 34:12:98:58:74:18 associated with Emerald
Oct 03 09:27:09 2935-75E8-7F74: Client 34:12:98:58:74:18 disassociated from Emerald
Oct 03 09:26:50 2935-75E8-7F74: Client A4:F1:E8:AE:93:86 disassociated from Emerald
Oct 03 08:58:20 2935-75E8-7F74: Client E0:33:8E:27:F6:29 disassociated from Emerald
Oct 03 08:50:50 2935-75E8-7F74: Client E0:33:8E:27:F6:29 associated with Emerald
Oct 03 08:50:50 2935-75E8-7F74: Client E0:33:8E:27:F6:29 disassociated from Emerald

This clip is just showing one of the SSIDs, but both appear in the log. More often than not, the device is disassociated and then immediately re-associated. There are hundreds of entries per day.

@chklee, the log shows that the clients disassociated themselves from the AP, not AP disassociate the clients. This is different from the issue reported in your first post since the clients able to reassociate back to the AP.

For the reported issue 1 (client disconnected to AP but failed to reconnect. Reboot AP solved the issue), I need your favor below

  • Please check how many APs with the same SSID can be scanned by the clients in the affected environment. I just want to ensure AP One Enterprise the only AP for the client to connect to.
  • Provide the date and time when the problem occurs.
  • Provide the MAC address of the affected clients.
  • Download Diagnostic Report from the AP One Enterprise.

For the reported issue 2 (Clients associate/disassociate from AP One Enterprise), it could be caused by poor Wifi signal strength received by clients, clients roam between AP due to 2 or more APs with strong signal strength in the environment, power saving mode from the client’s wifi adapter and etc. On-site Wifi survey is the best approach to rule out the reported issue. You may need to get help from the local Peplink partner.

Thanks.

1 Like

I can understand that the clients disassociating themselves may not be the same problem, but it is unique to the AP One and is happening with immense frequency. It did not happen when I had the SURF Soho at this location and it does not happen at the other site where I have the same client devices. Importantly, every type of device on the network is reflected in the log. I see IOT devices like NEST thermostats and WEMO devices. I also see windows and Mac devices as well as IOS devices. It happens on both the base network (Emerald) and the guest/IOT network (Blue). I tried to upload the diagnostic report, but this forum does not appear to allow that file type, so I just added a TXT to the end of itAP_Log.txt (129.6 KB)
20181004_aponeenterprise_293575E87F74_diag.report.txt (177.2 KB)
. I am also attaching a text version of the AP Event log.

In terms of WIFI strength, I don’t follow how that would be a problem causing the AP to lock up. I am in a suburban area with a handful of weak detected SSIDs none of which conflict with this one. My SSIDs Emerald is served only through this AP One. The whole idea behind the AP One was to focus on one, professional grade access point to control my network. I have no other access points working here, so my Wifi environment is clean. Over the years I have had many Wifi configurations at this site and have never seen clients dropping connections and I have never had a router or access point that needed to be rebooted. So with all of that being said, I remain convinced the problem here is with the AP One (or the Balance). Those are the only new variables in my system. Either I have configured one of these improperly, or the device is defective. Sadly, I am leaning increasingly toward the latter because no one seems to be coming to the table with alternative suggestions. I can’t see spending more money (and my time) bringing someone in to survey my site when I know that all I have to do is reinstall my Asus router and discard the AP One. I will lose the seamless VLAN control and $250, but that may be the price I have to pay to move on.

So, I came home to find that once again the AP has locked up. This time it is exclusively the Guest network. The base network is still working fine. The event log clearly shows all devices being shed at one time:

Oct 04 14:26:50 Client 18:B4:30:05:95:C2 disassociated from Blue
Oct 04 14:26:50 Client 18:B4:30:01:54:32 disassociated from Blue
Oct 04 14:26:50 Client 44:65:0D:B4:78:A8 disassociated from Blue
Oct 04 14:26:50 Client 18:B4:30:12:D7:92 disassociated from Blue
Oct 04 14:26:50 Client 18:B4:30:12:FB:7E disassociated from Blue
Oct 04 14:26:50 Client 58:EF:68:DA:F9:B5 disassociated from Blue
Oct 04 14:26:50 Client 94:10:3E:B5:E1:11 disassociated from Blue
Oct 04 14:26:50 Client 58:EF:68:DB:08:19 disassociated from Blue
Oct 04 14:26:50 Client 14:91:82:D8:C3:7F disassociated from Blue
Oct 04 14:26:50 Client 60:38:E0:49:E6:35 disassociated from Blue
Oct 04 14:26:50 Client 58:EF:68:F6:03:B9 disassociated from Blue
Oct 04 14:26:50 Client 18:B4:30:08:62:E5 disassociated from Blue
Oct 04 14:26:50 Client 58:EF:68:BB:56:19 disassociated from Blue
Oct 04 14:26:50 Client 58:EF:68:F8:D3:3D disassociated from Blue
Oct 04 13:47:04 Client 60:38:E0:49:E6:35 associated with Blue

I believe this confirms that it is the AP that is “disassociating” the devices rather than the other way around. Does anyone understand a formal process for getting tech support from Peplink? When I sent an inquiry to the 3G Store where I bought this equipment, it fell on deaf ears. Thanks in advance.

@chklee

Normally, you should contact your purchase point for help as they are the local representative for us. Seem you can’t get anything from them, please open a support ticket here for support team to check.

1 Like

Thank you. That is super helpful!

@chklee

Please include the forum link into the support ticket so that support team aware on the request.

1 Like

I have the same problem. My devices lose their connection and when i try to connect again, i see the password error some times or some times not, but I cant connect to wifi , while I entered the correct password. I have a BP One Core and 3 AP One Enterprise and the firmware is up to date.

@chklee

Could you please update this thread on your progress resolving your problem. I am having the same issue as you, and am about to dump my peplink AP’s to try to solve the problem. Thanks.

And similar here. Wired network is fine but AP One Enterprise locks on multiple devices periodically.

As luck would have it, I have been digging into this further recently, as we are all held up at home taxing the network. Unfortunately, I have to report that I continue to have difficulties with the AP One Enterprise. It does not lock up, but it frequently requires users to detach and reattach to the wifi in order to maintain internet connectivity. Looking at the event logs, I still see devices disassociating and reassociating with the network rapidly (6 seconds is not uncommon). My conclusion is that the access point is not reliable for a high quality of service. We can get by, but it is a source of annoyance And I expect more. For trouble shooting purposes, I had people attach to my guest network which runs through an old AirPort Extreme. Both access points get dhcp via a Balance One. The airport maintains continuous connectivity, so I have to conclude it is the AP One. I have already played with channels, signal strength, etc. I was hoping there would be a firmware update that would help me out, but now, I am prepared to move on. I am tired of listening to the complaints. FWIW, I love the balance one and my surf soho.

1 Like

I had a very similar problem a year or three ago with clients needing to toggle wifi off, then on to “reconnect” to wifi periodically through the day. We are a mixed shop. Many of the affected clients were Apple centric (MacBooks, iPhones and iPads). However this was also observed on a few Lenovo clients and a few Android phones. There was no common denominator such as wifi radio chipset, vendor or distance from the AP.

I’ve copied my fix (with some light editing) from another post. I am running with these settings on our APs (AP One Enterprise and AP One AC mini). Wifi connectivity issues have not been a issue since.

3 Likes

Thank you so much louisbohn! Very helpful. Also read through the related thread. Have applied the beacon/interval settings you recommend. Will test for a couple of days and report back. Also read through the related thread. Did not implement the other changes there (have auto channels); will make a change at a time for now.

Just for reference, so others who read this know, my connectivity issue is that some devices show as connected to a given SSID, but there is in fact no network connectivity. It happens randomly, with an iPhone but also non-Apple laptops. Kind of what’s described in the linked thread from louisbohn.

1 Like

Here is a link to an in-depth article about wifi beacons, and how they affect performance. I used this article as the basis for the beacon changes that resolved the wifi connectivity issues at our shop. It’s a very good, technical read.

4 Likes

How does one set the beacon rate for APs under InControl2 management? I don’t see anything under the radio settings in IC2, and AP management is turned off at the device itself.

1 Like

Don’t know about IC2, I don’t use. However, on the Balance One itself, I had to click the ‘?’ and then the ‘click here’ link to enter advanced settings. Advanced settings do not show at first.

Capture

IC2 is the issue. When an AP is controlled by IC2 then local control is no longer available.
Screen Shot 2020-05-07 at 13.19.27

1 Like