Wi-Fi Performance on Surf SOHO MK3

I just bought a Surf SOHO MK3, which is running firmware version 8.0.1, and it appears to have terrible Wi-Fi coverage. Internet speed tests over Ethernet regularly clock in at 29 Mbps, but Internet speed tests from devices connected via Wi-Fi regularly measure only 5 Mbps. Even when I place my iPhone right next to the SOHO, it can only get Internet speeds of around 5-8 Mbps. (At work my iPhone is able to get Wi-Fi speeds well over 100 Mbps, so it isn’t a limitation of my iPhone.) My laptop, when connected via Wi-Fi and placed 20 feet away in direct line of sight to the SOHO is only able to get around 18 Mbps in Internet speed tests.

I expected business class performance, but I get the same or better Wi-Fi performance out of my consumer class Wi-Fi access point that is 15 years old. Is this level of performance typical of the Surf SOHO MK3? Does this indicate a defective unit (or defective external antennas)?

I have Rogers Ignite 500. The surf SOHO is rated at 120mbps max speed. I knew that going in but honestly nobody needs 500mbps or even gigabit at home unless you’re in the habit of downloading large files or house 100 people. :wink:

HD Netflix stream requires about 4mbps. So you got lots of room.

I’ve been using my Surf soho for a couple of months. Standing next to my surf soho on my iPhone 8 Plus I get about 75-80mbps on the 5ghz band. I’m also running on firmware 8.0.1. Note that speeds are slower in the 2.4 vs 5 band.

I have a pretty standard configuration (pretty much as listed on routersecurity.org). My IoT devices run in their own vlan and ssid. I also have different vlan and ssid for guests.

I don’t have QoS enabled but do have intrusion protection enabled. I’ve read elsewhere that QoS can severely impact performance but I haven’t tested it myself so can’t say whether this is the case with the surf soho.

I have a family of 5 pretty active users. We can have YouTube and Netflix HD streams going simultaneously and social media and web browsing and no noticeable lag or buffering. For December alone we used about 500gb on download and 55gb on upload.

I would scan your environment to see how many other wifi networks are present and whether you have channel saturation. Or perhaps a source of noise is interfering. Router placement is important as well.

For me, the 2.4 band is very crowded so I leave it for my IoT devices in their own vlan and ssid.

My main lan and ssid I enable only the 5ghz band and no one has complained so far. Teenager and wife satisfaction are a good metric to rely on.

I’ve had some concern as well when I first bought it but since having split my 5ghz and 2.4ghz bands performance has gotten much better.

Pretty satisfied with the Surf Soho. I’m tempted to talk my parents and in-laws into getting one and getting them off the ISP provided garbage.

I could then remotely manage and monitor and secure their home networks. :sunglasses:


Thanks. It’s helpful to know that the SOHO should be able to get speeds of 75 Mbps if the unit is not defective. I’ll try setting up an SSID to use only the 5ghz band and see if the speeds on that are better. Like you, I used routersecurity.org as an aid to configuring my SOHO, and I have intrusion protection enabled but not QoS.

Make sure you don’t have WiFi Wan enabled but not connected to anything. If its on and “Scanning…” looking it will cause packet loss on the LAN side of the WiFi on the same band resulting in very poor performance.

1 Like

Thanks! Switching to 5ghz band only (for devices that support it) definitely helped performance!

However, I’m still having a lot of problems with (some of) my 2.4ghz only devices and frequently dropping their connection to the SOHO (2.4 ghz Wi-Fi Connections to SOHO MK3 keep getting dropped).

Your results are not at all typical. Been using a Surf SOHO for many years. Even on the slower 2.4Ghz band, with a standard 20MHz wide channel, I get WiFi speeds of 32 Mbps on a wired connection that’s about 100 Mbps. And thats in area with many other nearby networks. Of course much depends on the WiFi device, but clearly your iPhone has the horsepower to go faster.

Obvious suggestions:
switch channels
switch channel width
switch wifi bands

Do you have a WiFi analyzer on whatever OS(s) you use? That is, some software that shows you gory techie details on the WiFi networks in your area? On Windows, look at WiFiInfoView at nirsoft.net.

Trying more than one WiFi client is the right approach, perhaps there is a pattern. Any chance you can try the router in a different physical location? Not just a different room in your home, but somewhere else? You can connect any router into the LAN port of another router, so perhaps take the Surf SOHO with you when visiting friends/family and trying it out there.

It can go faster.


Thanks. Those are good suggestions, and I’ll do some experimenting. But I don’t understand why Internet speed tests consistently show speeds of around 29 Mbps (the limit of my ISP) when connecting via 5GHz or via Ethernet, but on 2.4Ghz I consistently get around 3-8 Mbps–even when my laptop reports excellent Wi-Fi signal strength and a Wi-Fi connection speed of 144 Mbps. It seems like the connection is strong, but for some reason the actual Internet speeds on 2.4Ghz are really bad. And some of my computers and devices don’t support 5Ghz, which is why this is an issue.

This is a summary of the Wi-Fi analyzer findings (strong blue signal is my SOHO, the others are not mine):

What do you have set for RTS Threshold and Fragmentation Length? The SOHO’s defaults are different than the defaults on my old router (which were 2347 and 2346 respectively).

This is interesting and we’ve seen it before. @Michael234’s points are well taken. In addition to doing what he said, as a test I’d move your SOHO to channel 7 to minimize the impact of the overlapping signal on channel 4. It appears that this would reduce near-channel interference by about 5-6dB – not insignificant. However, before I did that I’d resurvey the environment to make certain none of the nearby transmitters have moved. The test I describe would help to determine if the cause of the situation you describe is adjacent channel interference.

I’d do this test with NO other clients attached to your router via wi-fi. If you have a client with a marginal signal that will likely slow the data rate significantly. (IOT/M2M devices are a particular risk as many have crappy wi-fi radios and poor antennas.)

I have no particular opinion vis-a-vis changing RTS/etc. One of the folks here has played with that a bit and I think he found that it was not worth the effort. But YMMV. I don’t think we have any systems out there where we’ve changed those parameters.


Can you check packet loss I use pingplotter to do so, that is how I discovered the WiFi WAN scanning issue. Again make sure WiFi wan is disabled on 2.4 Ghz unless its connected to a network, every time it scans LAN traffic is dropped causing huge packet loss.

If it is connected and you are using that for your internet connection it might be related to the radio being shared between WAN and LAN use although I am pretty sure I have seen higher throughput even 2.4 to 2.4ghz LAN-WAN on the SOHO Mk3.


I have never changed the RTS Threshold or Fragmentation Length. Over my head.

My Surf SOHO has to deal with 10 times as many SSIDs. Thus, interference from your neighbors is not likely to be a problem.

I suggested a new location because other things besides WiFi use the 2.4ghz band: baby monitor, microwave oven, cordless phone and no doubt others. If the problem is interference from one of these things, WiFi tools will not show it.

The Surf SOHO has a somewhat hidden support page that should be your next step. This image shows the URL and what the Ethernet details report looks like when all is well. This should show any type of interference, no matter what the source. On the downside, I just noticed it only does LAN and WAN, so it seems to lump Ethernet LAN with WiFi LAN. So watch it while there is no Ethernet traffic on LAN. Screen shot is from 7.1.2, maybe different on 8.0.2.

Another advanced option, one that’s really cool, is that the router can do an Ethernet packet capture, all by itself. This too is on the support page. If the Ethernet report shows trouble, the packet capture should show exactly where the trouble is.


I wanted to report back that I updated the firmware to 8.0.2 and rebooted, and now all of my 2.4Ghz clients have maintained strong connections for the past few days. I don’t know whether it was a problem with the firmware or just rebooting, but everything seems to be working fine now.

Before updating the firmware and rebooting, one of the 2.4Ghz devices that had trouble was receiving an IP address but in the Client List page no MAC address was displayed. After the firmware update and reboot, it now shows a MAC address.

devices with a blank MAC address in the client list are probably Android 10 devices using the new default of a random MAC address. More here