What 1G SFP Modules work with Peplink Balance 2500?


We got the Balance 2500-2sfp and we need to connect the balance to devices that only support 1G SFP.
We tried a couple of SFP’s that we have and the ones that got mention in the post -

None of the 1G SFP worked only the 10G SFP.
Because this post is from 2017 and no one added to the list it can be outdated.
Is there any 1G SFP/SFP+ that work with the Balance 2500-2sfp?

I’m adding the SFP’s that also worked with the balance 2500 that aren’t mentioned in the 2017 post -
Cisco | SFP-10G-LR-S (10G single-mode)
Cisco | SFP-10G-SR-S (10G multi-mode)
Cisco | GLC-TE (1G/10G RJ)
Finisar | FTLX8574D3BCL (10G multi-mode)


Thanks for your contribution, @Doron . It would be really helpful if Peplink were to keep a list of “known good” SFP modules current and available for any and all devices with such ports, including switches.


Hello @Doron ,

Note that both the Balance 2500EC and the Balance 2500-2sfp
SFP slots are only 10G capable, and not 1G capable.
( Peplink.com - Model Comparison )

1 Like

We’ve tested A LOT of SFP modules…

The SDX somehow supports the least amount… And never got to work reliably.
The SDX Pro supports below as far our tests went…


We also tried some of the Cisco modules but did not note down the models.


There is no option to use balance 2500 with 1G SFP?

1 Like

Correct, the SFP slots are 10G slots only.

1 Like

So I was just coming on here to post about this. I have a deployment coming up that is basically SDX to a bunch of SD Switches. The SD switches take 1G SFP modules, but the SDX doesn’t? How am I supposed to connect the router to the switches via fiber (required due to distance) if the SDX doesn’t talk gig over SFP? That’s basic networking hardware functionality that seems to be lacking…

Sincerely hope I don’t have to buy media converters after I just spent tens of thousands of dollars on Peplink networking hardware.


Hi Maxwell,

As far I know (and have tested) the SFP ports on the SDX and SDX Pro run multiple speeds (obviously depending on the module).

We’ve tested recently using Ubiquiti modules & DAC Cables which are functional.

We’ve done this using both Peplink SD Swiches, Cisco and Ubiquiti/UniFi Switches with no issues.



Hi Nik,

Thanks for chiming in here. Your advice seems contradictory to what I have seen on this thread. I noted that 10G seems to work fine for me, as I can link two SDXes with 10G SFP+ modules. What I cannot seem to get working, however, is any form of 1G Bi-Di SFP module, which is very common for our use. I tried 4 different brand/models of 1G bidi transceiver, and none of them would link.

The thing that really gets me is that there is no transceiver diagnostic in any Peplink device. Almost every other networking device of this caliber has a way to indicate transceiver information and diagnostics. Hopefully PL adds this feature in at some point, as I believe it is pretty critical for network engineers to use as a troubleshooting point.

I’ll see if I can get my hands on some UI single gig SFPs, or something duplex (maybe it doesn’t like the bidi firmware on the SFPs?) and see what happens.

1 Like

I have always found anything by FS.com works first time every time.

its our go to SFP and SFP+ module for Peplink routers and Switches.

They are just designed to be compatible with everything, and great price point too!

1 Like

Cool, thanks for the input.

Currently I am working with our SFP vendor to attempt to re-code some of the inventory that we have. Usually, the SFPs we purchase are Cisco compatible (mostly all Cisco shop), and the vendor has deduced that the Peplink devices seem to jive with Intel coded SFPs.

It is critical that we get a BiDi 1G SFP working in the SDX range, so we are on a mission to try and get something of the sort working in it. Stay tuned for results.

1 Like

Hello fellow Peplink integrators,
In Australia, we have standardised on SFPs from PlusOptic ( now owned by 4Cabling Australia https://www.4cabling.com.au/4cabling-acquires-plusoptic ); here is a URL to a filtered list for those interested.
( https://www.4cabling.com.au/sfp.html?trans_data_rate[0]=1Gbps&trans_data_rate[1]=10Gbps&trans_vendor=PlusOptic )

As a standard practice, we always test the SPFs before deployment, especially if the customer supplies them.

We have seen many a time where people have had issues due to:

  • mixing transceiver models/brands
  • mixing Single-mode/Multi-mode fibres
  • damaged or dirty interconnects/patch leads

I hope this is useful to someone; I’ve offered to get a bunch of PlusOptic to Peplink to formally test and update the compatibility list, though the offer was not taken up.

Happy to Help,
Marcus :slight_smile:

1 Like

Just an update to my endeavours here…re-coding my SFPs to intel code didn’t seem to change anything. Saw this odd message in support.cgi:

Link: Down Supported link modes: 10000baseT/Full Supported pause frame use: Symmetric Supported FEC modes: Not reported Advertised link modes: 10000baseT/Full Advertised pause frame use: Symmetric

Looking like the SFP ports on the SDX Pro only support 10G…but for some reason I can manually set the link speed at 1000M…very strange…have a ticket open with Peplink support.

@Captain_Nik - have you successfully run a 1GB fiber module in the SFP+ ports on the SDX and SDX Pro? I know you previously mentioned them running multiple speeds. If so, do you have a definitive part number of a 1GB fiber module that works in those ports from your testing?

We have indeed - I have both in our workshop, will go test for you Monday with the modules we have available.


@Captain_Nik awesome - thanks so much for doing that.