WAN interface failure with B20? Or?


#1

Folks, I needs some help here, please. We have a Balance 20 (HW3, FW 7.0.2) at a remote communications site which is fed by Time-Warner/Spectrum cable (WAN 1), Sprint 4G (via wi-fi adapter, WAN 2), and AT&T 4G (set as cold standby on WAN 3 - USB). Once in a while WAN 1 fails. (Always at the worst time, of course.) As I write this it shows “connecting” – but never does. So, as I write this, WAN 1 is down – still “connecting.”

Here’s what I’ve done to troubleshoot:

  1. Connected a laptop directly to the Motorola SB6141 cable modem. A 1GB link was established and connectivity was as expected.
  2. Rebooted the cable modem (several times) – no effect.
  3. Rebooted the B20 – no effect.
  4. Changed the WAN 1 port setting from “Auto” to 1Gb, full duplex, with “advertise speed” checked [going back through the forum this seemed to fix some situations for others] – no effect.
  5. Changed ethernet cables – no effect.
  6. Swapped WAN 1 and 2 (changed Spring 4G to WAN 1 and T-W to WAN 2 – Sprint 4G worked fine on the WAN 1 port.

So, where’s what I think I learned:

  1. All cables are OK.
  2. I had originally suspected a bad port on the B20 - not true as the other WAN worked fine there.
  3. The modem is OK as it worked fine with a computer connected directly to it.
  4. The frequently-recommended “solution” of locking the B20 port to 1 Gb did not resolve the issue.

At this point I’m out of ideas. I’ll appreciate some help. :confused:

Added: I just took one more step to troubleshoot: Going back through the forum I found where it was suggested to insert an unmanaged switch between modem and router. I did. Presto! Connectivity!

While this is a great troubleshooting step, and is OK on a temporary basis, we certainly don’t want to leave it that way! (Kludges are not welcome here.) Obvious question: “What changed?” – and the answer is “nothing!”

So, how should this issue be addressed in the longer term?


#2

Hello @Rick-DC,
What is the Port Speed & MTU size you have the WAN connection set to? Ask the provider/carrier for what they expect it to be for the connection to the modem/bridge.
image
We have been caught out previously with a combined Port Speed & MTU mismatch once that was causing a similar situation to what you have written, once we set the setting up manually as supplied from the carrier/provider the issues went away, the connection has not missed a beat since.
Happy to Help,
Marcus :slight_smile:


#3

Great thought, Marcus – as always. I’ll do that. The MTU is what I have my eye on. The modem has a 1Gb interface. and has been OK.

But if that’s’ the issue, I’m wondering why this problem only occurs about once every few months. I have to ask myself: “What happened at 0230 this morning to cause the problem?” Strange.

Rick


#4

I’ve been unable to find anything as to what the “preferred” MTU setting should be. But I found when I changed it to “Auto” after which I interpret to be a “negotiation session” the B20 once again connected to the Motorola modem.

I’m still mystified as to what caused the loss of connection between B20 and modem.


#5

Hello @Rick-DC,
I know that you already know of this though if the Balance 20 does it again, download the diagnostic report from the router and raise a support ticket with the report attached, the team at Peplink may be able to see something within the report that could isolate the issue.
Happy to Help,
Marcus :slight_smile:


#6

Yes, you are right, of course. I had hoped not to bother the folks at “Peplink HQ” but that will certainly be the next step.
I always appreciate your advice – TU!

Rick


#7

@Rick-DC, do you think forum below help?


#8

Hi TK. Yes, I saw that and tried it but was not successful. Right now the B20 is set at 1Gb, advertise speed and to negotiate MTU. These are not settings I would normally use but it seems to have worked – at least for now.
What is bothersome about this is that the previous setting (Auto, advertise and MTU of 1492) worked for several months – then failed.
Thanks for the pointer to that thread – all help is always appreciated! :grin:

Rick


#9

Please open ticket when this happens again. We wish to observe the problem. This is a problem of port negotiation based on our previous experience.

Thanks.