SB6121 Cable Modem


This is currently a popular cable modem in use today and it has a very picky Ethernet negotiation characteristic.

The fix is simple, just lock down the Ethernet WAN port speed to 1000Mbps Full Duplex and uncheck the “Advertise Speed”. Save and apply and then reboot the cable modem, you are good to go.

You may not see this issue on all of our devices but it definitely applies to the Surf SOHO.



So glad I found this post in the forum. This trick got me connected immediately, so please update your post to say that it also works on the ARRIS SB6183. Thanks!

I have this modem attached to a Balance 580. I get WAN failiure warnings from that device several times a day. The cable company says no problem on their end. I just made this change, hope this cures the problem!

Thank you so much for this great tip! I was getting desperate with that SB6121 failing to connect each time Comcast’s connection goes down and then back up, or when the modem powered was cycled. It took a manual procedure every time, to power cycle the SB6121 with the link between the Surf MK3 and the modem unplugged and then connecting the link after the modem had fully initialized… If I was not in the office when Comcast had an ‘event’ which they have a lot of, I would have no way to get the office back online until I get there…
With the fix above, the modem can cycle as much as it wants and the Surf MK3 just reconnects as it should…
Just another piece of info from when the I had the problem: when the modem cycles, it first succesfully connects to the Surf assigning a local IP address (it turns out they have a DHCP server for when the cable link is down). Then when the cable link gets established, it tries to renegotiate the connection and that is when the Surf Mk3 is unable to get it… that is, prior to the WAN port being locked at 1Gbps as recommended here.
Anyhow all fixed now, I don’t have to upgrade to another modem :grin: so thank you.

I take back my previous post in terms of this solution fixing the problem… It was just a big coincidence, some timing fluke of some sort. After I applied the fix I was not able to reproduce the problem, so I thought it was fixed, but 3 days ago, Comcast went down for 30 minutes and as before when the modem rebooted, the Surf MK3 got stuck into connecting mode… I had to power cycle the modem and the router per the procedure I mentioned to get back online…
Worse, I followed the other advice above and upgraded to the ARRIS SB6183 which was claimed to work by Zugig above and I am having the exact same problem with that one. I don’t think it is a port negotiation issue, because I get the same problem with a switch between the modem and the Surf. I think it is that DHCP server they run that is messing up the Surf. Because the initial connection to the modem always work (except it is not connecting to the internet so the Surf does not enable it) and it is when the modem gets the internet uplink and switches to online mode that it fails… Anyhow… I wasted enough time with Arris. I am going to switch to another modem … again. Disapointing.

Well, here’s another data point for you. We have tried the following four modems within the last year with Comcast:

  • Arris SB6121
  • Arris SB6183
  • Arris CM820A
  • TP-Link TC-7620

None of them have yielded acceptable performance. Sometimes they would connect irregularly but packet loss, as measured with PingPlotter and MultiPing was always extremely high – often reaching 10%. So, it it really a modem problem? We are convinced with the SB6121 it was; possibly the 6183 also. We are not so sure about the 2nd two l listed. In any case, we think Comcast has a serious problem with their network – so bad that sometimes we simply have to turn health checks OFF on Pepwave products.Comcast has been unresponsive. Sad.


Thanks Rick-DC! I have ordered a NetGear CM500, hopefully that one will just work! I almost got a TP-Link TC-7620, but given what you say above, I am glad I didn’t :slight_smile:

Rick and Peparn, I’ve had similar problems, including the Netgear. I tried every possible combination of connection test and port settings. In the last week my problems appear to have been cured with the latest Peplink firmware 7.1.1b2. I have no idea if Peplink actually changed anything that would affect the problem, but I’ve gone from 25 to 50 modem disconnects per day, to less than 1. That 1 is probably a legitimate issue with the ISP.


Very good info. TU Don. I think what we’ve been dealing with are actually TWO problems. Several of us have previously written about “issues” with Arris SB6121 and SB6141 devices “talking” to Peplink Balance routers. We strongly believe some of these events to be “Peplink issues.” We have two locations (both of which happen to be with Comcast) where I think we’re dealing with the aforementioned “Peplink issue” and severe packet loss issues. Sometimes it’s difficult to determine the locus of the real problem – particularly when we are hundreds of miles away.

I wish we had an environment where we’d feel comfortable trying beta software. Absent that, reports like yours are extremely helpful. :smile:

Edit/add: As I think about this, I wonder how many modems we’ve thrown away thinking it was a “modem issue” when the culprit was Peplink. I bet at least a half-dozen.

Thanks a lot Don, I am a starting a new thread about this specifically since it is not modem specific: Surf SOHO MK3 never finishes connecting to cable modem if modem reboots. How stable is the beta for you beyond this? I would hate to fix one problem and get 30 others because of the beta? Do you know how close to a release it is? (I haven’t checked yet)

1 Like

To be clear, my situation was never exactly as you describe. I’ve never had trouble with the initial router to modem connection, but it was not stable. Sometimes it would last 30 seconds. Sometimes it would last a few hours. I am using an Arris modem now, but it was the same with a Netgear. Reference Rick’s comment above, my situation is also only on Comcast.

I’ve had the Balance One running on 7.1.1b2 for 72 hours with no interruptions. I haven’t done any speed tests because I don’t have a benchmark from before, but the connection feels quicker. My WAN settings are 1Gbps full duplex, advertised speed is UN-checked.

I am changing the WAN settings to Auto now, and will report back in a couple days if there is any difference. Ideally it should not be necessary to use anything other than Auto.

Specifically with reference to Comcast, I have found their DNS servers to be unreliable. I’ve fixed several other Comcast installations by changing the DNS to public servers such as and Those other installations did not include a Peplink device. On the Balance be sure to UN-check “acquire DNS server address automatically.”


Thanks for the additional info Don. Indeed, a different kind of problem. In my case the connection is rock solid once it connects, unless of course the internet link goes down on the modem side and it reboots (luckily that isn’t too often on average).
It doesn’t look like the DNS servers would be problematic in my case (it is not the health check that fails), but at this point I am desperate, so I will try anything. I will report back here if it improves the situation. Thanks.

Rick-DC - can you suggest a modem that plays nice with Peplink routers? I may need one soon.

@anadyrgirl, now that the issue here has been understood and resolved (see the end of that thread for the link to a special build), we have been getting flawless performance with the SOHO MK3 with all three of these modems on Comcast: Arris SB6121, Arris 6183, and NetGear CM-500 .
Hope this helps.

1 Like

Hi. Before the special build of firmware was released we stopped using all Arris modems with SOHO and Balance routers. And, in one case a customer tossed his SOHO in the trash and replaced it with a competitive product because we were unable to help him resolve the “cable modem issue.”
I do know we have several TP-Link products in use but I don’t have the model nrs handy and can’t get at them tonight. You may wish to take note of the message sent you by @peparn, above. If we were to confront that issue today we’d try the special FW build. However, I should note that the problems we had were with SOHO HW2 and With Balance 20. ISPs were Xfinity/Comcast and Spectrum/Time-Warner.

1 Like

Awesome! Glad it’s working great.

1 Like

Thank you Rick! Peplink’s support through the forum is impressive.

An update. My SOHO surf router arrived 8/25/18. I bought it from the 3G store.* They provide an "Advanced Setup Guide" for home users who follow Michael Horowitz; he recommends the SOHO surf on his "Router Security" blog. Within a few hours I was set up without a snag or need to reset to the default configuration and start over. I could do it in less than an hour had I not been a complete naif. I updated the firmware with the special build 7.1.1s022-build1344; link (see below) found in sitloongs 8/21 reply in this thread [Surf SOHO MK3 never finishes connecting to cable modem if modem reboots - #35 by peparn. The router had no problem connecting with my ancient Motorola surf SB6121 and has worked flawlessly for 3 days now. Thanks sitloongs and the Peplink team for providing the special build!

I set up a simple LAN and WAN with most of the security features enabled. I have some more learning to do before I set up VPNs and the rest of the security features. What great control, though! I blocked an obnoxious redirect on the iOS Safari browser on my iPhone, which the iOS and Safari couldn’t block. Awesome!

I didn’t set up a POS VPN or other commercially useful networks. It looks like it would be straightforward using the Peplink "PCI_Compliance_Guide" post by sitloongs 8/20/18 in the “Router hardening” thread Router Hardening

I am grateful for the invaluable help I received from the forum, the 3G store and Michael Horowitz. Thanks to Rick-DC, peparn, Don_Ferrario, Jaywalker and all the others who took time to reply to my posts.

*I don’t know if this was the work of Peplink or 3G store packaging folks, but they used incredibly neat hospital corners with the packing tape – who does that? How is it possible? Amazing. The exterior engineering on the SOHO is impressive: the articulation and sturdy construction of the wireless antennae is miles better than the cheap plastic ones on my retired TP-Link. I think I won’t open the box to check the connections and inspect the board but it is probably as impressive as the outside. Nice work!