Talk Talk ISP needs username/password

Hi,

I’ve tried a search on the forum but not able to find anything about inputting a username/password for my ISP, which at the moment is Talk Talk. Also trying to connect with a Draytek Vigor 130 modem.

Any help/advice would be greatly appreciated.

Thanks,

Derek29

Connect Draytek to WAN of your Peplink device, set the Peplink WAN port to PPPoE and then enter username / password as usual.

1 Like

Hello @Derek29,
We use the Draytek Vigor 130 modems extensively with clients in Australia that are either still on ADSL or have transitioned to NBN’s VDSL service.
There are two things important with the Draytek Vigor 130 that you need to get right.

  • Load the latest regional county version of firmware for your ISP
  • Configure the modem into Bridge Mode

If you have already put some settings into the Draytek then we recommend that you factory reset the unit when you do the firmware upgrade and then start again, there are only a few screens you need to change things in, these are screenshots from a system running ADSL (due to be upgraded in a few months) where the default IP has been changed. (Note: the default IP for the Draytek is 192.168.1.1, we recommend changing this ASAP, see step 5)

  1. Firstly do the firmware, this shows a stable release we have been using
  2. Under General Setup, leave everything on “Auto
  3. Under PPPoE/PPPoA, for “PPPoE/PPPoA Client” select “Disable
  4. Under MPoA / Static or dynamic IP, for “MPoA (RFC1483/2684)” select “Enable” and setup you Encapsulation as required by you ISP (shown works for most ISP in Australia)
  5. This part is an option, though if you want to monitor and manage your Draytek when in bridge mode, we highly recommend changing the default IP, this is an example you can use.

Once those are done, you can follow @MartinLangmaid notes. You can also find more details here

Note: You will need to set up your management IP within your Peplink/Pepwave router to match what you did in step 5 above. If you use the same subnet as in the example, then you could put the Management IP of 192.168.100.254/24.

Happy to Help,
Marcus :slight_smile:

1 Like

Thanks guys for your help. Going to set up as you suggest, and see if I get a working internet.

Derek29 :smiley:

1 Like

Hi Guys,

Thanks for the suggestions, still no internet access! Think maybe change ISP from TalkTalk, because I know hardware working ok, just settings I can’t seem to configure. :confused:

Derek.

I’ve setup this configuration on BT in the UK and it works fine, check the PPPoE credentials and VLAN settings you need on the Draytek modem, if those are correct this should work fine for you.

Alternatively you could just use the Talktalk supplied device, plugin the Peplink behind that with Ethernet but this isn’t ideal of course.

As an example BT use standard credentials for VDSL connections, Draytek have a guide for that here https://www.draytek.co.uk/support/guides/kb-vigor-v2850-setup this has the relevant VLAN tag and username and password.

2 Likes