Surf SoHo MK3 and Sprint Zing/Netgear 771s not playing nice


#1

Just got the new MK3, issue is it won’t play nice with the Zing/Netgear 771s via USB. I have played with settings for hours, anyone have better luck?


#2

We will follow up with you since the ticket was opened. Please ensure the USB modem was connected to MK3.

Thank you.


#3

I’m having the same issue with the Mk3 and have an open ticket. Hoping we can get this figured out soon - I waited months for the Mk3 to release because it’s supposed to be compatible with the 771S, but this issue has been very frustrating.


#4

I can tell you support so far has been useless. They must be located in Asia somewhere because they do nothing during working hours and have sent me numerous emails that make little sense.


#5

Hi,

We have the standard practice to troubleshoot the USB modem connectivity issue. The reason we sent numerous emails is to do the further checking since we can’t see the SIM card IMSI, insufficient power for the USB modem since it was connected to MK3 via USB cable.

Engineering team suggests connecting the USB modem directly to MK3.

Thank you.


#6

Understood about the basic troubleshooting first, but in my case, I didn’t hear from the Support team at all yesterday after providing detailed information on my settings/configuration.

I’ve spent tons of time troubleshooting on my own as well to no effect.It seems pretty clear that this is a firmware issue at this point. Discussion here (and elsewhere) indicate multiple people are having this issue with the Surf SOHO and Netgear Zing - and that it was working correctly on older firmware. Unfortunately it’s not possible to downgrade from the current version, otherwise I would have tried that.


#7

Hello,

Has anyone tested their MK3 with the new firmware 7 that is currently in beta to identify if the issue with the Zing/Netgear 771s is still present? It hasn’t been mentioned yet so I thought I would present that as a potential resolution path to try.

Please find the link to obtain the firmware 7, in beta, here.

This link will take you to the open beta page, once there please read through and accept the terms and conditions. When you select the button indicating your acceptance you will be taken to a page where you can download the beta firmware.

Scroll down until you see the appropriate area and select the “SURF SOHO MK3” button. This will prompt you to download the file and once it is saved locally you can perform a manual upgrade within your SOHO.

Please utilize this link for directions related to performing a manual firmware update on your SOHO, reference “Method 2.”

Thank you for your patience while we work to address the issue related to the SOHO MK3 and Zing/Netgear 771s.


#8

Installed the beta firmware. So far no change - Surf SOHO still won’t connect/stay connected via USB tether.

Literally the only reason I bought the SOHO was because the 771S is listed as being compatible, so it’s very disappointing that it’s not working even with the newest firmware (yet is still listed as being supported…). I’ll most likely just return this to Amazon and go back to using Wifi as WAN on my other router, which was working fine for that purpose.


#9

Hi brainpattern,

I do understand your frustration with this matter, that being said it would be very difficult to test every device with every modem with every firmware release to ensure that compatibility/functionality that was once present is retained. Additionally each modem manufacturer can occasionally release updates for their devices which can impact device compatibility and functionality with certain Peplink products. I’m not claiming that is the case here, only that it is another variable that can cause problems from time to time.

As I understand your frustration, I think it would be fair of you to understand our position. I’m certain that the compatibility issue will be resolved in time and that with some patience you will be able to utilize the SOHO. I hope you decide that the SOHO provides enough feature/functionality value for you to utilize your alternate option until such a time as the compatibility issue has been resolved.

Thank you for your valued input, feedback and patronage.


#10

Understood and I appreciate the response. Let’s give the tech team a little more time and see what happens.

The other feedback I’d like to give however is that the support team should provide consistent windows when they’ll be actively working on an issue - for example, they only seem to be in contact in the evening, and yesterday I sent a lot of detailed information and asked for acknowledgement of receipt, but didn’t hear anything back at all yet. They asked me to set up an alternative WAN and leave it up, but I can’t do that for long periods of time. Knowing when they will be actually working on the case would be very helpful.


#11

Support was able to remedy the problem - turned out the APN/login information was set to incorrect defaults. For Sprint users, the APN should be ‘r.ispsn’ with no username/pw/etc. The Surf SOHO has been online for 12+ hours now without any major issues. It can take a while for the link to come up - I’ve noticed rebooting seems to help if it gets stuck at “Connecting…” for an excessive amount of time, but overall, it seems pretty stable so far.


#12

I now have a even stranger issue. Support has been in my router trying to fix and now the USB interface has disappeared from the dashboard. I can’t see the Zing or change these settings.


#13

We are still investigating the issue, we need you to obtain more info from the modem settings. Please follow up from the ticket.


#14

I am now having the same issue with the Zing/771S not staying connected to my Surf SOHO Mk3. Has there been any progress on a solution? I have tried changing the APN/Login information as mentioned above to r.ispsn with all other fields blank.

My event log just looks like this:
Jan 15 21:35:34
WAN: USB disconnected
Jan 15 21:35:05
WAN: USB connected to Sprint (192.168.1.4)
Jan 15 21:34:35
WAN: USB disconnected
Jan 15 21:34:27
(this continues to repeat)


#15

Peplink replaced my SoHo thinking it was a issue with the router, same issue as before. Its a software issue , my 771S works fine on my older SoHo running 6.1.2


#16

@Baron2877, I notice you opened a ticket on this. We will follow up with you there. Please help to connect the USB modem directly (not using any USB extension cable or USB hub) to MK3 for further checking.

Thanks.


#17

@Reelgator, I feel sorry for the situation you are facing now. Anyway, you have provided a valuable feedback which 771S works fine in v6.1.2!

Please help follow up in ticket and we will continue look into the problem. Thanks for your patience!


#18

@TK_Liew If I do that, you will not be able to access the router. The modem is the only internet access I have and it is currently connected by WAN as wifi. If you give me some notice, I can connect the modem to the router and use my cellphone hotspot for WAN but I cannot leave it that way


#19

The Netgear Zing was working perfectly with the Surf SOHO - I had 26 days of uptime, but as of this past Saturday morning, it will no longer tether via USB. I can’t get it to connect whatsoever via USB. It simply repeats “Connecting…” endlessly.

As far as I’m aware, nothing should have changed. I haven’t changed any settings, nor did either device appear to get a firmware update.


#20

@Baron2877, Appreciate if you can provide an alternative WAN connection and put USB modem as standby. Fyi, my timezone is MYT. Your ticket with me now.

Thanks.