Speedfusion One Link Constant Failure

Good Afternoon,

After carefully studying the three routers I noticed that the one router (HD2) that is working perfectly has an MTN # from Verizon while the other two routers (HD4) don’t. That is about the only difference in settings I can tell. I tried switching a SIM from the HD4 to the HD2 and it still won’t obtain an MTN and goes into “Link Failure.” Do you think I have 2 bad SIM cards here?

I have 3 Pepwave units 2 HD4s and 1 HD2. The HD2 is working perfectly but the HD4s have had intermittent issues. The main issue I am trying to solve today is that one HD4 uses TMobile, Verizon, and FirstNet. For some reason the Verizon link always shows link failure even though the signal is good. Testing that connection by itself works fine outside of Speedfusion. When Speedfusion is on then that one goes into Link Failure again. I have tried changing the health check to DNS and it hasn’t helped. Any other suggestions?

Thank you!

Dear @ml177,

sorry for a late reply. If the issue is still actual please create a ticket, provide your HD4 serial number and enable Remote Assistance


1 Like

I finally solved the problem, unknowingly Verizon turned off the SIM cards and reallocated the phone number. So in the future if anyone has a Verizon SIM card that shows connected in the PepWave but has no MTN “phone number” or showing all 0s you might want to check if your SIM card was deactivated for some reason.