Remote User Access Instructions

I followed this guide and cannot connect with OpenVPN to my Peplink MAX BR1 Pro 5G on Verizon.

I have tried UDP and TCP.
I have tried Split and All Traffic profiles.
I’m running OpenVPN Client on my MacBook.

I’m able to connect to other OpenVPN servers (not the peplink).

When I try to connect to the Peplink it times out.
I was surprised there were no firewall changes I had to make or Firewall rules added when I enabled OpenVPN.

I’m sure someone else has set this up before. I don’t think Verizon is blocking anything.

Thanks for the help!

@Erik_deBie are you still active on the site? I think your Remote User Access guide could use some updates, but I’m not sure where to go next to help with that.

Is the Verizon plan you have with the Peplink device a public IP and allows inbound access?

Or you can submit a ticket for our team to check it out.

I found no other Peplink owners on the Ford Transit USA Forum site who got this working either.
We’re all using Tailscale instead.

It works brilliantly since we’re running Home Assistant in our vans, and the HA instance can provide access to the entire subnet.

The question that we didn’t ask was are you on Verizon Wireless with a CGNAT connection? Then it would not be expected to work. There are never native inbound services in a CGNAT network.

In such circumstances you run a FusionHUB VM out at a cloud provider and your remote access is OpenVPN to the VM, which then maintains a SpeedFusion tunnel to your remote router.

Talescale essentially provides the central VM via their services, but if you want the SpeedFusion featureset then you can switch to FusionHub.