Pepwave SOHO MK3, FW 8.1.2, frequency hopping

Just wondering if anyone has seen this. I’m not sure how long this has been going on, and only discovered it when attempting to resolve a connectivity issue with a camera. Note that all of my WiFi networks have always been configured with both their 2.4 and 5.0 GHz networks enabled.

Specifically, in the AP Event Logs I am seeing that multiple connected devices are, every few minutes, hopping back and forth between the two frequencies. These devices are not being moved around (within the premises) when this is happening. it makes no sense to me why they would hop around. Am I just missing something obvious?

Thanks for any/all input.

Hello and Good Day

I have had that happen also in the past.
I made separate ssid for the two frequencies and it solved the problem.
So for devices that only work on the 2.4 have their own AP.
And devices that have 5 capability have their own AP.

So if the ssid is, CAM WiFi only tic the 2.4
And this ssid is, iPad WiFi only tic the 5
Here is our setup.

Thanks. I sincerely appreciate the response. I’ve pretty much done exactly what you did (after the fact), in killing the dual-frequency setup. I guess I’m trying to figure out whether my camera-related connectivity issues are really just a Peplink issue. I.E. the camera is suddenly unable to even successfully connect to the Peplink, but having also discovered that my other existing (stable, in one place in the house) devices seem to be continuously hopping around (even before yesterday, when I eliminated the dual-frequency configuration), I’m now not certain whether I have a camera problem, or whether this Peplink “oddity” is actually an issue. Even with everything now frequency-segregated, the camera still won’t connect, so my gut tells me that IT is the problem, but the Peplink thing sorta leaves me less convinced that it has its head in the right place, too.

None of this is helped by the fact that both devices (Peplink and camera) had recent firmware updates. I did roll back to 8.1.1, and that didn’t help, but I also could see in the logs that the hopping was occurring there (for my other devices). I would have thought a device would not disassociate itself from a frequency unless it decided that it was problematic.

Much as you have done (because I am in a somewhat rural area) I had previously selected specific channels. I use WifiInfoView to check out what else is being used, to avoid any sharing. Even though I verified no collisions in that setup, I tried disabling my dedicated channels, just to see if that made a difference, but it did not.

Anyway, I guess I am just whining… I do appreciate your input, and (at least) knowing that someone else has seen the same frequency hopping behavior. I’m probably going to have to break down, and buy a new camera, if for no other reason that to definitively rule that out as the culprit.

Thanks again.

Hi Serenity. I also use 2.4 and 5GHz devices with my SOHO MK3 without “hopping” issues with a single SSID. I have “Band Steering” set to FORCE in Advanced AP settings—this means any device capable of 5GHz must use it and the others use 2.4. Hope this helps.

1 Like

Oh wow!! Gosh… I semi-hate the question-mark thingees. I had tried like the dickens to be sure that I had clicked all of those things, to review what sat behind them. Obviously, many are just “help” related, but I COMPLETELY missed that one, and (obviously) had NO idea that capability existed. Well, I’m going to have to go back and completely re-read the manual, to see what other things I missed when I set all of this up a few years back.

THANKS for that. That will at least assist in better isolating where the fault lies (and it is what should have been done in the first place, regardless of my current problems).

And if you decide you may need new cams. This is a great option.

I try not to plug products but……

They are very versatile and cost effective. We have ten of these cams and never have a problem.

Thanks for the tip!

JUST TO FINISH OFF THIS TOPIC THAT I STARTED…

This whole problem that I was chasing is (was) a Peplink bug. ANYONE WHO IS RUNNING 8.1.2. on a Surf SOHO MK3, needs to IMMEDIATELY go to the Downloads page (NOT the Beta Firmware page), and download the version “8.1.2s052”, that you will see there, and install it NOW.

As alluded to earlier, what I was seeing was what seemed to be serious issues with my WiFi, which I eventually deduced as likely being specific to the 2.4 spectrum. It turns out that 8.1.2 seriously frak’ed up that spectrum. A camera (that is 2.4 only) that had been working perfectly fine, seemed to now not even be able to see the network it had been on, and I even ordered a new one, just to figure out if the camera was the problem. The new one arrived today, and was doing the exact same thing, and in doing another search (“Google is your friend…”), I stumbled onto a post where someone pointed out that “yesterday” a new firmware was released, and “lo and behold” it definitely fixed my problem.

All for what it is worth…

1 Like