Pepwave MAX Transit Router Health Check failure when using Microsoft Teams

I’ve had the Pepwave MAX Transit Router with the CAT 18 Modem for a couple months now with only a Verizon Wireless SIM. The router has been very good/stable, except when a computer connected to it is doing video conference calls over Microsoft Teams. When using Microsoft Teams with video, within 5-10 minutes I’ll receive a Health Check failure and the connection from the router to Verizon will drop, at which point I have to reboot the router to get it to reconnect to Verizon.

Currently I am using the SmartCheck setting for health checks and using Google’s DNS server IPs for the ping hosts. I have tried using different health check methods but the result always comes back to a health check failure. After a reboot the router has no problem reconnecting back to Verizon. This is also a bit odd since I believe the health check stops working at this point. I’ve let it sit as long as 10 minutes and it never reestablishes a connection back to Verizon, but it will reconnect if rebooted.

I use the router for multiple purposes(work, streaming video(Netflix, etc.), gaming, video conferencing(Zoom and Teams)) and I consistently get health check failures while doing video conferencing over Teams. As I’m required to use Teams for work this is a problem. I typically end up having to switch over to Teams on my IPhone over LTE, which works but means I can’t share my screen.

Any thoughts or suggestions would be appreciated.

This can happen (the health check failing) when the WAN connection gets saturated. You can increase the health check interval and the failure count as a workaround. The only reconnecting on reboot seems like a bug, I’d collect a diag report when it’s in that state and submit a ticket to Peplink.

We’ve seen this happen – occasionally – under similar circumstances. What happens when you set the method to “ping” to known-good, low latency hosts?

In a multiple-WAN situation health checks are really important. However, if you are in a single-WAN situation health checks don’t have a ton of value – either the WAN “works” or it does not. So, my second suggestion would be to disable it. (I think @JasonHilton’s observation may well reflect what’s happening here.)

What happens then when you try these two suggestions?

Thank you for your suggestions.

I had a conference call on MS Teams this morning. I had switched the Health Check to DNS with 8.8.8.8 and 8.8.4.4 as the hosts. HC failed within 5 minutes and I had to reboot the router for it to reconnect to Verizon. After reboot I disabled the health check and made it through the remaining 20 minutes of the call, which is the best I’ve seen since I purchased the Max Transit. My previous router was the Max BR-1 running on the same Verizon plan I never had issues with it on Teams. I’ll reply to this thread after having more time to run with the HC disabled.

I have had the same problem with Zoom and Ring Central meetings. I am on my third Max Transit Cat 18 ( second one was non-functional and sent back on RMA). Both functional ones would work great on everything except these video conferences. Connected to Verizon without issues. Never disconnected while surfing or streaming.

When video conferencing, after about 10 minutes the meeting would freeze and would get a heathcheck WAN failure. Even though the dashboard then would say connected, I could not surf or connect to the internet. The device would then try to reconnect but would just spin saying finding IP address. The device would not be able to reconnect unless it reset itself or was rebooted. Once reset or rebooted, it connected fine and I was able to log back into the video conference. Then would happen again a few minutes later. Really a pain as this takes time. Have had several tickets with Peplink trying multiple things with the same result. Really frustrating that the replacement unit is doing the same thing. This occurred in multiple locations including big cities with super connection speeds so I know that was not the problem. I don’t know if it is a Verizon thing in that I only have a Verizon Sim. I know I am not being throttled in that I have a grandfathered unlimited plan without throttling.

Since this is my second unit doing the same thing and have read other reports by others (now including this thread of similar issues), my suspicions are that there is a bug in the CAT 18 firmware.

I have tried setting the Healthcheck to DNS Look-up and PING with no improvement and the same issue happening. Last night I turned the healthcheck off and I was able to complete my video conference. I will be have another conference tomorrow and this weekend and I will let you know what happens with the healthcheck turned off.

@farmdoc55

Similar situation here, Max Transit with a single Verizon plan. I used the same plan on a BR-1 and had no issues with video conferencing. Aside from video conferencing the router has performed very well. I live in a rural area about 2 miles from the closest tower. I typically have good signal at my home and will hit 40-70mbps on speedtest.net depending on the time of day. I received a nice bump in speed going to the Max Transit which is why I picked it up.

I do suspect this is a problem with the router. The fact that reboot is required to get it to reconnect points to a bug with the router. Using the same VZ plan, I can tether my IPhone to my laptop and use Teams without issues, so I don’t think the circumstances point to this being a VZ problem. However it is hard to go back my BR-1 since it is an older model without the LTE-A modem and usually tops out with dl speeds in the 20mbps.

I will turn HC back on and grab an diagnostic report and submit a ticket to Peplink, and then continue to run with HC off.

I also live in a rural area. I also get a good signal and run 35-70 on speed test. However, the same thing happened to me when I was in Houston getting over 90mbps on speedtest. I too don’t want to go back to what I was using before since this is working so well on everything else.

I’ll let you know what happens with the HC off. Maybe if enough complain Peplink will figure out a solution. :grinning:

I am having the same issue, and ONLY with Teams.

Since my last post I have had this occur Zoom, Teams, and Google Hangouts video.

I’ve tried some different things with Teams and have had the best result if I turn off incoming video. I can leave my camera on so people can see me but I can’t see anybody/audio only. Not ideal but it has been usable that way.

I continue to have the same problems with the CAT 18 MAX Transit. I have tried multiple solutions … AT&T sim card, turning off HealthCheck, different antennas, multiple settings, etc. Sometimes its works great with video conference calls and sometimes not. Very frustrating. Peplink is working for a solution per my ticket with them. Have not seen any issues like this with the CAT 12 modems.

I am having the exact same issue. Single SIM, Verizon, disconnects during Video calls (Teams, Slack and Zoom). After loosing connection I can only reconnect with a reboot.

I can confirm that disabling the health check does not help. The device just doesn’t recognize that it’s lost the connection. If health check is enabled it will continually cycle indicating that it’s attempting to acquire an IP address but never does reconnect.

I have Pepwave MAX Transit (MAX-TST-GLTE-G-T-PRM), firmware 8.1.1 build 5040.

PLEASE HELP!
Carl Lance

1 Like

Odd. I have the CAT-18 / 8.1.1 as well and I practically live on MS Teams throughout the day with many videoconference calls and screen share sessions on cell connection (T-Mobile). Healthcheck is set for http but was for a long time set for smartcheck before that. Probably jinxing myself but not had an issue yet

I do have “All VoIP applications” and “Microsoft” prioritized as “High” in the Advanced / QOS section. Perhaps worth a try and see if it helps all y’all? :slightly_smiling_face:

@meyc @farmdoc55 @kennethg.bush @carl.lance @Rick-DC Any updates to the issues you are/were having? It is now June 2021 and my max transit CAT18 is having the same issue. As you I have tried everything I can think of. Set QoS priorities, tried PING, HTTP, and SmartCheck settings as well as turned it off altogether. I have moved all wifi connections to disabled and only have cellular. I tried connecting to MaxT via wifi from laptop and RJ45 from laptop. Oh also upgraded firmware to 8.1.2.

Everything works great if I remove the MaxT from the picture and connect to my iPhone hotspot. Silly to invest so much and have this amount of issues. Please update with your progress or solution

brent3162,

Pepwave support updated my firmware remotely and it seemed to solve my problem. I believe they installed a “special” firmware, which had not yet been released in the normal automatic update channel.

However, I also switched from Verizon to AT&T for service fairly soon after that. I suspect that my problems were a Pepwave firmware issue related to Verizon connections specifically. Therefore I can’t say with 100% certainty that the firmware update resolved my problem completely.

I definitely suggest you speak with Pepwave tech support.

Carl

Still having this issue—both Pepwave and the vendor where I bought the router from are uninterested in troubleshooting the issue or acknowledge the problem. Its clearly a Pepwave issue, as you mentioned hotspot from my phone with the same carrier has no issues.

Kenneth: I don’t know who the vendor of your hardware is so I can’t speak to that issue. However, your assertion that Pepwave [Peplink, actually] is uninterested or has not acknowledged the problem is most curious. We have had the exact opposite experience. We raised a couple of issues (which you can read about elsewhere in the Forum) and I can tell you the Peplink support engineering team has taken it super-seriously. Indeed, I personally have had about a dozen, almost daily, status updates from these folks. Peplink could not be more responsive. Indeed, my opinion that these support engineers are absolutely the best in the business. Period.

Given your strong opinion about this, I’d recommend you reply to this message and cite the ticket number you received when you submitted your request for assistance.

Pepwave ticket number: 20110882

They said I had to go through the reseller where I purchased from, MobileMusthaves.com (they are an authorized reseller) which was extremely slow to respond to the issues, no phone support, actually refused to have a phone conversation, and basically gave up on try to diagnose the problem as the owner stated they only make $75 profit per router and they could not help troubleshoot the problem anymore because they were loosing money.

Regardless of their excuses or lack of support the problem still exists, whenever using Teams. To me, buying this router was a total waste of money as I can. Get better results and no disconnects hot spiting from my phone.

Just curious if anyone has tried routing their Teams traffic through the SpeedFusion Cloud? Same result? How about forcing the TTL to 65?

have you tried to set the flag for the fragmented packets in the tunnel?

ah sorry, thought there was a problem with the traffic itself, its a health check issue right?

Kenneth, sorry to hear you are still having issues. I purchased a new service from AT&T today. Replaced my Tmobile SIM and things seem to have improved. Have you thought about requesting a new SIM from AT&T? I still have issues when using the TMobile SIM but I am thinking it is related to a bad piece of equipment locally with a TMobile cell tower. But working with Pepwave through the ticket I raised nonetheless.