Peplink Router eMail Notification and Google

My domains use Google GMail services for email operations.

As of this week, Google has disabled email from less secure mail clients. That now includes the Peplink Routers.

I used this to send out email alerts and also text messages from Peplink Routers.

Anyone have any ideas how to solve?

I use a google domain email alias. You have to generate an app password in your gmail account and use the one time generated password as your credentials in the Peplink email settings.

1 Like

So i need to setup the GMail account the router is using as a 2 Step Verification to generate the code to work?

I think GMAIL enforces 2FA now… in any case, once your logged into Google account, manage account > Security > Signing in with Google and go to App Passwords.

Generate the app password using the device and app dropdowns… choose Mail as APP and descriptive device so you know what it is if ever you need to delete.

When you generate, it’ll show a password… which you will use in the Peplink email notification smtp password. You can’t recover this password later, so copy it into the peplink smtp password textbox, or copy it temporarily somewhere.

here is my config:

SMTP username is the first part of your gmail before the @ symbol.

1 Like

If you are only emailing to yourself inside your own domain, you can always use the restricted domain aspmx.l.google.com on port 25 with old school SMTP.

1 Like

OK. Finally got it working (I think). 2FA was turned off for entire domain which was why I was not seeing the option to turn it on at user account level.

Thank you