Setup of Email Notification and Google SMTP using App Passwords

I am unable to use google for outbound SMTP traffic. I read the related articles (Configuring Email Notification with GMail SMTP - #6 by ricdom) and (Peplink Router eMail Notification and Google - #5 by thebigbeav) and the info included did not resolve the issue. Looking at the debug output the router is connecting to the smtp service and google is returning that
“IP550-5.7.1 [] The IP you’re using to send mail is not authorized”
Steps I took:
Went into my google profile and generated an app password (mail>specific name, received a 16 character unique psswd)
Configuration of SMTP dialog in pepwave max-transit

Gateway: , port 465 but also tried 587 from one of the older posts no luck.
Used gmail address and unique 16 character psswd from google.
Tried with and without security if no security I get the following
This is an automated message generated from MAX_TST_83C9 (Pepwave MAX Transit: 2934-DCA2-83C9 running 8.0.0s071 build 4240).
With security I get the following debug output
<initialization w/google, hanshake etc) and then at the bottom:
If you are reading this email, your Email Notification settings are correct.

Pepwave |
Nov 14, 2021
[->] .
[<-] 550-5.7.1 [] The IP you’re using to send mail is not authorized
[ERROR] [sent .
] [result 550] [expect 250] unknown response "550-5.7.1 [] The IP you’re using to send mail is not authorized

What firmware version are you using?
This is what my settings looks like:

Thanks for the heads up that we were running an older firmware 8.0 vs 8.13 which we upgraded to.
I re-entered the google unique app password to force a save and apply changes to make sure that any of the config software from the last version were cleared out by re-saving. Unfortunately now it just times out with no debugging response. Writing this update from the connected device so not a connectivity issue timing out.