Peplink Balance 20 unresponsive

Hi I was hoping someone could help me i’ve filed a ticket but not sure how long until I get a response and i’d like to try some things during the weekend if possible. Anyways i’ve had zero issues with my balance 20 since I bought it in March of 2018. I’ve always updated to the latest firmware I was using it primarily for the dual Wan since I live out of town so I have two LTE Modems connected to it. Scroll to today and my internet was down completely but I could connect wifi to the LTE Models. Tried a regular reset on the router and then hard reset to no avail. After that I disconnected all my wan and lan cables but left my laptop plugged direct into the router it will not even so much as assign a internal lan ip on any of the lan ports even if I set my own ip on the laptop still nothing. Hopefully someone else has had these problems and can help? Thanks. - Aaron.

Forgot to mention the Status LED is Amber and does not change and it does not blink. As well I have it protected by a UPS so it never goes down.

No one has any thoughts of anything I could try? Support told me today that my warranty was only good for just shy of 4 months on the unit from the date I purchased it (Brand new i might add) and they have no interest in helping me so hopefully someone else here can? Thanks for anything that might come my way.

A solid red status light means there is an internal hardware error and it cannot be recovered from this state.

All of our products come with a full one-year warranty and if you didn’t register your product on our site than this is the reason why you are not seeing the full year. Thanks

1 Like

So what would be the cause of something like this? As I stated before its behind what I thought was a good UPS CP850PFCLCD. As well there are 2 more switches and the 2 LTE modems that run off the same unit niether of which have had any issues so am I to assume its just bad hardware? I need another router now as i’m back onto my old TPlink multiwan router as my backup and if this is the lifespan I can expect I’d be better off buying a consumer grade router. I realize hardware can fail but generally there is a cause for it to do so. I’m just waiting on support to get back to me on ticket # 9090181 to see if this can be repaired. Thanks.

Sounds like the Balance has been completely reset. DHCP may not be enabled. Set your computer manually to / and connect to one of the balance LAN ports. You should get a ping response from which is the Balance default address. Once confirmed you can log in at that same address http (not https), using the default username/password of admin / admin.

1 Like

Thanks Don. Tried setting that earlier to no avail it doesn’t even return a ping nor will it connect to I don’t suppose the SD Card has failed in it? Perhaps there is a way to get a copy of that data and replace the card but I don’t suppose that is accessible here on Peplink. Does anyone here know if there is a way to check that card? Thanks.

I’ll keep messing around with it but it seems doubtful. Apparently my money isn’t good enough. Just ordered a new Ubiquiti Router since I can’t seem to even pay to fix this one and my old TPlink while it works drops connection too much for my liking. Too bad I liked the features and the ease of use on this but when support won’t even give me an answer as to why (would have been willing to pay shipping) good features don’t mean much if I can only expect 17 months out of a commercial product. I know what i’ll recommend at my workplace now we’re only the largest trucking fleet in North America. I’ll keep checking back if anyone has any ideas.

I don’t mean to come across as rude to support but your implementation of warranty when purchasing new products needs some work as none of this was made aware to me that registration was required in order to receive a full warranty (I realize that I am outside the period and will pay for my mistake) but the only answer i received more than once was you are out of the warranty period. I felt like I was dealing with warranty issues on a personal vehicle at a dealership (no one likes that). It’s just very frustrating that I can’t even get an answer as to what might have failed (obviously don’t want to buy a new router every year and a half). Thanks again best of luck and hopefully I am the oddball out on this (known to be unlucky here),

Even the device is not registered, the device still can consider to have 1 year hardware warranty from the date you purchase the device. For such case, you only need to show the proof of purchase info to support team will do. Again this is only limited to valid purchase for new devices. You mentioned 17 months using the device then the device having hardware problem ? This is definitely exceeded the 1 year hardware warranty come with the new purchase. I believe, this is the reason why support team is saying the device is out of warranty & base on the Warranty, Support & Return Policies, no other option that support team can offer.

Default out of the box, there is a “Getting Started Guide” to guide registering the device for Warranty Protection & information. It should be included in the device box when shipped. Do you get your copy for the “Getting Started Guide” ?

Supposedly after you have registered the device, you should able to know the expiry date for the device hardware warranty, even email notification will be send before the warranty is expired.

Details FAQ for product registration can be found also using the following URL:

1 Like

@Aaron_Brooker Unfortunately the Balance 20 is part of the lower end models or a Velocity Series product. The cost of having an engineer take a look, fix and use new parts could exceed quickly the cost of the device.

About the 4 months of warranty, it is advised to only buy Peplink devices from Peplink Certified Partners. They will correctly follow up the warranty dates and support.

Please contact a local Peplink Certified Partner and maybe they have some ideas to help you further. Check if the SDCard is still in place might be a good start, different ways of reset or even try different network cable.

1 Like

Thanks sitloongs i’ll go find the box I received it in I don’t recall seeing that it was in a sealed box though when I purchased the unit. I thought it was a valid reseller when I purchased it at the time I didn’t see an option of buying it through Peplink like it shows now on amazon. As I stated in the support ticket as well I can stomach the money part but not knowing what caused it is a bigger concern to me. The out of warranty part aside if this was your router at say your home or workplace and it spontaneously died in a reasonably short time period (I have Routers 19 years old that still function) and could not determine what happened would you rush out to buy a second one if you had other options? That is all i’m getting at. I’m even willing to ship it back at my own cost if you are willing to tell me what failed on it as until I know if it was something on my end or some outside cause I can’t justify throwing my money away potentially. Thanks.

Thanks aldwinaldwin. I have tried a couple different network cables as well but thanks for another idea. Is it possible to clone the SD Card inside with another one of the same size or is it possible to ship the SD card in and have it checked out?


@aldwinaldwin is right for this. This is the reason why we don’t have such arrangement for the lower end model. Hope you can understand the difficult part on this.

1 Like

Interesting that Peplink does not want it back to do a post-mortum, the warranty issue notwithstanding. If it were our product we’d want it back just to see what failed so we could try to make it more reliable. “Just sayin …”

1 Like


:wink::wink::wink: We have sampling devices to do post-mortum but not all devices. For Aaron case it’s really not worth to send back the device.


So just to be sure there is nothing else you recommend trying on this unit? If so i’m going to toss it.


Yes, no option from the B20 if the LED status light is showing red. Normally the device need to get replaced after getting diagnosis (Hardware reset, Power on & Off test, Disconnect all cables test and etc) that i believe you have done all the requires test.

1 Like