Peplink 580 vs ASUS Router (cheap router)


#1

Peplink 580 Hardware version 3, Firmware 7.1.1 build 2460

compared to Asus RT-AC88U

The test done by :

    1. Same Modem from Unifi (telecoms), direct connection to Peplink 580 or Asus Router and direct LAN1 to Laptop. Speedtest using same server M1 (Singapore)
    1. Peplink WAN setting (PPPoE connection, NAT enabled, Always On, Upload 1gbps, download 1Gbps, Physical 1Gbps, MTU 1440, MSS Auto, VLAN 500, enforced priority, no QOS)
    1. Asus Setting (PPPoE, everything else auto setup)
    1. Modem to Peplink/ Asus – Cat6e cable
    1. Peplink/Asus to Laptop – Cat 6e
    1. Laptop Macbook Pro 15inch 2018 model
    1. Speedtest Using M1 server (on all test)

Step 1

  1. My download speed is 800Mbps. This has ben confirmed by my service provider.

Before starting, doing a speedtest using Asus Router to confirm that the speed of 800Mbps is really attainable. Speedtest shows Download of 825Mbps and Upload of 204Mbps.

Before starting, doing a speedtest using Peplink 580 to confirm that the speed of 800Mbps is really attainable. Speedtest shows Download of 465Mbps and Upload of 203Mbps

  1. According to performance comparison chart, Peplink 580 is rated at 1.5Gbps (way above the 80Mbps of the ISP).
    1. The Peplink 580 setting :
  • a) Current firmware version: 7.1.1. No update available
  • b) Wan Bandwidth upload and download set at 1Gbps
  • c) Outbound policy Enforced all to this WAN (any source/destination/protocol)
  • d) QOS (all same user group(manager)/ no bandwidth allocation / no application priority)

  1. Internet àModem àPeplink 580 or Asus Router àLAN connection 1Gbps to Macbook

Ping 1ms faster. Speed still same !

Back to Asus

Questions Required :

    1. This is a recent speed upgrade by the ISP from 100Mbps to 800Mbps
    1. No changes have been made.
    1. Subscribed Upload is 800Mbps (shown above)
    1. Router is Unifi 48port. Rated at 70Gbps
    1. When directly connected to Peplink or by Router, same speed. Download is around 425Mbps
    1. With direct connection is 825Mbps (Using Asus Router – default setting)
    1. All test was by wired WAN
    1. Setting port speed has NO effect on speed

#2

Peplink 580 Hardware version 3, Firmware 7.1.1 build 2460

compared to Asus RT-AC88U

The test done by :

    1. Same Modem from Unifi (telecoms), direct connection to Peplink 580 or Asus Router and direct LAN1 to Laptop. Speedtest using same server M1 (Singapore)
    1. Peplink WAN setting (PPPoE connection, NAT enabled, Always On, Upload 1gbps, download 1Gbps, Physical 1Gbps, MTU 1440, MSS Auto, VLAN 500, enforced priority, no QOS)
    1. Asus Setting (PPPoE, everything else auto setup)
    1. Modem to Peplink/ Asus – Cat6e cable
    1. Peplink/Asus to Laptop – Cat 6e
    1. Laptop Macbook Pro 15inch 2018 model
    1. Speedtest Using M1 server (on all test)

Step 1

  1. My download speed is 800Mbps. This has ben confirmed by my service provider.

Before starting, doing a speedtest using Asus Router to confirm that the speed of 800Mbps is really attainable. Speedtest shows Download of 825Mbps and Upload of 204Mbps.

Before starting, doing a speedtest using Peplink 580 to confirm that the speed of 800Mbps is really attainable. Speedtest shows Download of 465Mbps and Upload of 203Mbps

  1. According to performance comparison chart, Peplink 580 is rated at 1.5Gbps (way above the 80Mbps of the ISP).
    1. The Peplink 580 setting :
  • a) Current firmware version: 7.1.1. No update available
  • b) Wan Bandwidth upload and download set at 1Gbps
  • c) Outbound policy Enforced all to this WAN (any source/destination/protocol)
  • d) QOS (all same user group(manager)/ no bandwidth allocation / no application priority)

  1. Internet  Modem  Peplink 580 or Asus Router  LAN connection 1Gbps to Macbook

Questions Required for lodging a Peplink support :

    1. This is a recent speed upgrade by the ISP from 100Mbps to 800Mbps
    1. No changes have been made.
    1. Subscribed Upload is 800Mbps (shown above)
    1. Router is Unifi 48port. Rated at 70Gbps
    1. When directly connected to Peplink or by Router, same speed. Download is around 425Mbps
    1. With direct connection is 825Mbps (Using Asus Router – default setting)
    1. All test was by wired WAN
    1. Setting port speed has NO effect on speed

WHAT SHOULD I DO ?


#3

We has responded you below:



#4

Reply done what suggested and not working. See enclosed photos and attachments

What is the next step?

Yoga


#5

The technical support engineer already provided the suggestion but not getting your respond. Can you help to follow up with us in the ticket?

Thanks.


#6

Hi,

Was done last night.

Is this the suggestion?

https://forum.peplink.com/t/my-router-is-not-giving-me-the-expected-download-upload-speed-when-running-a-speedtest-how-should-i-troubleshoot-this/11750

If this is the suggestion, I have replied in the ticket. This was not sent to me but my local support. Please check with your support engineer.

Yoga


#7

Hi Yaw Theng,

Thank you for the suggestions.

I tried the setup. Windows laptop and Speedtest via LAN2. Got a speed for 372Mbps.

Just for your info the Asus info is enclosed and it is 738Mbps.

I still don’t understand why I do all this test.

The Same internet line, the same modem, the wan connected to Peplink /. Asus shows different results.

Asus is 800 and Peplink is 400.

There is no reason why change Laptop windows/Mac.

It is a Peplink issue and my local support /. Peplink support and Community still has not come with a solution.

This is likely a Peplink 580 issue / setting and only you can help.

Please do something

Yoga

Peplink 580 result

Asus RT-AC88U result is impressive

On 31 Oct 2018, at 3:18 PM, Yaw Theng via RT <support@peplink.com> wrote:

Hi Yoga, Can you help to perform the following: - i would need your help to isolate further, please prepare a windows base laptop - connect the windows base laptop directly to lan port2 of balance 580 - perform the speedtest again - do provide me the download and upload bandwidth test result Thanks. Regards, Yaw Theng

The information contained in this email originating from Peplink is

intended solely for the specified addressee(s). Any further use,
copying and dissemination of the information without permission of
Peplink is prohibited. If you have received this message in error,
please notify the sender and delete the message immediately.


#8

Hi,

It has been over 2 weds. I was contacted by the local Peplink support and advised to use the Asus Modem as PPPOE and connect this to the Peplink 580. This is a messy option and did n to think I had to do this for a Peplink Enterprise grade item. With this suggestion I do get the speed over 80Mbps.

But this is NOT the correct way. Why the Peplink cannot do the PPPOE ?

ARE YOU TELLING ME IS FOR PEPLINK 580 CUSTOMERS, THEY MUST BUY AN ASUS MODEM AND CONNECT TO PEPLINK TO GET SPEEDS OF 800Mbps ?

You say it is a bug. Will this mean that it cannot be solved with this machine. Can you lend me a loan unit until you solve this issue?

Yoga


#9

Hi

I have complied with all your technical team reply. The suggestion was use an ASUS router in front of Peplink 580. I get the speed but this is not a proper way from your side. It is an embarrassing solution. Asus will be delighted to hear that they HOME grade device can beat a Peplink 580 enterprise grade. This is a stupid suggestion. Would not have bought an expensive Peplink 580 for me to have this kind of setup. Kindly look into my reply.

Yoga


#10

Thank for your valuable feedback on this matter. A bug had been filed for this and brought to engineering team attention. We need time to improve this and a workaround had been provided in the ticket for the time being.

Sorry for the inconvenience caused.


#11

The workaround does not allow me to port forward. I cannot get a public IP with this setup.

Thank you

Yoga


#12
  1. You need to do the port forwarding in Asus router.
  2. Configure routing for LAN subnets of Balance 580 in Asus router.
  3. Change WAN port of Balance 580 from NAT to IP Forwarding at Network > WAN > Select WAN interface > Connection Settings > “?” of Routing Mode > here.

Hope this helps