One DDNS for both WAN


#1

Hello,

I have a Peplink Balance 30, Firmware v4.8.1 build 1106

Can I have a ddns for both wan?

If one down, the other WAN up and renew the IP address of DDNS.

If I configure both WAN in “Alway-on”, what have the priority?


Dynamic DNS with DynDns.org not updating reliably
#2

Hello,

You can use the same DDNS host name if setup in Active/Standby for the WAN connections. Otherwise if both are “Always On” you would need to configure each WAN link with a unique DDNS host name.


#3

I have made this exact same request of Peplink twice. No resolution, unfortunately. What I think many users (certainly including you and I) need is, in a case of multiple WANs “always on,” to have a single DDNS host in use. Example: When all WANs are operational, the DDNS host would point to the WAN with the greatest capacity. When/if that WAN fails, the DDNS would then point to the “next best” connection. Configuring multiple WANs with unique host names is not effective – at all. Hopefully, Peplink will take this request seriously.
I can’t believe it would be a difficult programming effort to set a single DDNS host and prioritize the WANs with which it is associated. To avoid this issue would seem to “sell Peplink short” – and not let the users use this excellent hardware to its full advantage.


#4

I will move this thread over to Feature Requests for better exposure and to see if there are a lot of others looking for this.

From a support standpoint I can tell you that we already spend a great deal of time explaining to customers that DDNS does not work if you have a NAT’d IP from the ISP…


#5

Thanks very much, Tim. While I bet you DO spend a great deal of time explaining the issue of “DDNS behind NAT” [eeek!], I think we’ll all agree that that is not a challenge to the present issue. For our purposes here, we must assume the WANS have routable addresses and are NOT NAT’d. I do not believe the satisfaction of this request would worsen your support load but may well help with the “why does my DDNS no longer point to my router” question. :cool:

Thanks for “listening!”


#6

Why not do simply allow this, and IF the ddns provider supports multiple A records (which might be the reason that if it doesn’t, your problem relies there instead of the peplink restriction)
they would perform some form of loadbalancing on the incoming site. Oh, and IF the DDNS setting for same hostname is allowed to be set, add an option to unregister the ‘dead’ links though the ‘alive’ links.


#7

Hi,

Please try “Find My Peplink Address” for InControl2. This should able to resolve the multiple WANs IP for the devices with single Hostname. For more information, please refer to the KB below:

Note: Please make sure WAN having “Dynamic Public IP address” or Static Public IP address. Else “Find My Peplink Address” feature may not work.

Thank You


#8

I think you misread what we are talking about here sitloongs, people want the ability to, no matter what state the wan definition is in (active/backup), to have ANY wan being currently active connected, to be reachable through the SAME hostname advertisement towards dynamic dns providers (noted that the dynamic dns provider needs to support multiple A Records for the same name somehow).

This has nothing to do with the “Find My Peplink Address” feature :slight_smile:


#9

Hi,

I understand your concerns. What i propose here is the similar solution that work as the request below:
“no matter what state the wan definition is in (active/backup), to have ANY wan being currently active connected, to be reachable through the SAME hostname”

For more information on how “Find My Peplink Address” work, please refer to the explanation below:

“Find My Peplink Address” feature is the propriety InControl2 feature to allocate the WANs IP address for the device. “Find My Peplink Address” work similar as DDNS.

Example Setup:

Device connected WANs:
WAN1: 1.1.1.1 (Active)
WAN2: 2.2.2.2 (Active)
WAN3: 3.3.3.3 (Active)

**“Find My Peplink Address” feature enabled settings: **
abc.mypep.link

When user accessing abc.mypep.link basically it will resolved for WAN1, WAN2, WAN3 IP address. User browser/access client will decide which IP addresses (WAN1, WAN2, WAN3) to use when accessing to “abc.mypep.link”

You can define the service port for different inbound traffics:

https://abc.mypep.link for Webserver
http: //abc.mypep.link for Webserver
abc.mypep.link:25 for email server

Again, the main feature for “Find My Peplink Address” is to get the WAN IP address used for WAN1, WAN2, WAN3 for single hostname (abc.mypep.link).

Thank You


#10

Hi. OK, just to make certain I understand: It’s Peplink’s position:

  1. the only way to have the DDNS host point to the BEST (greatest throughput, lowest latency, etc.) and ACTIVE WAN is via InControl [we cannot use this in our environment]
  2. There is no other way to do this at present, and
  3. Peplink does not sees this as a feature really needed by its customers. No changes to the firmware is likely to enable the needed capabilitiy.

Just want to make certain I got that right and there is no misunderstanding on my part.

Rick


#11

Hi Rick,

I believe you hosted server in your environment and you don’t want any interruption on this. If so, WAN links with static IP and enable DNS settings (Network > DNS Settings) with Default Connection Priority in Balance router is the suitable solution for you. My own experience with DDNS, there is no guarantee on the consistency and having some dependencies on the DDNS server.

We definitely will listen and look into the request from the customer. Anyway if we found that there is a better option or solution, we will alway provide the best recommendation to our customer.

Thank you.


#12

TK: Actually, our experience with DDNS is excellent. Our DDNS provider has been extremely reliable. All we need to do is have the Balance router send an update the DDNS when the favored/priority/best WAN changes. The DDNS would not point to a lower capacity/high latency WAN until the “main” one fails.

Thanks for listening! :o

Rick


#13

So in the end this feature is useless for those who are behind non-bridged routers as WAN, hence why we want this to be possible through either Network->WAN->WAN(x)->Dynamic DNS Settings, OR have the balance determine it’s external IP itself, and pass that through to IC2.

Oh, and before you ask ‘why is your WAN not bridged’, well, simple, some ISP’s don’t provide IPv6 by default, and thus need to be able to have the router make a tunnel connection, like with me on the draytek vigor 130. Since IPv6 MUST be provided by the WAN (and the peplink has no method of setting up the v6 tunnel in itself) in order for the balance to work with ipv6. I’m stuck with non-bridged connections.


#14

OUTsider: Yes, agreed. And, further, InControl may not be in use and even if it is, one must be able to SPECIFY the DDNS address in other applications, e.g., the Peplink iOS Router Utility, webcam viewing software, etc.