Newbie struggling with internet dropping

I ran a test overnight with a Balance 20X (with Cat-18 modem, Firmware 8.1 RC3) and a MAX BR1 Mini (Cat-6, Firmware 8.0.2) set up with identically provisioned AT&T plans.

In the morning that Mini was showing as connected, but no data was flowing and I had to reset the cellular module to get online.

The Balance 20X on the other hand was working fine.

I hope this helps you narrow down the root issue - we are definitely seeing a lot of reports popping up now of AT&T issues.

At the very least, I am puzzled why the SmartCheck Health Check is not detecting the connection as having gone down on the Mini so that it would attempt to recover somehow.

  • Chris

Reporting back - outbound DNS stopped again and had to reset the modem the past two nights to get AT&T traffic flowing. Getting frustrated now… Still have a ticket open with little feedback…

[Firmware - 8.0.2s046 build 4437]
[Pepwave MAX Transit Cat 18]
[Health Check - Disabled]

Might I ask why you chose to revert back to the old firmware? I have a Max transit Cat 18 and 8.1.0 RC3 addresses a bug related to LTE/3G and version 8.0.2s122-build4468 addressed a bug related to band selection. So by being on that old firmware there are at least 2 bugs that need fixing in the code. I’m not saying they are causing your issue, but just something to think about.

1 Like

@Legionetz Because the DNS traffic issue was not resolved after applying the firmware. Maybe I need to default to factory → apply the update and see if that helps. I have a peplink rep on the ticket but not a lot of help beside offering build4929

FYI - we’ve been doing some digging, and the AT&T issues seem to be widespread and not just impacting Pepwave routers.

The best theory I’ve heard is that it is AT&T’s HTTP proxy servers that are locking up after a certain period, since when the connection drops web traffic is impacted but it seems that already established VPN tunnels stay up, and other protocols (like IMAP) still work as well.

I think this is primarily on AT&T to fix - but it would be great if Pepwave routers could detect the situation and reset the cellular modems. Re-establishing the connection fixes things every time.


  • Chris


Thank you for updating the status here and very appreciated that.

We do see the same behavior for some of the customers that using AT&T that HTTP & HTTPS traffics no longer able to route (Not all websites).

From the analysis, we confirmed the HTTP/HTTPS packets is sent but not getting reply from remote servers. We also setup some test HTTP/HTTPS server to confirm whether the HTTP/HTTPS packets sent are reaching to the remote servers but the results is negative that the traffics sent is not even reach to the test servers. That shown that the issue is on the service provider level.

Do you tested the WAN health check HTTP method ? This should triggered the WAN health check failed and cellular WAN will be reset after failed sometimes.


We have 10+ MAX BR1 ENT that started doing this.
We have ATT sim cards. Grandfathered accounts.
The pepwaves will stop passing web traffic (yet I can still log into them remotely and they show good on smartcheck.
Also I can ping from a laptop behind the pepwave… just can’t pull up a website.
When I reboot the pepwave it comes back up working.
If you look under STATUS->WAN QUALITY->CELLULAR the “latency” says “no latency”…

Just a stray thought: Since this seems to be AT&T throttling (essentially) HTTP[S] traffic, try routing that traffic through a speedfusion connection to a SpeedFusion (solo) server or a SpeedFusion Cloud (thereby avoiding the HTTP[S] ports for the traffic).

Please report back.


1 Like

Yup exact same issue here. I’m able to remote into the network and reboot the device via web admin.

Hopefully you have a ticket going…

Its not a throttle thing. The internet straight up stops working. Like if you go to google chrome and go to it will not load. BUT I can ping (google dns server).

I can also remote into the pepwave from another location. If you go into the WAN quality reports the “latency” blue line just stops. But the cell signal is still good…

The moment you reboot the pepwave it all works again

1 Like

Yes, it’s getting old. It seems to happen about every two hours or so.

Instead of a reboot, I just toggle the 3G/LTE selection and it forces it to reconnect. The reboots were getting too tedious.

i’m having the same issue and had created this related thread

i had the problem again about 2 hours ago; here are the details. let me know if there are other tests i should be adding:

Date and Time: 7/30 5:54pm

Does the problem occur on multiple client machines? YES

Can you ping (i used a new domain, that i’ve never been to for each step) from a client computer? YES (a lot of times in the past i’ve not been able to do this)

Can you traceroute from a client computer? YES (a lot of times in the past i’ve not been able to do this)

Can you ping from another client computer? YES (a lot of times in the past i’ve not been able to do this)

Can you traceroute from another client computer? YES (a lot of times in the past i’ve not been able to do this)

Can you connect to devices via ports other than 80 and 443?

  • SSH (on port 6xxx)? NO

  • NTP (TCP port 13)? YES
    cat </dev/tcp/

  • SFTP (port 22)? YES
    sftp [email protected] (password is password)

  • WIFI Call - interestingly, I got an iphone wifi call during the outage, and it came through and worked no problem… so I assume that doesn’t use 80 or 443??

Can you connect to the peplink modem and login as admin? YES

Can you ping from the modem? YES

Can you traceroute from a client computer? YES

Anything relevant in the event log? NO

I downloaded the diagnostic report in case it’s needed in the future

Good to know about the pinging. When it first started happening with, I swear that I was able to do it from my Windows laptop but couldn’t get the browser to open any URL. Then it became 100% packet loss, so I just assumed the first times were a fluke. I was also able to ping from the modem.

ok, so my test results over the last 3~ days are consistent with the report below and the previous report i posted. i get the same results each time…

interestingly during the outage loads, and searches work… but no other website i try work (though i only tested around 10~). i know for sure i’d tested in the past and it did NOT work, no website i tried worked - so i’m not sure what changed and why that one site works consistently now but no others do. i also don’t understand why sending slack messages failed, but i received messages…

Date and Time: 7/31 8:57am US ET (it also happened again just now, same results)

Does the problem occur on multiple machines? YES
(e.g,. Your laptop, phone, other machines, etc all can’t connect to the internet)

Can you ping from a client computer? YES (34ms latency avg.)

Can you traceroute from a client computer? YES

Is it all websites? Do any work?

Can you ping from another client computer? YES (53ms avg.)

Can you traceroute from another client computer? YES

Can you connect to devices via ports other than 80 and 443?

  • SSH? NO

  • NTP (TCP port 13)? YES
    cat </dev/tcp/

  • SFTP (port 22)? YES
    sftp [email protected] (password is password)

Can you connect to the peplink modem and login as admin? YES NO

  • Can you ping from the modem? YES (29.4ms avg)

  • Can you traceroute from a client computer? YES

Anything in the event log? NO

I downloaded the diagnostic report just to have it…

Does the problem resolve itself? No (after 15 min i forced 3g only, it came back online, and i went back to forcing 4g only; faster than rebooting )

Just wanted to chime-in as I posted in the RC3 thread that I noticed something funky with AT&T. In the location I am in, I have never seen 3G. I loaded the 8.1.x RC firmware and started seeing 3G quite frequently. Before it was always LTE-A or LTE. I thought it could be the RC firmware or perhaps just coincidental timing with when I decided to load the firmware and its actually a cell tower/an AT&T issue? But this seems pretty widespread… although its not unheard of for cell tower radios/firmware to have issues with certain radios in client devices (I saw it happen once before years ago).

I was experiencing constant drops on my WiFi calling which led me to setup Speedfusion Smoothing. I never had issues with constant drops before. I could drag the cellular connection to disabled and then re-enable it and it would get LTE-A or LTE. Running a MK2. BTW, we’ve had some of our hottest days in the past week or two… wondering if temps are playing a role…

Perhaps someone wants to start a thread at: or ?

Hi all, same exact issue for me as described in this thread. I spent $300 and replaced the Pepwave Max with a MoFi, and the issue still occurs. So it it definitely an AT&T issue.

I was told by my carrier that it’s due to increased usage with work at home, but if that were the case wouldn’t it have been going on prior to now? June 28th it started for me. Starting to think AT&T is having a much bigger issue affect fixed wireless installations.

@Matthew_Rice: I don’t think I noted what plan you are on – you may have said and I missed it. Is it a plan intended for use in a router or hotspot? Or is it a “tablet” plan or a SIM intended for use in a phone? Pre-paid or postpaid? And, can you say (in general terms) where you got it?

1 Like

I am now noticing tons of disconnects on AT&T whereas I never noticed this before…

@ Peplink support team ticket # 20070808


PS. I started this thread on HoFo:

1 Like

For me, my plan is a data only plan, intended for use in data only devices, not intended for use in a tablet or phone. It is post-paid. Obtained from AT&T directly.