Need help with using DNS-O-Matic


Now that I’ve upgraded to firmware 5.4, I’d love to figure out how to use the updated UI to actually use DNS-O-Matic from my Peplink gateway instead of a system hanging off the LAN. I’ve filled in my email / password information but the “Hosts” area confuses me: DNS-O-Matic doesn’t deal exclusively in hosts — it deals in sending IP address updates to one or more services that it is setup for (which themselves may or may not deal in “Hosts”: for example a DNS-O-Matic service for OpenDNS as in my case). The “Hosts” field is a required one in the UI and seems to require a FQDN (which DNS-O-Matic doesn’t need or use for all its supported services).

According to the DNS-O-Matic Web site for my account, it hasn’t even “heard from” my Balance 20. This may be indicative of some other issue, or may just be a “mismatch” between what the Peplink is sending and what DNS-O-Matic is expecting for OpenDNS setups.

Please advise with a working example of what a DNS-O-Matic setup in your UI would look like, with a screenshot of the related service (preferably with OpenDNS) setup from the site so that I can matchup X <–> X between the two interfaces.




Okay, for all you other DNS-O-Matic users out there…

DNS-O-Matic’s API will update all the setup services if a blank host is passed to it, but since the Peplink firmware requires a host value they (DNS-O-Matic) does provide as a means of getting the task at hand done. I changed my configuration in the Peplink UI to specify this hostname and immediately saw that DNS-O-Matic had received, and registered the IP to itself and on to OpenDNS.

I had to dig into the DNS-O-Matic API documentation to find this hostname, so perhaps calling it out somewhere either in the firmware’s UI help or in the documentation (or both) would help future users of the DNS-O-Matic service.




Hi Marty,

Thanks for your tip. In the next firmware, we will simply hide the Hosts field when DNS-O-Matic is selected. Then all records under the account will be updated.



Thanks for sharing your DNS-O-Matic config with us.

Glad to know that everything is working well for you. Now, enjoy your Peplink!


Hi, I know that I am responding to a 7 month old thread… :slight_smile:

First, I am pretty sure that the firmware 5.4.7 does not hide the Hosts field, but that is not the biggest issue.

In order to get this to work, you need to identify two networks at OpenDNS - one for each WAN connection.

Unfortunately, when OpenDNS gets updated via DNS-O-Matic using the approach above, things get complicated. Even if you can get it to work at all, both OpenDNS networks get the same WAN address.

OpenDNS needs to know your IP address as it changes from your ISP

For example, these are the addresses for each WAN, associated with my OpenDNS account:

OpenDNS Network Name — IP Address
================== ========
MyNet1 ----------------------------
MyNet2 -----------------------------

When Peplink updates the DNS-O-Matic site, both OpenDNS networks get the same IP

OpenDNS Network Name — IP Address
================== ========

This is because Dynamic DNS settings run for both WAN ports…

I think that in addition to the HOST name alone, perhaps the OpenDNS network name could be sent? I’m not sure…

So, the only way I can think of to do this is to create two OpenDNS accounts and two DNS-o-matic accounts… :frowning:


Ummm… I would think we want one DNS-O-Matic account for wach WAN?

Peplink WAN1 > DNS-O-Matic #1 > OpenDNS #1 and DynDNS #1 etc.
Peplink WAN2 > DNS-O-Matic #2 > OpenDNS #2 and DynDNS #2 etc.

Or you are looking at something like

Peplink WAN1 > DNS-O-Matic > OpenDNS #1
Peplink WAN2 > DNS-O-Matic > OpenDNS #2

In this case we want to use for WAN1 and for WAN2. I am no expert in DNS-O-Matic. Anyone else has more experience in DNS-O-Matic?


You have displayed and explained it much more clearly than I did.

^^^ This is what you would have to set up to make it work. You need two DNS-O-Matic and two OpenDNS accounts for each Peplink WAN connection. DNS-O-Matic and OpenDNS are paired…

I don’t think this is what I’m looking for.

I have OpenDNS, a single account login. I have two networks defined in the account, to be linked with the Peplink WAN1 & WAN2. The OpenDNS networks share the same web content filtering rules. Now, how can I update the IP address for each one?

Right now, I can’t update both OpenDNS networks via a single DNS-O-Matic account.

If I use, then both OpenDNS networks get the IP address of WAN1 (or WAN2 - whichever connected most recently).

I can’t create two DNS-O-Matic accounts that access the single OpenDNS account; the accounts are paired - they are created separately, but they are connected.

Bottom line is that you have it described right - you need two DNS-O-Matic (and therefore two OpenDNS) accounts for each WAN…

For me it is not a big deal, I use my cable modem as Priority 1, and my DSL as Priority 2. My OpenDNS settings work only with my cable modem. When the cable modem is down, when the DSL is working, I have no web content filtering via OpenDNS.

In any case, thank you for your help and interest! I continue to be impressed with Peplink and will certainly recommend your products…


Thanks. Yes and I think this is because DNS-O-Matic isn’t quite designed for multi-WAN but rather to provide redundancy in dynamic DNS services in a single-WAN environment - in a single-WAN environment there is no need to bind two OpenDNS accounts to the same DNS-O-Matic account and hence no mechanism to update one of the two OpenDNS accounts that is bound to the same DNS-O-Matic account.

And if you have a minute, we will much appreciate it if you could share some experience with our products here.


Done! Thanks again!


Thanks for your kind words. Glad to be of help. :slight_smile: