MiFi6620L & peplink SOHO internet connectivity issue


#1

I have a Verizon mifi 6620L tethered to a SOHO router and use it as my home internet source. This setup worked great for many months, but recently it has become very spotty.

If I disconnect the MiFi from the SOHO and connect directly to the mifi via wifi, it works without issue. When I reconnect the mifi to the SOHO and tether it barely works.

The 6620L can tether and shut off it’s internal wifi, and it also allows tethering while broadcasting it’s own wifi. I have tried both modes, and neither work. Interestingly, although the mifi wifi network is fine when untethered, if I select the option that allows tethering and having the mifi broadcast its wifi, both the soho network, and the mifi wifi do not work.

I believe the problem started when I upgraded to 6.3 firmware on the SOHO, and has steadily become worse. It is now at the point that it is unusable.

Any tips are appreciated.


#2

I reverted from 6.3.3 Firmware on the SOHO to 6.2.1 and it seems to work. I found the link below which may indicate I have a setup problem, but the resolution is not clearly posted. Again, any tips appreciated.


#3

I have restored both the mifi and the peplink to factory settings. only changes on mifi were to change DNS server to 8.8.8.8, & 8.8.8.4

Only changes to pepwave surf soho
Disabled all connections other than USB
Changed IP to 10.0.01
Changed DHCP IP range to 10.0.0.10 to 10.0.0.250
Changed DNS servers to 8.8.8.8, & 8.8.8.4
Changed SSID & password to my choice

Still not working well.


#4

We have customer with the same Mifi device works fine on v6.3.3. Can you share what is the status shows on the Mobile Internet? Have you enable tethering on the Mifi when it connects to Surf Soho?


#5

I enabled tethering on the mifi. The internet status shows as green and
connected. I have been running this setup for almost a year without issue
until recently.

Although I did not mention it in my orifinal note I also have a pepwave
IP55 bridge re-broadcasting the wireless network under a different name. I
am currently checking to see if that is the device causing the issue.

My MIFI IP is 192.168.1.1

The SOHO IP has been changed to 10.0.0.1 per this discussion
http://www.evdoinfo.com/content/view/4384/63/

The default IP for the IP55 bridge is 192.168.20.1, I have tried changing
that to 10.0.20.1 but it has not resolved the issue.

Joe


#6

May I know this is your connectivity?

Clients(10.0.20.x) )))Wifi))) (10.0.20.1)Device Connector IP55(10.0.0.x) )))Wifi))) (10.0.0.1)Soho(192.168.1.x) —> (192.168.1.1)Mifi 6620L —> Internet

If the connection above is correct, please do me favor below when problem occurs:

  1. Ping 10.0.20.1 from client PC. What is the result?
  2. Ping 10.0.0.1 from client PC. What is the result?
  3. Ping 192.168.1.1 from client PC. What is the result?
  4. Ping 8.8.8.8 from client PC. What is the result?