Max Transit Duo Router with Starlink 12-48V POE Modification


It seems there was some issues when using connecting Starlink using its own Ethernet adaptor to the WAN port of Max Transit Duo (and some other routers), at least in the past.

For example:

I recently upgraded my router’s firmware to 8.4.1, and I have done the 12-48V modification for my Starlink set up (i.e. feeding 12V DC to a DC-DC converter to get 48V and then feeding the 48V to a POE injector).

Haven’t tried connecting Starlink to Transit Duo’s WAN port yet (via the POE injector), but I would like to know if anyone have tried it on firmware version 8.4.1, does it still have problem with this setup?


I had no issues with 8.4.0 and I also have no issues with 8.4.1 as I have upgraded I think a month ago.

No issues with my Max Transit Duo running the latest firmware 8.4.1. Been using Starlink powered with 12v-48v in our RV for the last 2 years. The Dishy is plugged directly into the Pepwave router (not using the Starlink router or ethernet adapter).

No issues at all using it this way.

You can enable the Starlink integration which gives you some status stuff like if it’s Stowed or not.

But I remember you had to use a switch: Starlink connect to the switch and the switch connect to PepWave router WAN port, right?

Or can you connect Starlink directly to PepWave router WAN port now and have no performance issues?


If you are using the Starlink Router with ethernet adapter, I had to use a switch in between the pepwave and Starlink adapter.

However, if Dishy is plugged directly into the Pepwave (with modified cable), you can plug it directly into Pepwave with on issues. This is how I’m running mine.

This is good to know. I will try when I get a chance. Thank you very much!