Manual DNS setting not overriding automatic DNS

I have been using a Balance 20 for about a month. It is running firmware 8.1.1s048 build 4990. I have two WANs, and one is configured with manually specified DNS:

When I look at the WAN details on the Dashboard, however, that WAN’s DNS is listed first, before the two than I want it to use:

image

Is there some way to force it not to use the WAN’s automatic DNS, and only use the ones that I specified?

Thank you!

It is a known web UI bug and it doesn’t affect your operation. We have filed this bug.

2 Likes

Thank you for letting me know @TK_Liew !

Determining the DNS being used can be complicated. There are DNS settings in browsers, OSs and routers plus there is old and new DNS. A list of testers is here
https://www.routersecurity.org/testdns.php

If there are DNS settings in a browser, then different browsers on the same device can/will return different results.

1 Like