ISP DNS appearing in Balance One

I have just received and installed my Balance One. All is working. I have configured it to use Quad9 DNS and not the ISP’s, by deselecting “Obtain DNS server address automatically” and selecting “Use the following DNS server address(es)”. However, in the dashboard, when I click “details” behind the WAN connection, I still see the ISP’s DNS and Google ( being added. I also see Quad9, but as a third and fourth DNS server.

Why is this? Why isn’t the Balance One respecting my choice to use my own DNS server settings?
Am I doing something wrong, or is there some hidden settings somewhere else?

What firmware are you running? I suspect that the Balance One is using the servers you set but that there is a web ui bug as per this post:

I’m sure @TK_Liew can confirm, but in the mean time run a DNS leak test and confirm which DNS servers you are actually using.

1 Like

Hi @MartinLangmaid, thanks for responding. I am running the latest firmware 8.1.1. I ran a DNS leak test ( and can confirm I only see Quad9 IP’s there. So you’re right, the router is respecting my choice but seems to somehow show incorrect DNS values.

Good. So no fault, but additional evidence that there is indeed a web interface display bug that needs squashing. Thanks for the update!

Seems to be aUI bug: Manual DNS setting not overriding automatic DNS - #2 by TK_Liew

Web GUI is showing four DNS servers, Google’s and the ISP’s as the first two, then my DNS servers as the third and fourth. CLI is showing only Google’s and the ISP’s when I type “get wan”. Seems to be a CLI bug as much as a web GUI bug?

@brightwolf, thanks for reporting this. I filed this CLI bug.