Login length and password length allowed


#1

Hello my name is Randy and I am trying to find out what length of username and password I can use to log into my Mark 3 SOHO router. I am also looking to see if some special characters are not allowed on the router for the password.

Presently, I have placed a 30 character username with small and capital letters along with numbers. My password is 42 characters user small letters, capital letters, numbers, and symbols. I know excessive but that is what I do.

I have the username and password on a thumb drive and just cut and paste in when I am logging into the router. Previously this worked fine in the router with no problems. However, lately every time I try to log into the router (firmware 6.3.3) it says invalid username and password and I have to reset the router password back to admin to get in. To make sure there was no error on my part I cut and pasted the username and password into the router, hit save, then apply, and logged out. I tried logging back in by cutting and pasting the username and password but no dice.

If we are not allowed to use certain characters or lengths of passwords or usernames the router should not be allowing us to save them and not be able to log back in, quite frustrating!!!

If you could please let me know the length of the username allowed and password along with what character types I could use in both I would appreciate it.

Thanks


#2

Hi Randy, wow those are long!

You mentioned it previously worked, so what changed? Did you change to a new firmware version?

The only problem I see with using copy and paste is that you are now relying on the clipboard.

Thanks.


#3

Hello @Randy89,
I did not know you could change the admin username, you learn something new everyday in this forum about the Peplink products, I’ll have to go figure out how you did that.

Can I ask, when you changed your credentials and found you could not login, did you also retry the login of username “admin” with the new password?

Have you considered using InControl2 with 2FA enabled? There is a guide by @Alan here on securing your routers via either the device console or the InControl2 platform (we prefer the InControl2 platform ourselves).

Happy to Help,
Marcus :slight_smile:


#4

Hi Tim:

Yes I know these are long but the change happened after I updated to platform 6.3.3. I was able to use those character lengths for both the password and username before on previous firmware. I know using clipboard is an issue too but that is why I also clear the clipboard after using it so neither the username or password are present.

Thanks

Randy


#5

Hi Marcus:

I changed the username by simply going into the router settings and where the username admin is and I type a different username in. Afterwards I put in my new password, hit save, then apply, and it is done. No I did not use “admin” and the password it may have worked but I did not try it. To test further to see if it was a username and or password length problem I reset the username and password again in the router settings then shortened the number of characters for both the username and password. Both were accepted and I could log into the router without problem.

I will review the information that you sent me as well about securing the router. Thanks. Have a great day!

Randy


#6

Hi Randy, would you be willing to upgrade to the new firmware version 7.0 and try again? Thanks!


#7

Let me follow up on this for you, I will edit this post with the information once available.
Thank you Randy.


#8

Hi Tim:

Funny you should mention that because I tried to update to the newest firmware and got “a error message stating I do not have enough room” for the update. According to tech support who I gave my serial number to a few days ago I have a mark3 soho router so I downloaded the firmware and tried uploading it but got that error message. Was the tech support guy wrong and I do not have a MK3 router?


#9

Hi Randy, on the Status page what Hardware Version is indicated?


#10

I went to the status page and I guess it is not a soho mk3 like I was told it said SUS-SOHO


#11

Hello Randy,
@ericwong has put together a guide on checking your hardware revision here

From the status page, you are looking for the Revision #

You may still be able to access the older Firmware versions through InControl2 with the Firmware Management options.

If you wish to do it via a direct URL, then the old binaries can be found here in the Downloads Archive at https://www.peplink.com/support/downloads/archive

Happy to Help,
Marcus :slight_smile:


#12

Hi Tim:

Here is the detailed information about the router:

Model: Pepwave Surf SOHO

Product Code: SUS-SOHO

Hardware Revision: 1

Firmware: 6.3.3 build 2252

PepVPN: 5.0.0

Modem Support Version: 1019

I have tried both versions of the download for the router being the mk3 download which was 39.5 M approx and the other download for the SOHO the 19.5M file. The 39.5 M file for the mk3 states it exceeds maximun limit and does not begin upload. The 19.5 M file download however, states it will take 6 minutes to complete upload. After a few minutes it says “Invalid Firmware Image”. So if you could help me figure out what is going on with the firmware update I would appreciate it.

Thanks,

Randy


#13

Thanks for your help Marcus

Randy


#14

Hi Randy, Hardware Version 3 would be the MK3 so you have an original unit. You will not be able to load firmware version 7.0.

Sorry for the confusion…

-Tim


#15

Hi Tim:

ok that clears things up thanks. When was version 1 manufactured?

Randy


#16

Hey Randy, that would be prior to March of 2015. Thanks.