Kind of says it all. Speedfusion doesn't bond for increased bandwidth

Well, this test kind of says it all. Bandwidth speeds inside the router interface don’t transfer to the desktop. My LAN is entirely 10G. Yes, I have Latency Cutoffs configured - every combination imaginable. Yes, I’ve tried Dynamic Bonding vs. normal bonding.

I think it’s time for Peplink to change the marketing material to specifically address cellular WAN bonding. I’ve been working on this for months with experts and still can’t achieve the claims of improved bandwidth with Speedfusion bonding. Will someone at Peplink please be honest about expectations? Thank you.



What model is the router?
What version is the firmware?
What is the Outbound Policy (OBP) for that pc that is running the speed test?

1 Like


Fusionhub:

Are you using Encryption on the SpeedFusion tunnel? (Its enabled by default) EDIT - just seen in your screenshot that encryption is off
The Transit series is rated at the following SpeedFusion throughputs;
Encrypted - 60Mbps
No Encryption - 100Mbps

1 Like

Sam the speed fusion test isn’t matching the speed test.
I’m wondering what path the speed test is taking.
Can you try an enforced policy to BeanFH.

Do a “what is my public ip” check to confirm it’s showing the sf exit tunnel ip vs one of the local cell providers.

1 Like

I have received significantly higher throughput than 100Mbps on the Speedfusion tunnel. At least this is what the Speedfusion test under Status has reported. This occurs early morning when my ATT link provides 100+ mbps.

Please note that my post mentions a problem with the router getting the interface-reported throughput to the desktop on my 10G network. There isn’t a network problem. There is a problem getting the router throughput to Speedtest running on a LAN client.

Encryption is OFF.
image

Jonathan,
Speedtest is using a server <1 mile from where my Fusionhub is hosted.
Also, the same public IP as the Fusionhub host IP.

Does it make a difference if you test using speedof.me or fast.com?
I’d test with OBP set to enforced just so that can be ruled out.

1 Like

Interesting.
fast.com won’t even connect.
speedof.me reports 7Mbps download.
speedfusion.net reports 28Mbps.

What is OBP?

OBP = OutBound Policy. The policy that you were doing as priority change it to enforced and run again.
Fast.com is a netflix site and there proxy and CDN servers tend to freak out when you have traffic coming from datacenters.

1 Like

OBP enforced to use Fusionhub.

Unless you are using Peplink’s monthly Fusion Cloud subscription, or 5GStore’s bandwidth subscription, links will aggregate not bond, as speed fusion will bond the bandwidth of multiple carriers within a point to point tunnel between two Peplink devices or Fusion Hub. Unless I missed part of this thread?

Dave

He has his own fusion hub and a device that supports bonding, so those requirements aren’t needed.
I’m trying to confirm that the traffic is routing properly.

2 Likes

Jonathan is correct. I have the free Solo Fusionhub license hosted at Vultr in the bay area. With Primecare attached to my Max Transit Duo, Speedfusion is included. Therefore, I have ALL of the Speedfusion facilities available to me for $6/mo. I’ve had this for 8 months now.

I just want it to improve throughput speeds like it is supposed to. Thanks.

1 Like

Gotcha Jonathan and Joel …

Interesting - pondering

@joelbean
Have you tried it with an enforced Outbound policy.
Once it’s setup I would also reboot before testing it.
I have seen some random times where it tends to lock on to the last policy
Also make sure the policy is in the top of the list and you have turned on expert mode.

You can also set the source to the specific ip you are testing from.
Also make sure you aren’t using any domain name Outbound policies rules as I think there is still a bug that can limit speed.

Basically you want to try to eliminate as many extra rules as possible so we can get a base line to start the testing from.

1 Like

@joelbean

What is the relative performance of each WAN link by itself if used within the VPN?

In other words, what throughput do you see on your test device if you build the SF profile with just a single active WAN link?

Your graphs from the WAN analysis suggets each of your upstream links is capable of 40-50Mbps, PepVPN will obviously add some overheads but testing one link at a time can help show if there is some underlying carrier issues.

For example I have been debugging an issue with a client where traffic via one WAN link outside of the VPN was significantly faster than if we tested that WAN link on its own with the VPN over the top, it turns out the data plan that the client has used for their SIM has some undeclared restrictions on certain traffic types in terms of throughput.

If one of your WAN links is possibly affected in that way and has significantly degraded performance vs the other it will in a lot of cases drag down the overall performance quite a bit.

2 Likes

You’ve had so many threads on this its hard to keep track. Perhaps having kept everything in one thread would have allowed us to follow everything you have tried more easily.

Please post a screenshot of all your Outbound policies.

There is a known bug that has been referenced here several times for policies with domain names.

Jonathan,
If you take a look at the Speedtest screenshots, you’ll notice that the originating connection says “Choopa.” This is a clear indication that that traffic is passing through the VPN.

Everyone: Please reread my initial post. The problem is that speeds reported in the router interface aren’t realized at the client.

If I could achieve the speeds that Status > Speedfusion reports, I would be content.

The Outbound Policy for the VPN is being used as is evidenced by Speedtest seeing the traffic coming from “Choopa.”

Here are screenshots with the VPN tunnel turned off and then turned on.

ATT ONLY in WAN pool:

Verizon ONLY in WAN pool:

TUNNEL OFF, both carriers in WAN pool. Outbound Policy chose ATT based on Fastest Response (see ATT in Speedtest). Don’t know why it chose ATT since Verizon was more performant.

TUNNEL ON, both carriers in WAN pool. Outbound Policy (see CHOOPA in Speedtest).

And with Speedfusion test in Status > Speedfusion.

THE PROBLEM IS that the available throughput/bandwidth is not getting to the client.