Guest wifi doesn't get IP address suddenly (had been working)


#1

Good Afternoon

We have two networks set up (untagged main network and VLAN guest network)

This had been working nicely for around 6 months through a few firmware updates on the Balance ONE and the Switch without issue.

About a week ago, clients on the guest network stopped getting an IP address (even when an IP is entered manually, there is no connectivity - iPhones display “No Internet Connection”)

We have the following in the network;
Balance ONE (Using a single WAN)
Peplink Switch
4x AP ONE ENT
1x Untagged LAN (192.168.1.0/24)
1x VLAN (172.10.64.0/24 VLAN ID 11) (Inter-VLAN routing DISABLED)

The APs are controlled by the Balance ONE and the VLANs are controlled by IC2. The AP on the Balance ONE is disabled.

The only thing that I can think of that was changed was the deletion of a subnet in the IC2 VLAN management that was been distributed to the devices (something like 10.10.1.1/24) which is not a subnet that we set up or would of used in this situation.

Is this VLAN required by IC2 if you are using the VLANs from IC2? If so how do we get it back?

We changed the Wifi configuration so the guest wifi is on the physical LAN and the clients get an IP address and internet access.

I have checked the following;
-Port settings on Balance ONE - all set to Trunk and ANY VLAN
-Port settings on Switch are all Trunk and ALL networks

It seams to us like the VLAN tagging on the Guest wifi is not happening at some point between the APs and Balance ONE.

Thanks


#2

Please open ticket for us to check all the Vlan related settings from InControl2, Balance One, SD Switch and AP.

Thanks.


#3

Hello @GNO-2014,
I’ve noticed an issue with the IP address range you have for your VALN 11 network.

This is an invalid private network range, have a read of these two articles from Wikipedia

Start with fixing that and see if the situation improves.
Happy to Help,
Marcus :slight_smile:


#4

True that!
Have now changed to 172.16.64.0/24
Everything had been working with that subnet for a few months though!
Thanks


#5

Hello @GNO-2014,
Check on any of the previous IPs you’ve been using in your DHCP offering (and the old VLAN Gateway IP), if any of these are now an active Public IP, then there is part of your problem.


Happy to Help,
Marcus :slight_smile:


#6

Hi @mldowling
There have been no IP’s dished out in the network this month but from IC2’s data, I can see that the following IP’s utilised data last month;
172.10.64.100 40 Gb
172.10.64.101 5 Gb
172.10.64.102 1 Gb
172.10.64.112 266 Gb
172.10.64.113 34 Gb

All these public IPs are assigned to AT&T U-verse are not responding to pings.
These IP addresses where happy using data and no users reported error for the previous 6 months


#7

This has now been solved with the help of @TK_Liew

The default VLAN on the switch had been removed so any VLAN traffic could not pass through the switch.

After following @TK_Liew instructions below, everything is now functioning normally.

Thank You

From TK

Problem

  1. Mismatched of Native Vlan between AP, SD Switch, and Balance One.
  • Native Vlan for Balance One = Untagged
  • Native Vlan for SD Switch = Vlan11
  • Native Vlan for AP One Ent = Untagged

So, Wifi client who connects to SSID Guest47 (Vlan11) will not grab IP from Vlan 11 of Balance One.

  1. Mismatched of Native Vlan between InControl2 and the devices.

Solution

  1. AP One Ent and others AP
  • Change back to Vlan11 for SSID Guest47
  1. InControl2
  • Create Tag for SD Switch (e.g. switch). We need to ensure the Vlan is correctly pushed to the corresponding device. Please refer to the link below to create the Tag:
    Tagging in InControl 2
  • Go to “Vlan Networks” of “GNO Office” Group. Create a new Vlan, suggest Vlan1. Then assign the new Vlan1 to Tag with “switch”. After that, edit the “Default Vlan” to the new Vlan1. The purpose here is to push Vlan1 to SD Switch and make Vlan1 as Native Vlan in SD Switch.
  1. SD Switch
    Please find the attached - SDSwitch2.png. Please ensure you choose the new Native Vlan1 after the step 2 above.

Your problem will be solved after proceeding 3 steps above.