First time setup - please help me


#1

Good morning all.

I am a small WISP using ATT and cable for my bandwidth.

I was previously using a Mushroom Truffle to do my bandwidth combining. Well, it died, and they are wanting an arm and a leg to repair it. So, I found a nice used Peplink 200 I thought I would try out.

I cannot get drop-in mode to work at all.

Here is a general layout of my network:

Cisco 2821 gateway to my ATT connection (3 multilinked T1s)
DNS1
DNS2
MikrotikRouter
Mail-server

All the above are connected by cabled network switch, and all have public IPs from ATT.

The Mikrotik handles all my DHCP leases for all my wireless customers, and also the routing for my point-to-point-wireless links.

Previously, I had the Mushroom Truffle in this. WAN1 on it connected to the Cisco above, then it (mushroom) was connected to the switch. I had my cable access attached to WAN2. It worked great…

I have followed the directions exactly for drop-in mode, but it will not communicate with my cisco at all.

Someone there please help me…

I can provide any other needed information.

Thank you.


#2

OK, I had to change my setup to get this to work even somewhat.

I have taken the switch out of the scenario. I now have this layout:

Cisco 2820 router–in dropin mode to WAN1 (ATT connection)
Cable modem - in DHCP to WAN2

I have the following machines connected to the LAN ports. All are on public IPs from ATT:
DNS1
Mikrotik
DNS2

I am getting Internet access on all PCs/customers thru the Mikrotik, so net access is working. However, it is only working thru the WAN2 connection, there is no data moving thru the WAN1 connection.

I get that the Peplink is checking connectivity on WAN1, then it reports that: Failed to receive DNS response from the health-check DNS servers for WAN connection 1. But public DNS server lookup test via the WAN passed. So please check the DNS server settings.

No matter what I do, I cannot get communications from the Peplink to either DNS server (cannot ping). Can someone clue me in as to how I can get this to work? This has been very frustrating…


#3

It is hard to tell what could be the reason why the drop-in mode is not working with the Cisco. Please open a support ticket, and we can look into it: http://www.peplink.com/contact/support/. A network diagram with IP addresses would be helpful.
Thanks.


#4

Hi,

I wanted to follow up with the issue you were having with the Balance 200 deployed in drop-in mode.

My initial feeling is that this is an Ethernet Duplex/Speed issue. You may want to try forcing the port to 100M Full Duplex. You can do this on the setup page for the WAN.

With regards to the DNS health check failures, I am wondering if you are using the ISP assigned DNS servers? I believe this may be caused by the fact that your DNS servers are located on the LAN side of your network. When the Peplink performs a health check for that connection, it will attempt an outbound connection on that WAN port. You may want to change the DNS settings for that connection to the ISP’s DNS servers or public ones like Google.

Let me know how this works for you.

Best regards,
Tim


#5

Tim, thanks for the reply. I actually got it all to work in drop-in mode. I had to put DNS/Mikrotik/mail/Cisco on the switch ahead of it, and then wire the switch to the WAN1 port. Cable is in WAN2 port.

It appears, however, that it is not using any bandwidth from WAN2, where actually I have more bandwidth available. Or let me say that all the traffic from my Mikrotik router (all my office PCs and all my wireless users) is going only through WAN1, and not through WAN2 at all.

And, my Real-time bandwidth usage has not changed in several minutes (even after refresh) - I have been running streaming audio on my office PC all day.

Both WAN interfaces show to be connected with no problems.

I am not any kind of routing expert, but it seems like that my Mikrotik needs to be behind the Peplink instead of in front of it.

Am I missing something here?


#6

Consider starting over and don’t use drop in mode at all. Your setup would look like:

T1 -> Cisco
T1 -> Cisco
T1 -> Cisco -> Peplink 200 Wan 1

Cable Modem -> Peplink 200 Wan 2

Peplink Lan -> DNS 1
Peplink Lan -> DNS 2
Peplink Lan -> Mikrotik
Peplink Lan -> Mail Server

The more critical issue for you would probably be use of subnets. Consider making the Cisco 192.168.1.1 and the Wan 1 side of the Peplink 192.168.1.2 (disregard if your Peplink Wan 1 can be assigned a public IP). Then use the 10.x.x.x network for your internal network, this should help with some of your routing issues. Another thing you could consider is using the Peplink as your DNS server. It’s not as flexible as having two dedicated DNS, but it’s easy to configure and part of a reliable box.

I installed a Balance 380 a couple years ago. Could never quite get the drop-in working smoothly, but after committing to a ‘normal’ IP address scheme I had the whole setup working in less than 30 min.

…also given your current setup, you may be able to transition to my suggestion without ever losing connectivity for your clients if migrated correctly.


#7

I have some questions about Drop-in mode. If you will look at my network diagram, all my servers, including my Mikrotik router, are in the same public IP range as my gateway Cisco router.

Here is what the manual says: “When operating in Drop-in Mode, Peplink Balance forwards the traffic between the LAN hosts and the router to WAN1 without performing any IP address translation.”

Does this mean that all my servers/PCs that are in this same IP range will strictly be using WAN1, and not WAN2?

Someone please clue me in here. This has been more than frustrating. I had zero problems with my Mushroom Truffle server doing the same thing.


#8

The traffic is distributed to your WAN connections based on outbound policy, and has nothing to do with drop-in mode. You also need to make sure that you have the proper values in the upstream/downstream bandwidth settings of each individual WAN connection. Please refer to the following KB article for more information:

Thanks,
Tim


#9

OK. I have tried this every way that it can be connected, but CANNOT get both WAN interfaces to work at once. Its either one or the other, but never both. These attempts have all been in drop-in-mode.

Here are my machines again (IPs changed…):

DNS1 = A.A.A.130
Mikrotik = A.A.A.132 - is the gateway router for several other PCs, all on private IPs handed out by this machine.
Cisco-router = A.A.A.129 - T1s are coming in on this. It is connected to WAN1.
Peplink = A.A.A.135

I have a cable connection on WAN2. It is currently running DHCP, but I can make it static if needed.

I have tried with some/all the above in the LAN side of the Peplink, and also attached to an external switch then connected thru the LAN, and also tried it thru the WAN1 jack.

Right now, the Peplink is strictly running on WAN2, using my cable connection. It says that health check failed for WAN1, but public lookup on the WAN passed.
I have tried this with my above DNS entered, and also with ATT DNS entered.

I have also tried this with some/all of the above servers entered in “other hosts on WAN segment”. But, still cannot get both WANS to run at once.

I have also had the ATT link on WAN1 running successfully, and also WAN2 says to be connected, but WAN2 never moves any data at all, it all goes thru WAN1.

The Peplink documented way to setup drop-in mode did not work for me, even when I entered my servers in the other hosts on WAN…

Someone tell me how to make this work, please!


#10

Ok, we need to start from scratch… Please send an email to support@peplink.com with your phone number and I will have someone from the Support Team give you a call.

In the meantime, please reset the Peplink to factory defaults and restore your network to the original configuration.


#11

Original network configuration is complete. Peplink factory default is complete.

Do you have an online chat? My phone has been ringing off the wall lately. If not, then can we please do this over E-mail?
Thanks Tim, this means a lot…


#12

Sure, we can do this via phone and email, but I do want to speak with you. Please send an email to support@peplink.com to begin the process.


#13

Dear Legoman / Tim :

We have had many ISP customers using both Peplink in Drop-in mode + Mikrotik and are able to use the bandwidth of all WAN ports on Peplink. also they are be able to route public IP addresses through Peplink and Mikrotik.

If your links are all up , you have to check outbound policies and create a good Weighted Balance related to your WAN speeds and use all available bandwidth.
If you have problems routing Public IP addresses through Peplink, you have to check your Mikrotik router and create an appropriate NAT rule and Masquerade to enable Public IP address routing for Mikrotik and your PPPOE clients.

Thanks.


#14

I had a similar issue, where one WAN on my 30, was downstream of another multi wan device. The health check would fail with the ping, but lookup worked.

The solution was the upstream device was filtering oversized ping requests - turned that off and the peplink was happy. It seemed the peplink is sending odd sized pings in its health check. Edit: it sends a 98 byte packet, where as a std windows ping is 70 bytes.

Ross H.


#15

Hootan,

Like Tim from your company has said, I am starting over with this setup.

Thanks for the reply. So, if I continue to use drop-in mode, I need to attach the following devices:
A.A.A.130 - DNS1
A.A.A.132 - Mikrotik doing DHCP (all private IPs) and routing to other PCs.
A.A.A.129 - Gateway Cisco router to ATT

To either the LAN side of the Peplink, or to my network switch and then connect the switch to Peplink LAN or Peplink WAN1?

Or do I connect the Cisco Gateway router to WAN1 and the others to the LAN ports?

Then, do I need to put each of these IPs in the other hosts on WAN list?

If I continue to experience the DNS health check on WAN1 - do I need to enter my own DNS IPs (A.A.A.130) in the Peplink or ATTs upstream DNS IPs?

As for my Mikrotik, it is delivering web sites/web content to all computers that are attached to it, so it is working correctly in my environment without the Peplink.


#16

Dear Legoman,

first of all I’m not a Peplink employee, just have more than 2 years experience on selling and supporting Peplink devices.
by the way, we have many clients that using Mikrotik for their network and it has some kind of trick to configure along with Peplink in Drop-in mode.

A solution to diagnose such kind of problems is configuring all WANs on the Peplink and when they get alive connect a laptop to the Peplink in Drop-in mode and see if you can have all the availale bandwidth from all WAN ports. if it worked the Peplink is doing it’s job fine. the next step is to diagnose the connection between Peplink and Mikrotik on the LAN side. I know that Mikrotik is not a friendly configured device like Peplink and yo have to put everything manually and it has many tricks to get worked.

you have a Cisco gateway on WAN1 and this is the correct configuration, so if you have problems related to health checking, I would recommend that disable health checking by DNS and set the health check setting to Ping and specify your Cisco gateway to see if WAN1 can see it’s gateway or not, after your WAN gets connected please go the the System tab on the Peplink and use the ping utility or trace to a public DNS server like 4.2.2.4 or 8.8.8.8 and see what’s the result.
other servers and services like private DNS server / Mikrotik / Accounting / Cache , etc. should be connected to the Peplink’s LAN side either directly on by another switch, it doesn’t matter. if you’re going to set Public IP addresses it should be working and accessible from outside your network because in Drop-in mode everything would be routed. if you’re using private addressing you have to create port forwarding or NAT mapping on both Peplink and Mikrotik.
I saw many scenarios which Peplink is working great without Mikrotik and vice versa , Mikrotik working great without Peplink. I have to make you sure that this is not the Peplink fault nor Mikrotik fault. both of them are kind of routers, so you have to find a way to create a route between them. either through static routing , NATing or port forwarding , it’s up yo you and your configuration. just be noted that in Drop-in mode the gateway on the Mikrotik should not be set to the IP address of the Peplink, in Drop-in mode it should be set to the IP address of the gatewat on your WAN1 ( Cisco router ) and Peplink will capture the traffic in the middle.


#17

OK, perhaps this is the cause of all my problems:

My DNS is running Simple-DNS on Windows XP. It is A.A.A.130. I have not looked at it before, didn’t think it was causing/having problems.

Well, I am getting an IP conflict notice on it. It is using its own IP, not one that is assigned somewhere else.

Any suggestions?


#18

OK, I got both WAN interfaces to show connected. I have my Cisco router connected to the WAN1 port. All other device attached to the LAN ports (DNS, Mikrotik,etc). From the Peplink, I can ping the Cisco router fine, but cannot ping any device on the LAN side of the Peplink. I get destination unreachable.

I have tested all kinds of configs in the Peplink setup, but have not been able to ping any other device except my gateway Cisco router. Why is that?

Still need some help here.


#19

Hi , I think you have routing problems.
could you please draw and upload your network diagram and IP addressing, maybe I could help you :slight_smile:


#20

Yes:

Cisco 2821 on A.A.A.129--------Peplink WAN1 in drop-in mode-A.A.A.135---------LAN-Ports-on-Peplink-----DNS1(Simple-DNS)A.A.A.130,Mikrotik-A.A.A.132

WAN2 = Suddenlink cable modem - DHCP assigned IP.

From the Mikrotik-2 other Lan ports----one is 192.168.100.1 for my office PC network (using private DHCP)
Other port is 10.90.90.1 - A point-to-point wireless system to my service tower (using private DHCP)

Everything runs perfectly without the Peplink in the mix.

Thank you very much for help thus far.