First time setup - please help me

Okay , I think you have to create two static routes on the Peplink :

one : for destination network : MASK and Gateway for the routing between Peplink <==> Mikrotik <==> Office Network
two : for destination network : MASK 255.255.255.X and Gateway for routing between Peplink <==> Mikrotik <==> Service Tower

Also Mikrotik should be configured properly to route packets between Peplink and ether(s).
let’s try it and let me know the results.


OK, I received your post via E-mail but it has not shown up here yet.

I will give that a try. But can you tell me why I cannot ping anything on the Peplink LAN where all my devices are attached?

This is because you have different subnets behind the Peplink and Mikrotik and Peplink is in Drop-in mode. so you have to create static routes :slight_smile:

When I try to put those static routes in the Peplink, I get this message: “Gateway is not within the local network”

Please give me a call at 650-450-9668

Please keep the forum updated if this issue resolved.:slight_smile:


I thought since the Peplink is in drop-in mode, all systems in the same IP range are able to communicate with each other, even if one is on the WAN side and some on the LAN side. Isn’t that correct? That is how I am configured…

Issue resolved. The IP address of the Microtik was defined under the “Additional Hosts on this WAN segment”. This is actually reserved for devices on the WAN side, in front of the Peplink Balance. Once removed and everything rebooted to clear the ARP tables, traffic is flowing great across both links. :slight_smile:

We also changed the DNS servers to the ISP provided ones for the health check settings and changed the outbound policy to “Managed by Custom Rules”.

After observing for about an hour, there was around 2GB of traffic passed that seemed perfectly “Balanced” with 2/3’s of the traffic going across the 15Mbps line and the other third going across the 5Mbps line.

I strongly recommend upgrading to a more powerful model though, the older Balance 200 model is not sufficient for a network with over 200 users…


Wow, the “Additional Hosts on this WAN segment” should not be configured for this scenario. Thanks Tim :slight_smile:

Tim. thanks so much for your help. It seems to be running rather smoothly…

One concern, still, though - the Peplink is configured to use only my upstream DNS servers, and not my own. My two DNS servers are in the same public IP block, and connected to the LAN side of the Peplink. I still cannot ping either one of them from the Peplink.

I currently have a PC also attached to the Peplink on the LAN side configured within the same public IP block. I can ping all machines with it - the Peplink, DNS1, Cisco router, and the Mikrotik.

I really want to make sure this will function before I purchase the 310 or the 380. I have my own DNS servers in house to cut down on requests and make my service faster.

Thanks again.


Hi ,
In my opinion it’s better to always point Peplink to public DNS servers like & for better health checking and to prevent DNS inconsistency.
also you can turn ON the DNS caching feature on the Peplink , I’m not sure if Peplink 200 supports DNS caching or not.
if you insist to use your local DNS server it’s better to make a forwarder for it and point to the Peplink , so your local DNS server could cache lookups and will give a better response for internal clients.

Hootan, it seems DNS has been my whole issue all along.
It ran great for a few hours like Tim helped me set it. Then, web sites started not-resolving. At first it was just a few, then a lot of them did not come up.

So, do I put Google DNS (or any other public DNS) on both WAN ports or just one?

Also, how far down the line do I go putting public DNS in other servers? Do I put it in my Cisco Gateway router, my Mikrotik, etc…

I have found that the Google DNS servers and work excellent. Try putting those in for each WAN port, you should not need to put them anywhere else.

I have been trying that since your last post. As I said before, some sites will come up, but most will not. Nothing else has changed on the configuration, other then me putting Google DNS on both WANs.

Please turn on the WAN administration again and I will log in and take a look

Tim, I currently have my Cisco gateway in its normal setup, bypassing the Peplink, just so I could get service to my customers again. Give me about ten minutes, and I will have the admin open again…E-mail is the best way to reach me right now…

Sounds good, I still have the IP/credentials.

I really think we are overdriving this unit with that many users. As you know, we will give you top dollar trade-in value and you could have a nice Balance 380 in your hands tomorrow morning :smiley:
Your network will purr…