Firmware 8.2.0 RC 2

We would like to announce that Firmware 8.2.0 RC 2 is now available.

Supported models:
X Series, Balance, MAX, MediaFast, FusionHub, UBR, SpeedFusion Engine, Surf SOHO
Download Release Notes
Download the Firmware


OpenVPN over WAN outbound rules are working in this version.

Is there any plan to update the Content Filtering Database?


AT&T Mobley issue is resolved. I changed to my other AT&T SIM which is a recently subscribed Prepaid 5G SIM and it’s taking over 5 minutes to connect to. I tried setting APN to “broadband” as well as letting it set it automatically. Very very slow to connect to this SIM in a big city area (Charleston, SC).

is DPI reporting working for the Balance 20X, it was broken in RC1 ?, I just got No Data.

I came to this beta to try and resolve an issue, the issue I’m experiencing remains in RC1 and RC2.

I am using 2 x Pepwave BR1 Pro 5G routers. The two routers are ethernet connected via Router 1 WAN connected to Router 2 LAN.

Router 2 is providing the Internet connectivity via cellular WAN

My computer is connected via ethernet cable to Router 1 which is the main router doing the routing (DHCP, etc.) as all devices connect to router 1 via cable or wi-fi.

When my computer has Wi-Fi disable to ensure all traffic to Router 1 is over the cable, downloads fail “network error” about 10-50 MB into a 500 MB download.

If I connect my computer to Router 2’s LAN port, the download succeeds.

If I connect my computer to Router 1 using Wi-Fi, which is still connecting to Router 2 via ethernet, download succeeds.

If my setup remains purely ethernet, no Wi-Fi, downloads fail.

Pretty much an out of the box setup on both Pepwave BR1 Pro 5G routers. on Router 1, on Router 2.

Again, all works fine when connecting to Router 1 using Wi-Fi. Trying to use a pure cabled network for maximum speeds such as to my NAS, the network is unstable.

Any ideas as to why?

Tried it again and it connected fine, as expected to the 5G sim.

Odd, anyone else seeing this after loading RC firmware? It’s asking for a new activation key for SpeedFusion even though it isn’t expired yet.

@NealC Why not follow up to the other thread you already started on this topic where suggestions were given? No sense in rehashing everything in multiple places. Did you check into the troubleshooting suggestions? check ethernet stats on support page? replace ethernet cabling?,… etc

I must not be subscribed to that thread as I didn’t get notifications of replies @erickufrin - I’ll check that now. But I wanted to report this to Peplink in this RC as it may be a bug. I’ve been working with as well who is also stumped and took reports from both units to send to Peplink for review. I couldn’t even download the Report from Router 2 when connected to Ethernet, I had to connect to Router 1 via Wi-Fi in order to download the system report from Router 2.

Product Model: Peplink Balance 305
Hardware Revision: 2
Firmware Version: 8.2.0 build 5097

We’ve been experiencing problems with OpenVPN using Local User Accounts in all 8.2 releases so far. After a period of several hours following a reboot, all users get a “User authentication failed” error when trying to connect. A reboot gets it working again, but for less than a day.

Be smart, switch to Wiregaurd…

Installed on BR1 Mini, up and running.

With regard to WAN latency: RC2 reports 2000ms whereas 8.1.3 reports 8ms for the same network. Since response time from a user point of view is pretty good, I think 8.1.3 is probably correct. The router is a SURF SOHO MK3.

I am seeing increased latency on 8.2.0 RC2 in a B20X when compared to 8.1.3.

8.2.0 RC2


downloaded to Mini version 1 and pro 5g. Resolved cellular network connection and handshake issues. 2.4ghz wifi still working on pro 5g. Speeds were impressive on the pro 5G, the mini on the other hand will get repurposed to a paper weight most likely. Also ability to select channels/bands for LTE 5G will be helpful in rural locations

1 Like

I replaced the ethernet cable connecting router 1 and router 2 and the problem remains, it’s not the cable.

I am facing issues with Apple devices and other smart home devices interconnection since 2. beta on my Balance One. The problems occur in the same LANs but also in inter Vlan connection. Examples:
Homepods don‘t find each other in same LAN, Apple Automations with e.g. Tado heating control (in Vlan) and Eve Window guard do not work. Setting fw back to last GA version removes the issues.

Can we get a toggle for 2 antenna vs 4 antenna in the modem properties? that would be awesome

@jgsieve - toggle what? Just attach 2 instead of 4 if thats what you want. What would the toggle actually do?

disable the unused leads. there are commands for each modems firmware, so it’s not useless.