Dynamic DNS no-ip not working. Internal Error

I have been unsuccessful to set up dynamic dns update feature.
The same error arises with both no-ip.com and dyndns.org
Device Event log lists:

DDNS: Domain —deleted for privacy ---- update failed for WAN 1. Internal error.

Same error on two routers (Balance One and 30LTE) both running 8.0.2
Any leads on how to debug? (authentication credentials are correct for both services, and pwds do not contain special characters)

First thing I’d do is try it with another device using the same credentials – perhaps using a Windoze computer using no-ip’s DUC utility. Does that work?
If that works you may want to file a ticket on this if you are certain your credentials are correct. I can tell you we have quite a number of routers, including the two you mention, also using 8.0.2, and no-ip.com. All working fine.

1 Like

And confirm that your hostname can successfully receive an update.
See Step 5 in this article.

1 Like

No-IP DUC utility updates correctly using the same credentials.
I am certain credentials are correct.
Called No-IP customer service, they say that from their side they see router attempting to connect at an unusually high frequency. They estimated at least 1 attempt per second. They said that at that rate their system is going to automatically block updates. They suggested using DUC or lowering the update rate of my “devices”…
Created also an account with dyndns.org to see if the provider made a difference. Correct credentials, failure to update, same error message on peplink logs.
It seems that two peplinik routers running 8.0.2, located in different parts of the world, but using a very similar configuration, when using dynamic DNS update with no-ip AND dyndsns.org, are unsuccessful, produce an error message and the dynamic dns service see an inordinate frequency of connection attempts probably leading to the feature’s failure to work.

Well, it appears you’ve been diligent in troubleshooting this issue. I’d suggest you may want to enter a ticket on this. If you do so please let us know the outcome. This is something we’ve not seen before.

The use of DUC was useful to test but would obviously have limited use in a multi-WAN environment unless the device on which it runs was directed via OBP to only use a single WAN.

Let us know what you find, please.

1 Like

Hello @petreanu,
Are you using InControl2? I you are, see if you can use the “Find My Peplink Address” service for the devices, this will help verify if a known DDNS service works.

Happy to Help,
Marcus :slight_smile: