Dropbox, BOX, & Safari Strangely Blocked Until Reboot

I just got my Pepwave Max transit duo hooked up and at first glance, it is totally awesome. But when I connected my laptop to it, I noticed that some things were not working. Among those items are the following: Safari, Dropbox, Box I did not notice this initially because I first connected and tried to RDP and TeamViewer to a few servers across the internet and it worked successfully, and continues to work. I have tried this with 2 different laptops and an iPhone all with the same results. The laptop can ping google .com, Dropbox .com, and box .com, but the applications are not working. And even though I can ping these URL’s and they resolve successfully, I can not browse to any of them either. Now what is interesting if that if I reboot the Pepwave, then EVERYTHING works and I can access the internet with no issues.

A little background on my cellular plan…. It is an unlimited plan with AT&T that I have had for a long time. That said, the SIM has been in a different LTE router for some time with no issues other than having to reboot the device about twice a day. Hence the reason for buying the Pepwave unit. When it would have issues, it would just stop passing all traffic and would require a reboot to revive it.

With my new device, everything works perfectly when it first boots up. All applications work with no issues. After an undetermined amount of hours (usually overnight), I have to reboot the unit to get Dropbox, Box, & Safari to work again, along with a few other applications like basic web browsing. However, Teamviewer and VPN functions remain unaffected and fully functional. This does not seem like something that my plan would randomly block, and then suddenly unblock because I rebooted my device locally.

I am network savvy, but not knowing the new hardware very well yet, I am not sure the best way to troubleshoot it. I reached out to my vendor, and they referred me to these forums.

Thoughts anyone? Please help…

I am also have a problem like this with the HD4s 8.1.0 build 4943. Started a few weeks ago, maybe after this firmware build, but after overnight or a few hours all of sudden no web traffic will flow until a reboot. After it works fine again. I can ping and trace through the device but no web sites can load for any of the users behind the unit. They can however connect to VPNs trough the system and it works.

I can still VPN as well which is why I missed it initially. My company passes all traffic through the VPN when connected. I rebooted mine after an update to 8.1.0 Build 4943 and then choose to start it up running the proviso version 8.0.2 Build 4407 and I still have the same issue. I just ordered a brand new hotspot line from AT&T to try in it since I can return it within 14 days and cancel the line if I want. I should have the new SIM in a few days and will be able to test it further and see how it works. I can report back my findings once I test.

I got this back from peplink today

Are you using AT&T? They’ve been seeing this issue for a while now. http and https traffic stops passing, but other traffic types will still pass effectively which is why the VPN connections continue to work and the router doesn’t show any failed health checks. There’s a forum thread about this on Peplink’s site as well as one we’ve found on AT&T’s site. The issue is not specific to Peplink, or even to routers. There are reports of phones and other client devices seeing the same issue as well.
This sounds like what you’re experiencing on first reaction. If it is, Peplink has been asking that anyone seeing the issue log a ticket with AT&T in order to help show the breadth of the issue and get things addressed.

Very interesting! Yes I am on AT&T and I have been experiencing this for a few months now. I went Pepwave because of this issue… Ugh… But I’m loving my MaxTransit Duo! :slight_smile:

@sitloongs had a suggestion (his #1) in the other thread that you may want to try out: Route all through SpeedFusion. E.g., set up a trial SpeedFusion cloud and route all HTTP[S] traffic through that VPN. Additional approaches have been reported in AT&T problem solutions summary

Good luck


1 Like

Last night, I stumbled across the setting: System, Time, Time Sync. In a former life, I have experienced issues with wireless services when tower-to-client times were not close enough in sync with each other. Knowing that some towers use GPS for their clock time, I changed the setting from “Time Server” to “GPS with Time Server as Fallback” to see what it would do. Now strangely enough, I have not had a single AT&T disconnect like I experienced before since I changed that setting and rebooted the unit. Previously, if the unit made it an hour without having any of the AT&T proxy issues (as @Solonor pointed out) it was a good day, or hour. It’s been going 24hours now without a single hiccup. Fingers crossed it keeps working fine. Thought I’d share… :slight_smile:

1 Like

UPDATE: I have been using this setting for about a week with zero outages thus far. Maybe we found a possible fix/workaround…? I’m happy with the results for sure! :slight_smile:

Interesting but I am not sure what GPS would have to do with the AT&T proxy server stopping passing traffic?

It wouldn’t be the first time I have experienced traffic issues between a client and a server or proxy of some kind that was caused by the time stamp being off by more than a second or two. I work daily with an application that relies heavily on accurate time between the client and the server. If the time is off by more than 2000ms, it will throw errors. So originally I was leaving the network to go to the internet to get NTP. By using GPS, which is what most tower sites use usually, both my pep wave (client) and the tower and quite possibly the proxy system likely use GPS to maintain the correct time. I’m just saying that it is a possibility, and I’ve ran into it before. Knock on wood… Mine is still working after several months of headaches.

if this is the case, then i wonder if some fix or workaround can be instituted on the Peplink firmware without having to install the external GPS antenna?

Interesting thought… I’m not sure how you could get time from GPS without using the GPS antenna though… At the least, maybe you could hook it up and put it net to the window to see if it can receive a signal enough to get the time just to see if it helps.

i dont know enough about how it works but i was thinking some sort of automatic detection something might not be in sync, or manual offset, or something that keeps the proxy from timing out / rejecting traffic? or leverage a time server / keep the time in sync on the peplink device at a more regular interval? just throwing random ideas out.

:man_shrugging: Maybe…