Do I need to grant access for devices like temperature sensors and smoke alarms to allow them to join the Wi-Fi created by my Max transit 5G?

I’m having issues adding Wi-Fi devices like my temperature sensor and first alert one link smoke alarm and so I’m wondering if there is some level of permission needed to add this device to my pepwave Max Transit 5G‘s Wi-Fi.

During the setup process for temp sensor and onelink smoke alarm they both fail to join the Wi-Fi. My Victron Cerbo GX (solar electrical component) is able to join the Wi-Fi with no problems.

and just for the record the Wi-Fi itself is working great and I use it daily for my computer, phone, and tablet.


@ThirdEyeSamuel ,

May I know did you try before to create a new SSID using lower security setting will those devices able to get connected ? We do see some common issue that some old IOT device may not able to supporting latest security settings.

1 Like

Thank you for the quick reply.

I am still not able to connect either my temperature sensor or my smoke alarm and I’ve created a new SSID with No Encryption.

@ThirdEyeSamuel ,

Please submit a ticket here and allow support team to check for the connection logs.

Please make sure you attach a diagnostic report in the ticket and provide the MAC address for the device that having issue to connect.

Steps to obtain a diagnostic report from the device can be found using the following URL:

Things you can check as well to isolate the issue :

  1. Make sure country setting is correctly configured based on your location.

  2. Use a static channel 1 and verify whether it will help those device to connect:


You might also want to try using only 2.4 Ghz or creating a new SSID with only 2.4 Ghz. Some devices (including many IoT devices) don’t work on 5 Ghz.


Thanks GR7, I’ll give this a test early this week when I am ready to revisit this.

Hello Samual,
Some of our customers have a range of devices that only work on the lower 5Ghz and 2.4Ghz spectrum with 20Mhz width slots. As mentioned by other contributors here, it may be a good place to start by turning off the auto channel, changing the frequencies used, and setting the bandwidth on 20Mhz for both 5Ghz and 2.4Ghz.
Happy to Help,
Marcus :slight_smile: