DDNS config problem


#1

I have been trying to get DDNS working to update a host using dnsomatic or custom and not had any success. The DDNS provider that I am currently working with is NameCheap. The error that is reported is “Authentication Error”. It also reports the same error when I try and use dnsomatic for a single host … it does however work if I tell it to use the all.dnsomatic.com host which updates everything on the account. Things that I have noticed:
-the url field actually seems to want a server not really a url because if you supply a properly formated url the GUI will not allow you to save it.
-the host field seems to want a fqdn and will not permit you to use a host unless it contains a “.”. To get around this I made my host in a subdomain so that it would have a dot (ex. pep1.NYC, and pep2.LAX).

I would really appreciate if someone could let me know the key to getting this to work correctly.

Thanks
David


#2

Look like NameCheap URL update is using HTTPS that should not work for Peplink Dynamic DNS settings (HTTP).

https://www.namecheap.com/support/knowledgebase/article.aspx/29/11/how-do-i-use-a-browser-to-dynamically-update-the-hosts-ip

We would suggest to use Peplink IC2 Cloud Find My Peplink Service.


#3

@sitloongs Thanks for the quick reply! … I think that I tried it with http also but will verify. Assuming that I am hitting the https issue with the custom URL can you let me know how to get the dnsomatic to work properly for a single host.

Thanks
David


#4

@sitloongs … I just retested it and Namecheap works fine with simple HTTP (HTTPS is obviously preferred but not required). So the issue is not that it requires HTTPS. Knowing that how can we debug the issue and resolve it?

Thanks,
David


#5

@sitloongs After re-reading the “Find My Peplink” details … it might work for our needs. I will investigate it further as a possible solution if we cant get ddns updates working directly.

Thanks,
David.


#6

We will suggest you to use Peplink IC2 Cloud Find My Peplink Service as different Public DDNS server having different URL entries that may not work well with default Dynamic DNS Settings.

If you need to further check on the issue for your DDNS settings, please open a support ticket here for support team to check.