Cannot Achieve Gigabit Throughput on WAN / Balance One


#1

I cannot get gigabit (or near it) throughput on WAN -> LAN on the Balance One. I suspect this is related to use of PPPoE and VLAN tags (both of which are required for my ISP), but not sure.

Has anyone solved this problem before?

Here are the details:

WAN1:

  • CenturyLink fiber, 1Gb symmetrical
  • Balance One connected to the ONT (optical terminator) directly via RJ45
  • PPPoE enabled
  • VLAN enabled, ID=201

WAN2:

  • Comcast, 50/10Mb
  • Balance One connected to Motorola modem
  • DHCP enabled

No USB attached

The issue all comes down to speed. With WAN1 connected and WAN2 manually disconnected, the best throughput I can get on a desktop PC attached to local LAN ports is ~323Mb down / ~ 323Mb up.

When put the centurylink action tech C2000 router between the ONT and my desktop PC, I can get 900Mb/900Mb.

It feels like either vlan tagging or pppoe consumes all of the CPU on the balance one.


#2

Update:

I connected the peplink as a child of the CenturyLink-provided consumer router. After removing PPPoE and VLAN tagging, throughput is up to 550-560Mbps down / 700mbps up.

I notice that when doing the download speed test, the CPU is hitting 100% utilization.

It would be interesting to know if anyone has achieved 900Mbps+ through the peplink WAN connection. Right now, I am guessing the Balance one isn’t cut out for gigabit throughput from WAN.


#3

Interesting feedback. I have a Balance One on order and have an 800Mbps-1Gbps link here at home that I will test with. I have existing solutions that can get to around 800Mbps but are lacking the other features that the Balance One has.

I posted questions about overall throughput at https://forum.peplink.com/threads/4806-Balance-One-Throughput and was assured that the product can achieve 1Gbps.

I will post my test later tomorrow or Thursday.


#4

I’m only able to get about 400Mbps download and 250Mbps upload with the Balance One. With a competitors product, default settings, or a laptop directly connected, I would get 700Mbps down and 600Mbps up.

Clearly there’s something not optimized, or the claims that the Balance One can do 1Gbps are false.

I’d love guidance on how the 1Gbps numbers were achieved - jumbo frames, firewall turned off, etc. as I require the higher bandwidth for my setup, and will be forced to return the Balance One without this :frowning:


#5

Hi,

  1. May I know which firmware version you are tested with?

  2. You tested with factory default settings?


#6
  1. I am running 6.2.0 build 1847

  2. Mostly factory default - I configured various basic IP and DHCP settings. I haven’t changed anything in the firewall or any other areas that aren’t cosmetic as far as I know.

Thanks!


#7

Hi, I have several questions would like to ask:

  1. What is your throughput testing tool or testing website? If you are using a tool, what is the command used to test the performance?
  2. What is your ISP, and in which country?
  3. Here I have a beta firmware (6.2.1s011), integrated with some performance tweaks, could you please give it a try, and let us know your throughput test result? (If possible, please test the throughput for at least 3 times)

Firmware 6.2.1s011 download link (NOTE This is a beta firmware built for testing purpose, do not use it in production sites):
http://download.peplink.com/firmware/plb1/fw-b1_210hw4_310hw4_hd2mini_hd4-6.2.1s011-build1973.bin


#8

Hi Steve,

  1. Speedtest.net is my primary tool, but I also transfer large files to and from a Linux system exposed on the Internet, and have used iPerf. Speedtest.net has 5 servers within 10ms of my location, and I am able to achieve 600-800Mbps reliably without the Balance One in place, so I tend to use that 99% of the time.

  2. ISP is CascadeLink, which is in Seattle, WA, USA. They are a local Gigabit provider.

  3. Downloaded and installed beta firmware. Ran test six times with an average of 400Mbps download, and 300Mbps upload. The highest I got during this test was about 450Mbps download, and 330Mbps upload. It seems to have increased a little, but not much.

Other things I noticed/am doing:

CPU utilization on the Balance one is 85-90% during these tests. Seems like there is a bottleneck.
Tests are being run from a wired host directly connected to the Balance One. I can connect this wired host directly to the ISP and get 700Mbps.
Balance One has an AP One AC Mini connected to it - internal radio is shut off.


#9

One other particularly concerning side effect:

When I am doing these tests, all of my PPTP VPN connections are severed. Generally during the upload test. I’ve repeated this behavior about 5 times, where remote clients via PPTP are completely disconnected during the test, and have to disconnect and reconnect.

Again, the CPU is at high levels (90% plus) so it seems like there is a bottleneck elsewhere that is preventing the 1Gbps rate.


#10

Hi,

Please download Diagnostic Report during CPU spikes to 90% when you do the throughput test. Please help to open ticket and submit diagnostic report to us.

Thank you.


#11

Done! Ticket #752295


#12

400Mbps download is really slow and not expected. For me, I’m using myspeedmeter.net which can provide 1Gbps throughput in Hong Kong, the test result below is from the Balance One (6.2.1s011) in my home, ISP is Netvigator and I can get > 800Mbps download throughput without problem. We will investigate further and see if there is any special case overlooked and give a degraded throughput test result.

  1. Could you please help to do the test with 6.2.1s011 again, using factory default settings? You can backup the existing config first, and restore it after the test.
  2. Apart from speedtest.net, could you also test with myspeedmeter.net? Actually both of them are maintained by the company Ookla, but myspeedmeter.net has faster server as far as I know, it has a test server in Los Angeles and I hope this can provide good enough throughput for you in Seattle.
  3. I can see you have submitted support ticket but looks like there is no diagnostic report attached, could you please send it again? Thank you.



#13
  1. Could you please also have a check on the cable (The cable connected your PC to the LAN port of Balance One, and the cable connected Balance One WAN to internet)? Are they Cat.5e or Cat.6?

#14

I’ve used myspeedmeter.net and get the same results.

  1. I will have to do this later today, as there are people using the system, and resetting to factory defaults will cause a big interruption.
  2. Already have, same results.
  3. Responded to RT ticket email and attached diagnostic reports. Please let me know if you don’t get them.

#15

This same cable has been used with a standalone machine, and a competitors product and can get ~700-800Mbps. Nothing wrong with the cable AFAIK.


#16

I’ve reset to factory defaults and re-tested without making any changes. Same result - about 400Mbps download, and 300Mbps upload.

I’m reconfiguring everything back the way it was.

Still seeing 90-95% CPU usage during either test, so it’s clear that something is going on within the Balance One.


#17

Thank you for sharing test firmware.

I applied to my configuration and am seeing the same 320-330Mbps download speeds, but more like 550Mbps upload speeds. During download testing, the CPU is still hitting 99%.

I have to believe this is related to processing of pppoe and/or vlan tagging in my configuration. Both are required for my ISP.

The competitor product I am using is an edgerouter lite (ERL-3). It has specific pppoe and vlan offloads which make a significant speed difference. With the offloads disabled, I am achieving ~125Mbps/125Mbps. With the offloads enabled, I achieve 700Mbps down and 930Mbps up.

I greatly prefer the management interface of the peplink.


#18

I am using the edge router lite as well, but I do not have PPoE or VLAN tags with my ISP. Raw 1Gbps ethernet link directly from their switch.

The edge router lite gets 800Mbps down and 600-700Mbps up.

I agree, I prefer the management and features of the Peplink over Ubiquiti. I have a large deployment of Ubiquiti systems that I plan on replacing with Peplink/Pepwave, but I absolutely have to have better performance than what I’m seeing.


#19

Hi,

Engineering team is looking into the problem now. We shall provide the update asap. Stay tuned.


#20

Hi guys,

We are still investigating on this issue and have made some changes. Could you please give this firmware a try? (Using iperf/nuttcp and myspeedmeter.net / etc.)

Firmware 6.2.1s022 download link (NOTE This is a beta firmware built for testing purpose, do not use it in production sites):
http://download.peplink.com/firmware/plb1/fw-b1_210hw4_310hw4_hd2mini_hd4-6.2.1s022-build2004.bin

  1. We have found some PCs may have degraded network performance if they have enabled Jumbo Frames, could you please help to verify and disable Jumbo Frames before doing the test? Thanks.

  2. The firmware 6.2.1s022 is being built based on the latest public RC firmware (http://www.peplink.com/open-beta-program/), if you get a chance, could you please also compare the performance difference of 6.2.1 RC and 6.2.1s022?

  3. Would you please let us know what is your testing machine specification (the device that connect directly to Balance One’s LAN port), and the model of the network chipset, I hope we could reproduce your problem in our testing lab.

Thank you very much for your help :slight_smile: