BufferBloat


#1

Does the peplink balance firmware currently do anything to fight bufferbloat?


#2

Hi,

Basically bufferbloat is causing long latency and low throughput in a WAN link. Peplink is constantly working on smart technologies such as WAN health checks and “latency cut off” in SpeedFusion to tackle such WAN problems.


#3

Got another firmware update today, still seeing about 400ms of bufferbloat… Been 4 years since my initial question, I guess the answer is no nothing is being done about buffer bloat.


Single Youtube upload killing Internet traffic
#4

If you go to the support.cgi page you can manually adjust the WAN buffer size http://balanceipaddress/cgi-bin/MANGA/support.cgi



#5

looking good now! Set the buffer to 500 and I’m getting my max bandwidth with about 6ms of buffer bloat.


#6

Thanks for the update. I’m curious about what type of connection this is and how much of an impact did this change make?


#7

high latency makes all the difference when doing things like online video/voice calls or online video games.

Connection is Xfinity (100mbps up 10mbps down) and Uverse backup(20mbps down 2mbps up)
Also I have a constant 4mbps - 8 mbps up stream of security camera recordings going out to amazon.

In game ping times show a drop from an average of 60ms down to 23ms.


#8

Testing this feature: I had one test where I got just about the same as MikesToolz: went from 400/20 speed with 150msec of bloat (at default settings) to about 300/20 speeds with under 10msec of bloat (at 500 packet buffer size). But then I did some more tests and got weird results - it almost feels like the UI is not updating properly: I would set it to Default (2000) and get the good results, then change it back to 500 and get the bad results.

How long after clicking the Save button does this setting take effect? Do we need to reboot the router after clicking Save?

I’m testing on a Balance One with 6.3.2.


#9

@soylentgreen

You are right , there is some WebUI display issue for the experimental feature when setting up the “WAN Connection Buffer Size”. The saved custom buffer size settings did not actually apply to the device until you have apply a new changes to the device. This will be fix targeted for firmware 7.0.1 or above.

Temporary workaround to use the “WAN Connection Buffer Size” experimental feature:

  1. In support.cgi page setting up the custom buffer size for the WANs and save the settings.

  2. After that, please simply make a changes for other settings and apply the changes to the device. This will actually apply the buffer size settings together with the new changes to the device.

Suggestion to trigger the apply changes:

  • System --> Admin security —> Save (Click save) then Apply Changes button will shown at the right hand top corner
  • Click Apply Changes and the buffer Size setting will apply to the device.

P/S:
After applied the changes, the Buffers Size settings will immediate take effect.


#10

Reading here:

https://www.internetsociety.org/blog/tech-matters/2015/04/measure-your-bufferbloat-new-browser-based-tool-dslreports

The author suggests the following:

Armed with that knowledge I tweaked the router configuration (by shaping upstream and downstream bandwidth to be just below the connection bandwidth, thereby enabling the queue management technology in the router to have an effect) and now have a much better looking set of test results.

Would this work on a Balance 50?


#11

set all 4 WANs and 2 mbps below max speed and as you can see Bufferbloat remains a problem so it appears the WAN speed setting of firmware 7.0 does not include some form of que management.

test results are from:

http://www.dslreports.com/speedtest


#12

I got much better results on bufferbloat by using QoS settings at 70% for managers

Strangely with exactly the same settings and my other devices not active I can get failing bufferbloat sometimes (not usual). I don’t know what would cause such variability.


#13

Doc, can you say how you set up your QoS settings?


#14

Really only internet use is by managers but I thought, perhaps, limiting
bandwidth here might increase queue use

The order on these images got messed up in the email response but I’m sure that can be figured out if noted here.

Made all assigned IPs managers

Finally all WAN download speeds were reduced to 80% of max and all WAN
upload speeds were reduced to 70%

I admit this is a pretty draconian reduction in bandwidth but staring at
bandwidth use during gaming showed I seldom really got above 8mbps so the
lag, pauses and etc that show up in game
seem to have been BufferBloat. Now I can play the game with much less slow
down during intense activity…when it really matters. I generally get
speedtests now that look like this one I just took:


#15

Yeah, I have very inconsistent test results using DSLReports myself - so for raw speed tests I always try to use my ISPs’ version.

I’m guessing the variability comes because DSLreports picks a (new) set of servers for each test based on ping times?


#16

I have since found that the graphical and numerical display at

https://sourceforge.net/speedtest/?source=sfnet_header

seems a lot more informative

to get the above results I set my max download at 6,8,8.8 max upload at 400, 500, 500, 500 mbps and set bandwidth control for managers at only 20%

This is a huge improvement of BufferBloat.


#17

Well I keep testing bufferbloat and it is all over the board. It SEEMS like the more I test it, no matter what I do, it tends to get better. That makes me suspect that CenturyLink has an “on demand” type of set up whereby frequent testing, using more bandwidth, may temporarily help bufferbloat. As a result, it makes it nearly impossible to test it, as reassuring causes the system to change.

I have learned a few things though…bufferbloat appears to be bad and to be responsible for some if not all of the negative symptoms in my system. This makes me hope that Peplink will come up with some ingenious ways to decrease bufferbloat in future firmware.


#18

Remember that every network device between you and the speedtest also have buffers. The bloat you are seeing may not even be in your control (or Peplinks).

I also spent a couple of hours chasing that dragon. I also found that it was very inconsistent. Heck, even the device running the speedtest has buffers. Have you tried setting the WAN buffer size to something ridiculously small? If you set it to 2 - will bloat still occur? I bet it will.


#19

Yes I have tried settings at tiny numbers to see what happens and lately, not much, The articles I’ve ready on BufferBloat suggest that standard type QoS manipulation will not do the job. What is necessary are specialized algorithms like those of the SQM Lede project to intelligently shape and modify queue. Given such algorithms are in place then making your router the “bottle neck” of internet traffic will allow them to manage the queue, not some buffer out of your control. Here is one such article:

I’ve been exploring whether or not it would be feasible to put a dedicated SQM only Lede firmware appliance between the Peplink and my switch and let it do its magic. I’ll let you know what I find out on this.

In the meantime I’ve been thinking one approach might be to say let one WAN of Peplink handle all outbound traffic and the other three WANs handle all inbound traffic and see if that would make the internet connection less Bloated. Unfortunately on the Balance 50, at any rate, there is no easy way to balance inbound traffic.

With growing awareness of the strong effects of BufferBloat on internet quality it would seem likely that most router companies will be forced to address this issue, particularly when their routers get an F grade. The DD-WRT and Lede Routers can do this now as can IQRV2 Self-Optimizing router with dual band WiFi (AC1750).

I’m sure if Peplink comes up with a fix on BufferBloat it would give them an edge in sales over competitors such as Mushroom Networks and vice versa.


#20

Dude, me and you must be going for the same goal - lag free gaming.

I just purchased a “gaming” router. It supposedly eliminates lag with some kind of proprietary algorithm. They say it is not a derivative of SQM, but we will see.

I have simply not been able to get the VLan stuff to work for my Xbox one. If I put it on a VLan all by itself, then the UPnP port forwarders don’t have any effect on the router. I don’t have any managed switches, so there will be untagged packets on all of my interfaces. The VLan gateway should respond as though it is the internet gateway even when on a VLan. I believe that the XBox puts a TTL of 1 on its PNP packets. So, the request can’t traverse to the LAN IP which seems to be the only subnet that can make such requests.

I haven’t fully thought about how to implement this new router in the chain. i was thinking about letting the new router manage one link and then have a wan to LAN jumper from the Peplink and just double NAT (or maybe get IP forwarding to work) to allow access to the “better” link during non game times. We will see how it goes. I might play with drop in mode, but I haven’t thought it all the way through. Let me know if you figure out anything awesome.