Blocking youtube on Surf SOHO. Chromebook can still access it!

Hi, I’ve blocked using both firewall rules and the content blocking section. When I browse on my iPad, sure enough, is blocked. However, my daughter’s Chromebook can still access! She’s logging in with her ‘managed’ school account so wondering if this has something to do with it? I’ve tried searching but not turned up much, perhaps I’m not using the correct search terms… Anyway, the block is clearly working for me, but not her… Really frustrating so any help appreciated. Screenshots below for clarity.

Firewall rule goes as follows:

Content block as follows:

Any help or advice appreciated. Thanks!

Please see this post and add all the domains:

Thanks Jonathan, I’ll give that a go. However, I should have made it clearer that I’m only aiming to block YouTube on just one device. I could stick /32 exemptions in for my other children’s devices, but then that means they bypass all of the blocked domains, which is not something I wanted. Short of a targeted firewall rule (which means many rules to block each domain you mentioned in your reply, I’m not sure what else I can do.

Another option is to create enforced outbound policies for that specific ip that matches on a domain name and route it to a WAN that has no internet access or a bogus pepvpn connection.
The bogus pepvpn connection I do is ZZZ Block access, ip, , and I leave it disabled.
Then I create an enforced outbound policy for anything that I want to discard the traffic on and move it to the top of the list.

or do as a outbound firewall policy by each domain as well.

Maybe this will work better for your needs.

I guess they would probably both work either way, but currently you would have to create a bunch of rules , I understand not ideal.
Other option is to block all and white list what you want?

Well, I’ve tried with the following firewall rules but no joy I’m afraid (unless I’ve made a mistake)…

Are you able to elaborate on the outbound policies being matched to a route that has no Internet access please? I’m not really sure how to achieve it, or where to start. Sorry for being dumb! Is this something I can do on the Surf SOHO?

If the rules have recently been added , confirm they are on the outbound firewall then reboot the pepwave for it to take effect.